mac80211: fix r21990

SVN-Revision: 21992
This commit is contained in:
Alexandros C. Couloumbis 2010-06-30 15:21:15 +00:00
parent ffa2e4eaec
commit 5c42c43638

View file

@ -1,11 +1,15 @@
--- a/scripts/gen-compat-autoconf.sh --- a/scripts/gen-compat-autoconf.sh
+++ b/scripts/gen-compat-autoconf.sh +++ b/scripts/gen-compat-autoconf.sh
@@ -192,7 +192,7 @@ if [ -f $KLIB_BUILD/Makefile ]; then @@ -191,10 +191,8 @@ if [ -f $KLIB_BUILD/Makefile ]; then
echo CONFIG_NETDEVICES_MULTIQUEUE >> $MULT_DEP_FILE
define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS
rm -f $MULT_DEP_FILE rm -f $MULT_DEP_FILE
# Kernels >= 2.6.32 can disable WEXT :D - # Kernels >= 2.6.32 can disable WEXT :D
- if [ $SUBLEVEL -le 32 ]; then - if [ $SUBLEVEL -le 32 ]; then
+ if [ $SUBLEVEL -le 35 ]; then - define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT - fi
fi + # Up to kernel 2.6.35 we still need the following:
+ define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
fi fi
fi
echo "#endif /* COMPAT_AUTOCONF_INCLUDED */"