iproute2: print help in connmark
SVN-Revision: 36637
This commit is contained in:
parent
d090eea125
commit
5be36cbe83
2 changed files with 5 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=3.7.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
|
||||
|
|
|
@ -10,7 +10,7 @@
|
|||
TCMODULES += p_icmp.o
|
||||
--- /dev/null
|
||||
+++ b/tc/m_connmark.c
|
||||
@@ -0,0 +1,71 @@
|
||||
@@ -0,0 +1,74 @@
|
||||
+/*
|
||||
+ * m_connmark.c Connection tracking marking import
|
||||
+ *
|
||||
|
@ -62,6 +62,9 @@
|
|||
+
|
||||
+ NEXT_ARG();
|
||||
+
|
||||
+ if (matches(*argv, "help") == 0)
|
||||
+ usage();
|
||||
+
|
||||
+ *argc_p = argc;
|
||||
+ *argv_p = argv;
|
||||
+ return 0;
|
||||
|
|
Loading…
Reference in a new issue