kernel: bump 4.9 to 4.9.85
Signed-off-by: Magnus Kroken <mkroken@gmail.com>
This commit is contained in:
parent
45ae5c2de3
commit
5af85dab22
25 changed files with 29 additions and 70 deletions
|
@ -4,12 +4,12 @@ LINUX_RELEASE?=1
|
|||
|
||||
LINUX_VERSION-3.18 = .71
|
||||
LINUX_VERSION-4.4 = .112
|
||||
LINUX_VERSION-4.9 = .82
|
||||
LINUX_VERSION-4.9 = .85
|
||||
LINUX_VERSION-4.14 = .23
|
||||
|
||||
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
|
||||
LINUX_KERNEL_HASH-4.4.112 = 544b42cbeed022896115c76a18fc97b4507d5b41d7ac0ce1dce9afd6ffd11ecd
|
||||
LINUX_KERNEL_HASH-4.9.82 = 4b710b2701daafeb8e4db4c06f0ed3e62a6d20d6213a4927769c89ae42a9b180
|
||||
LINUX_KERNEL_HASH-4.9.85 = 80fe13eee45bd0d5aee6193281dc85dad14500e27d238dc45ebcbcc77cd965c1
|
||||
LINUX_KERNEL_HASH-4.14.23 = 9a97b5555a2baaed9aa7711524ae3b9179579efb902d76a814a916aefe5712ca
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -533,6 +533,12 @@ config SPI_QUP
|
||||
@@ -534,6 +534,12 @@ config SPI_QUP
|
||||
This driver can also be built as a module. If so, the module
|
||||
will be called spi_qup.
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -761,6 +761,13 @@ config SPI_TLE62X0
|
||||
@@ -762,6 +762,13 @@ config SPI_TLE62X0
|
||||
sysfs interface, with each line presented as a kind of GPIO
|
||||
exposing both switch control and diagnostic feedback.
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -768,6 +768,11 @@ config SPI_RB4XX_CPLD
|
||||
@@ -769,6 +769,11 @@ config SPI_RB4XX_CPLD
|
||||
SPI driver for the Xilinx CPLD chip present on the
|
||||
MikroTik RB4xx boards.
|
||||
|
||||
|
|
|
@ -4629,7 +4629,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
|
|||
+module_exit(fsg_cleanup);
|
||||
--- a/drivers/usb/host/Kconfig
|
||||
+++ b/drivers/usb/host/Kconfig
|
||||
@@ -762,6 +762,19 @@ config USB_HWA_HCD
|
||||
@@ -754,6 +754,19 @@ config USB_HWA_HCD
|
||||
To compile this driver a module, choose M here: the module
|
||||
will be called "hwa-hc".
|
||||
|
||||
|
|
|
@ -51,7 +51,7 @@ Tested with raspbian-jessie 2016-09-23.
|
|||
+
|
||||
config ARCH_SUNXI
|
||||
bool "Allwinner sunxi 64-bit SoC Family"
|
||||
select GENERIC_IRQ_CHIP
|
||||
select ARCH_HAS_RESET_CONTROLLER
|
||||
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
||||
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
||||
@@ -1,6 +1,7 @@
|
||||
|
|
|
@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -409,8 +409,8 @@ KERNELRELEASE = $(shell cat include/conf
|
||||
@@ -411,8 +411,8 @@ KERNELRELEASE = $(shell cat include/conf
|
||||
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
||||
|
||||
export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
|
||||
|
|
|
@ -637,7 +637,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
return received;
|
||||
--- a/drivers/net/ethernet/freescale/gianfar.c
|
||||
+++ b/drivers/net/ethernet/freescale/gianfar.c
|
||||
@@ -3186,7 +3186,7 @@ static int gfar_poll_rx_sq(struct napi_s
|
||||
@@ -3193,7 +3193,7 @@ static int gfar_poll_rx_sq(struct napi_s
|
||||
|
||||
if (work_done < budget) {
|
||||
u32 imask;
|
||||
|
@ -646,7 +646,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||
/* Clear the halt bit in RSTAT */
|
||||
gfar_write(®s->rstat, gfargrp->rstat);
|
||||
|
||||
@@ -3275,7 +3275,7 @@ static int gfar_poll_rx(struct napi_stru
|
||||
@@ -3282,7 +3282,7 @@ static int gfar_poll_rx(struct napi_stru
|
||||
|
||||
if (!num_act_queues) {
|
||||
u32 imask;
|
||||
|
|
|
@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -401,7 +401,7 @@ KBUILD_AFLAGS_KERNEL :=
|
||||
@@ -403,7 +403,7 @@ KBUILD_AFLAGS_KERNEL :=
|
||||
KBUILD_CFLAGS_KERNEL :=
|
||||
KBUILD_AFLAGS_MODULE := -DMODULE
|
||||
KBUILD_CFLAGS_MODULE := -DMODULE
|
||||
|
|
|
@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1200,7 +1200,6 @@ all: modules
|
||||
@@ -1202,7 +1202,6 @@ all: modules
|
||||
|
||||
PHONY += modules
|
||||
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
||||
|
@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
@$(kecho) ' Building modules, stage 2.';
|
||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
|
||||
@@ -1230,7 +1229,6 @@ _modinst_:
|
||||
@@ -1232,7 +1231,6 @@ _modinst_:
|
||||
rm -f $(MODLIB)/build ; \
|
||||
ln -s $(CURDIR) $(MODLIB)/build ; \
|
||||
fi
|
||||
|
|
|
@ -21,7 +21,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -404,6 +404,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
|
||||
@@ -406,6 +406,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
|
||||
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
||||
GCC_PLUGINS_CFLAGS :=
|
||||
|
||||
|
@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
||||
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
|
||||
@@ -634,11 +639,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||
@@ -636,11 +641,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
|
||||
KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
|
||||
KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -640,12 +640,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
|
||||
@@ -642,12 +642,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
|
||||
endif
|
||||
|
||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||
|
|
|
@ -47,8 +47,6 @@ Will send separate patches to stable as this file got moved/renamed
|
|||
drivers/pci/host/pcie-designware.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/pci/host/pcie-designware.c b/drivers/pci/host/pcie-designware.c
|
||||
index bf558df5b7b3..2b5470173196 100644
|
||||
--- a/drivers/pci/host/pcie-designware.c
|
||||
+++ b/drivers/pci/host/pcie-designware.c
|
||||
@@ -861,7 +861,7 @@ void dw_pcie_setup_rc(struct pcie_port *
|
||||
|
|
|
@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||
{
|
||||
--- a/lib/Kconfig.debug
|
||||
+++ b/lib/Kconfig.debug
|
||||
@@ -397,6 +397,11 @@ config MAGIC_SYSRQ_DEFAULT_ENABLE
|
||||
@@ -396,6 +396,11 @@ config MAGIC_SYSRQ_DEFAULT_ENABLE
|
||||
This may be set to 1 or 0 to enable or disable them all, or
|
||||
to a bitmask as described in Documentation/sysrq.txt.
|
||||
|
||||
|
|
|
@ -35,7 +35,7 @@ Signed-off-by: Vasudevan Murugesan <vmuruges@codeaurora.org>
|
|||
};
|
||||
|
||||
static int dwc3_of_simple_clk_init(struct dwc3_of_simple *simple, int count)
|
||||
@@ -100,6 +103,20 @@ static int dwc3_of_simple_probe(struct p
|
||||
@@ -102,6 +105,20 @@ static int dwc3_of_simple_probe(struct p
|
||||
if (ret)
|
||||
return ret;
|
||||
|
||||
|
@ -56,7 +56,7 @@ Signed-off-by: Vasudevan Murugesan <vmuruges@codeaurora.org>
|
|||
ret = of_platform_populate(np, NULL, NULL, dev);
|
||||
if (ret) {
|
||||
for (i = 0; i < simple->num_clocks; i++) {
|
||||
@@ -128,6 +145,12 @@ static int dwc3_of_simple_remove(struct
|
||||
@@ -130,6 +147,12 @@ static int dwc3_of_simple_remove(struct
|
||||
clk_put(simple->clks[i]);
|
||||
}
|
||||
|
||||
|
|
|
@ -24,7 +24,7 @@ Changed:
|
|||
|
||||
--- a/drivers/usb/phy/Kconfig
|
||||
+++ b/drivers/usb/phy/Kconfig
|
||||
@@ -194,6 +194,17 @@ config USB_MXS_PHY
|
||||
@@ -195,6 +195,17 @@ config USB_MXS_PHY
|
||||
|
||||
MXS Phy is used by some of the i.MX SoCs, for example imx23/28/6x.
|
||||
|
||||
|
|
|
@ -15,7 +15,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
|
|||
|
||||
--- a/drivers/usb/dwc3/dwc3-of-simple.c
|
||||
+++ b/drivers/usb/dwc3/dwc3-of-simple.c
|
||||
@@ -197,6 +197,7 @@ static const struct dev_pm_ops dwc3_of_s
|
||||
@@ -199,6 +199,7 @@ static const struct dev_pm_ops dwc3_of_s
|
||||
|
||||
static const struct of_device_id of_dwc3_simple_match[] = {
|
||||
{ .compatible = "qcom,dwc3" },
|
||||
|
|
|
@ -65,7 +65,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
|
|||
+};
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -403,6 +403,14 @@ config SPI_NUC900
|
||||
@@ -404,6 +404,14 @@ config SPI_NUC900
|
||||
help
|
||||
SPI driver for Nuvoton NUC900 series ARM SoCs
|
||||
|
||||
|
|
|
@ -2060,7 +2060,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||
}
|
||||
--- a/drivers/pci/quirks.c
|
||||
+++ b/drivers/pci/quirks.c
|
||||
@@ -4642,3 +4642,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
|
||||
@@ -4649,3 +4649,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
|
||||
DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2031, quirk_no_aersid);
|
||||
DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2032, quirk_no_aersid);
|
||||
DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2033, quirk_no_aersid);
|
||||
|
|
|
@ -636,7 +636,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||
|
||||
--- a/drivers/usb/dwc3/gadget.c
|
||||
+++ b/drivers/usb/dwc3/gadget.c
|
||||
@@ -2930,6 +2930,7 @@ static irqreturn_t dwc3_interrupt(int ir
|
||||
@@ -2932,6 +2932,7 @@ static irqreturn_t dwc3_interrupt(int ir
|
||||
int dwc3_gadget_init(struct dwc3 *dwc)
|
||||
{
|
||||
int ret, irq;
|
||||
|
@ -644,7 +644,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
|||
struct platform_device *dwc3_pdev = to_platform_device(dwc->dev);
|
||||
|
||||
irq = platform_get_irq_byname(dwc3_pdev, "peripheral");
|
||||
@@ -3044,6 +3045,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
|
||||
@@ -3046,6 +3047,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
|
||||
goto err5;
|
||||
}
|
||||
|
||||
|
|
|
@ -16,7 +16,7 @@ Acked-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -533,6 +533,12 @@ config SPI_QUP
|
||||
@@ -534,6 +534,12 @@ config SPI_QUP
|
||||
This driver can also be built as a module. If so, the module
|
||||
will be called spi_qup.
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -539,6 +539,12 @@ config SPI_RT2880
|
||||
@@ -540,6 +540,12 @@ config SPI_RT2880
|
||||
help
|
||||
This selects a driver for the Ralink RT288x/RT305x SPI Controller.
|
||||
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
From 900a9020af7a023f9b64c919fddf8a7486108962 Mon Sep 17 00:00:00 2001
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
Date: Tue, 18 Apr 2017 15:55:51 +0200
|
||||
Subject: arm64: sunxi: always enable reset controller
|
||||
|
||||
The sunxi clk driver causes a link error when the reset controller
|
||||
subsystem is disabled:
|
||||
|
||||
drivers/clk/built-in.o: In function `sun4i_ve_clk_setup':
|
||||
:(.init.text+0xd040): undefined reference to `reset_controller_register'
|
||||
drivers/clk/built-in.o: In function `sun4i_a10_display_init':
|
||||
:(.init.text+0xe5e0): undefined reference to `reset_controller_register'
|
||||
drivers/clk/built-in.o: In function `sunxi_usb_clk_setup':
|
||||
:(.init.text+0x10074): undefined reference to `reset_controller_register'
|
||||
|
||||
We already force it to be enabled on arm32 and some other arm64 platforms,
|
||||
but not on arm64/sunxi. This adds the respective Kconfig statements to
|
||||
also select it here.
|
||||
|
||||
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
||||
Acked-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
||||
---
|
||||
arch/arm64/Kconfig.platforms | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
--- a/arch/arm64/Kconfig.platforms
|
||||
+++ b/arch/arm64/Kconfig.platforms
|
||||
@@ -2,9 +2,11 @@ menu "Platform selection"
|
||||
|
||||
config ARCH_SUNXI
|
||||
bool "Allwinner sunxi 64-bit SoC Family"
|
||||
+ select ARCH_HAS_RESET_CONTROLLER
|
||||
select GENERIC_IRQ_CHIP
|
||||
select PINCTRL
|
||||
select PINCTRL_SUN50I_A64
|
||||
+ select RESET_CONTROLLER
|
||||
help
|
||||
This enables support for Allwinner sunxi based SoCs like the A64.
|
||||
|
|
@ -19,7 +19,7 @@ Acked-by: Chen-Yu Tsai <wens@csie.org>
|
|||
|
||||
--- a/drivers/clk/sunxi-ng/Kconfig
|
||||
+++ b/drivers/clk/sunxi-ng/Kconfig
|
||||
@@ -35,17 +35,14 @@ config SUNXI_CCU_NK
|
||||
@@ -36,17 +36,14 @@ config SUNXI_CCU_NK
|
||||
|
||||
config SUNXI_CCU_NKM
|
||||
bool
|
||||
|
|
|
@ -34,7 +34,7 @@ Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
|||
- clocks: phandle to the oscillators feeding the CCU. Two are needed:
|
||||
--- a/drivers/clk/sunxi-ng/Kconfig
|
||||
+++ b/drivers/clk/sunxi-ng/Kconfig
|
||||
@@ -53,6 +53,17 @@ config SUNXI_CCU_MP
|
||||
@@ -54,6 +54,17 @@ config SUNXI_CCU_MP
|
||||
|
||||
# SoC Drivers
|
||||
|
||||
|
|
Loading…
Reference in a new issue