updated layer7 to 2.15.. current is 2.16.1, i might bump again, this has been uncommitted for a bit
SVN-Revision: 9674
This commit is contained in:
parent
06b6aaae20
commit
59a715fdd5
4 changed files with 755 additions and 836 deletions
|
@ -568,8 +568,8 @@ CONFIG_IP_NF_MATCH_ECN=m
|
|||
CONFIG_IP_NF_MATCH_HASHLIMIT=m
|
||||
CONFIG_IP_NF_MATCH_IPP2P=m
|
||||
CONFIG_IP_NF_MATCH_IPRANGE=m
|
||||
CONFIG_IP_NF_MATCH_LAYER7=m
|
||||
# CONFIG_IP_NF_MATCH_LAYER7_DEBUG is not set
|
||||
CONFIG_NETFILTER_XT_MATCH_LAYER7=m
|
||||
# CONFIG_NETFILTER_XT_MATCH_LAYER7_DEBUG is not set
|
||||
CONFIG_IP_NF_MATCH_OWNER=m
|
||||
CONFIG_IP_NF_MATCH_RECENT=m
|
||||
CONFIG_IP_NF_MATCH_SET=m
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,109 +0,0 @@
|
|||
Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_layer7.h
|
||||
===================================================================
|
||||
--- linux-2.6.23-rc6.orig/include/linux/netfilter_ipv4/ipt_layer7.h 2007-09-21 16:23:59.000000000 +0800
|
||||
+++ linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_layer7.h 2007-09-21 16:24:00.000000000 +0800
|
||||
@@ -21,6 +21,7 @@
|
||||
char protocol[MAX_PROTOCOL_LEN];
|
||||
char invert:1;
|
||||
char pattern[MAX_PATTERN_LEN];
|
||||
+ char pkt;
|
||||
};
|
||||
|
||||
#endif /* _IPT_LAYER7_H */
|
||||
Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_layer7.c
|
||||
===================================================================
|
||||
--- linux-2.6.23-rc6.orig/net/ipv4/netfilter/ipt_layer7.c 2007-09-21 16:23:59.000000000 +0800
|
||||
+++ linux-2.6.23-rc6/net/ipv4/netfilter/ipt_layer7.c 2007-09-21 16:24:00.000000000 +0800
|
||||
@@ -300,33 +300,34 @@
|
||||
}
|
||||
|
||||
/* add the new app data to the conntrack. Return number of bytes added. */
|
||||
-static int add_data(struct nf_conn * master_conntrack,
|
||||
- char * app_data, int appdatalen)
|
||||
+static int add_datastr(char *target, int offset, char *app_data, int len)
|
||||
{
|
||||
int length = 0, i;
|
||||
- int oldlength = master_conntrack->layer7.app_data_len;
|
||||
-
|
||||
- // This is a fix for a race condition by Deti Fliegl. However, I'm not
|
||||
- // clear on whether the race condition exists or whether this really
|
||||
- // fixes it. I might just be being dense... Anyway, if it's not really
|
||||
- // a fix, all it does is waste a very small amount of time.
|
||||
- if(!master_conntrack->layer7.app_data) return 0;
|
||||
+ if(!target) return 0;
|
||||
|
||||
/* Strip nulls. Make everything lower case (our regex lib doesn't
|
||||
do case insensitivity). Add it to the end of the current data. */
|
||||
- for(i = 0; i < maxdatalen-oldlength-1 &&
|
||||
- i < appdatalen; i++) {
|
||||
+ for(i = 0; i < maxdatalen-offset-1 && i < len; i++) {
|
||||
if(app_data[i] != '\0') {
|
||||
- master_conntrack->layer7.app_data[length+oldlength] =
|
||||
+ target[length+offset] =
|
||||
/* the kernel version of tolower mungs 'upper ascii' */
|
||||
isascii(app_data[i])? tolower(app_data[i]) : app_data[i];
|
||||
length++;
|
||||
}
|
||||
}
|
||||
+ target[length+offset] = '\0';
|
||||
+
|
||||
+ return length;
|
||||
+}
|
||||
|
||||
- master_conntrack->layer7.app_data[length+oldlength] = '\0';
|
||||
- master_conntrack->layer7.app_data_len = length + oldlength;
|
||||
+/* add the new app data to the conntrack. Return number of bytes added. */
|
||||
+static int add_data(struct nf_conn * master_conntrack,
|
||||
+ char * app_data, int appdatalen)
|
||||
+{
|
||||
+ int length;
|
||||
|
||||
+ length = add_datastr(master_conntrack->layer7.app_data, master_conntrack->layer7.app_data_len, app_data, appdatalen);
|
||||
+ master_conntrack->layer7.app_data_len += length;
|
||||
return length;
|
||||
}
|
||||
|
||||
@@ -343,7 +344,7 @@
|
||||
enum ip_conntrack_info master_ctinfo, ctinfo;
|
||||
struct nf_conn *master_conntrack;
|
||||
struct nf_conn *conntrack;
|
||||
- unsigned char * app_data;
|
||||
+ unsigned char *app_data, *tmp_data;
|
||||
unsigned int pattern_result, appdatalen;
|
||||
regexp * comppattern;
|
||||
|
||||
@@ -365,8 +366,8 @@
|
||||
master_conntrack = master_ct(master_conntrack);
|
||||
|
||||
/* if we've classified it or seen too many packets */
|
||||
- if(TOTAL_PACKETS > num_packets ||
|
||||
- master_conntrack->layer7.app_proto) {
|
||||
+ if(!info->pkt && (TOTAL_PACKETS > num_packets ||
|
||||
+ master_conntrack->layer7.app_proto)) {
|
||||
|
||||
pattern_result = match_no_append(conntrack, master_conntrack, ctinfo, master_ctinfo, info);
|
||||
|
||||
@@ -396,6 +397,23 @@
|
||||
comppattern = compile_and_cache(info->pattern, info->protocol);
|
||||
spin_unlock_bh(&list_lock);
|
||||
|
||||
+ if (info->pkt) {
|
||||
+ tmp_data = kmalloc(maxdatalen, GFP_ATOMIC);
|
||||
+ if(!tmp_data){
|
||||
+ if (net_ratelimit())
|
||||
+ printk(KERN_ERR "layer7: out of memory in match, bailing.\n");
|
||||
+ return info->invert;
|
||||
+ }
|
||||
+
|
||||
+ tmp_data[0] = '\0';
|
||||
+ add_datastr(tmp_data, 0, app_data, appdatalen);
|
||||
+ pattern_result = ((comppattern && regexec(comppattern, tmp_data)) ? 1 : 0);
|
||||
+ kfree(tmp_data);
|
||||
+ tmp_data = NULL;
|
||||
+
|
||||
+ return (pattern_result ^ info->invert);
|
||||
+ }
|
||||
+
|
||||
/* On the first packet of a connection, allocate space for app data */
|
||||
write_lock(&ct_lock);
|
||||
if(TOTAL_PACKETS == 1 && !skb->cb[0] && !master_conntrack->layer7.app_data) {
|
|
@ -1,7 +1,7 @@
|
|||
Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_ipp2p.h
|
||||
Index: linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_ipp2p.h 2007-09-21 16:24:00.000000000 +0800
|
||||
+++ linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h 2007-11-19 18:22:19.000000000 -0600
|
||||
@@ -0,0 +1,31 @@
|
||||
+#ifndef __IPT_IPP2P_H
|
||||
+#define __IPT_IPP2P_H
|
||||
|
@ -34,10 +34,10 @@ Index: linux-2.6.23-rc6/include/linux/netfilter_ipv4/ipt_ipp2p.h
|
|||
+#define IPP2P_MUTE (1 << 14)
|
||||
+#define IPP2P_WASTE (1 << 15)
|
||||
+#define IPP2P_XDCC (1 << 16)
|
||||
Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_ipp2p.c
|
||||
Index: linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-2.6.23-rc6/net/ipv4/netfilter/ipt_ipp2p.c 2007-09-21 16:24:00.000000000 +0800
|
||||
+++ linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c 2007-11-19 18:22:19.000000000 -0600
|
||||
@@ -0,0 +1,856 @@
|
||||
+#if defined(MODVERSIONS)
|
||||
+#include <linux/modversions.h>
|
||||
|
@ -895,13 +895,13 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/ipt_ipp2p.c
|
|||
+module_exit(fini);
|
||||
+
|
||||
+
|
||||
Index: linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig
|
||||
Index: linux-2.6.23.1/net/ipv4/netfilter/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23-rc6.orig/net/ipv4/netfilter/Kconfig 2007-09-21 16:23:59.000000000 +0800
|
||||
+++ linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig 2007-09-21 16:24:00.000000000 +0800
|
||||
@@ -81,6 +81,12 @@
|
||||
help
|
||||
Say Y to get lots of debugging output.
|
||||
--- linux-2.6.23.1.orig/net/ipv4/netfilter/Kconfig 2007-11-19 18:21:55.000000000 -0600
|
||||
+++ linux-2.6.23.1/net/ipv4/netfilter/Kconfig 2007-11-19 18:22:19.000000000 -0600
|
||||
@@ -63,6 +63,12 @@
|
||||
|
||||
To compile it as a module, choose M here. If unsure, say N.
|
||||
|
||||
+config IP_NF_MATCH_IPP2P
|
||||
+ tristate "IPP2P"
|
||||
|
@ -912,16 +912,16 @@ Index: linux-2.6.23-rc6/net/ipv4/netfilter/Kconfig
|
|||
config IP_NF_MATCH_TOS
|
||||
tristate "TOS match support"
|
||||
depends on IP_NF_IPTABLES
|
||||
Index: linux-2.6.23-rc6/net/ipv4/netfilter/Makefile
|
||||
Index: linux-2.6.23.1/net/ipv4/netfilter/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23-rc6.orig/net/ipv4/netfilter/Makefile 2007-09-21 16:23:59.000000000 +0800
|
||||
+++ linux-2.6.23-rc6/net/ipv4/netfilter/Makefile 2007-09-21 16:24:00.000000000 +0800
|
||||
@@ -49,7 +49,7 @@
|
||||
obj-$(CONFIG_IP_NF_MATCH_AH) += ipt_ah.o
|
||||
--- linux-2.6.23.1.orig/net/ipv4/netfilter/Makefile 2007-11-19 18:21:55.000000000 -0600
|
||||
+++ linux-2.6.23.1/net/ipv4/netfilter/Makefile 2007-11-19 18:23:45.000000000 -0600
|
||||
@@ -50,6 +50,8 @@
|
||||
obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
|
||||
obj-$(CONFIG_IP_NF_MATCH_ADDRTYPE) += ipt_addrtype.o
|
||||
-
|
||||
+obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
|
||||
obj-$(CONFIG_IP_NF_MATCH_LAYER7) += ipt_layer7.o
|
||||
|
||||
+obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
|
||||
+
|
||||
# targets
|
||||
obj-$(CONFIG_IP_NF_TARGET_REJECT) += ipt_REJECT.o
|
||||
obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o
|
||||
|
|
Loading…
Reference in a new issue