mac80211: refresh all patches
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
4872c36c55
commit
57f7f91f0c
10 changed files with 39 additions and 42 deletions
|
@ -1,6 +1,6 @@
|
|||
--- a/compat/Makefile
|
||||
+++ b/compat/Makefile
|
||||
@@ -36,8 +36,6 @@ compat-$(CPTCFG_KERNEL_4_7) += backport-
|
||||
@@ -35,8 +35,6 @@ compat-$(CPTCFG_KERNEL_4_6) += backport-
|
||||
|
||||
compat-$(CPTCFG_BPAUTO_BUILD_CRYPTO_CCM) += crypto-ccm.o
|
||||
compat-$(CPTCFG_BPAUTO_CRYPTO_SKCIPHER) += crypto-skcipher.o
|
||||
|
|
|
@ -14,7 +14,7 @@
|
|||
ccflags-y += -D__CHECK_ENDIAN__
|
||||
--- a/drivers/net/wireless/ath/ath.h
|
||||
+++ b/drivers/net/wireless/ath/ath.h
|
||||
@@ -318,13 +318,6 @@ void _ath_dbg(struct ath_common *common,
|
||||
@@ -318,14 +318,7 @@ void _ath_dbg(struct ath_common *common,
|
||||
#endif /* CPTCFG_ATH_DEBUG */
|
||||
|
||||
/** Returns string describing opmode, or NULL if unknown mode. */
|
||||
|
@ -27,4 +27,5 @@
|
|||
-}
|
||||
-#endif
|
||||
|
||||
#endif /* ATH_H */
|
||||
extern const char *ath_bus_type_strings[];
|
||||
static inline const char *ath_bus_type_to_string(enum ath_bus_type bustype)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/wireless/ath/ath9k/init.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/init.c
|
||||
@@ -45,7 +45,7 @@ int ath9k_modparam_nohwcrypt;
|
||||
@@ -47,7 +47,7 @@ int ath9k_modparam_nohwcrypt;
|
||||
module_param_named(nohwcrypt, ath9k_modparam_nohwcrypt, int, 0444);
|
||||
MODULE_PARM_DESC(nohwcrypt, "Disable hardware encryption");
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/wireless/ath/ath9k/init.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/init.c
|
||||
@@ -731,6 +731,7 @@ static const struct ieee80211_iface_limi
|
||||
@@ -773,6 +773,7 @@ static const struct ieee80211_iface_limi
|
||||
BIT(NL80211_IFTYPE_AP) },
|
||||
{ .max = 1, .types = BIT(NL80211_IFTYPE_P2P_CLIENT) |
|
||||
BIT(NL80211_IFTYPE_P2P_GO) },
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/wireless/ath/ath9k/init.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/init.c
|
||||
@@ -1034,23 +1034,23 @@ static int __init ath9k_init(void)
|
||||
@@ -1076,23 +1076,23 @@ static int __init ath9k_init(void)
|
||||
{
|
||||
int error;
|
||||
|
||||
|
|
|
@ -181,7 +181,7 @@
|
|||
|
||||
--- a/drivers/net/wireless/ath/ath9k/init.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/init.c
|
||||
@@ -946,7 +946,7 @@ int ath9k_init_device(u16 devid, struct
|
||||
@@ -988,7 +988,7 @@ int ath9k_init_device(u16 devid, struct
|
||||
|
||||
#ifdef CPTCFG_MAC80211_LEDS
|
||||
/* must be initialized before ieee80211_register_hw */
|
||||
|
|
|
@ -55,7 +55,7 @@
|
|||
ops->spectral_scan_config = ar9003_hw_spectral_scan_config;
|
||||
--- a/drivers/net/wireless/ath/ath9k/init.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/init.c
|
||||
@@ -719,7 +719,8 @@ static void ath9k_init_txpower_limits(st
|
||||
@@ -761,7 +761,8 @@ static void ath9k_init_txpower_limits(st
|
||||
if (ah->caps.hw_caps & ATH9K_HW_CAP_5GHZ)
|
||||
ath9k_init_band_txpower(sc, NL80211_BAND_5GHZ);
|
||||
|
||||
|
@ -65,7 +65,7 @@
|
|||
}
|
||||
|
||||
static const struct ieee80211_iface_limit if_limits[] = {
|
||||
@@ -906,6 +907,18 @@ static void ath9k_set_hw_capab(struct at
|
||||
@@ -948,6 +949,18 @@ static void ath9k_set_hw_capab(struct at
|
||||
SET_IEEE80211_PERM_ADDR(hw, common->macaddr);
|
||||
}
|
||||
|
||||
|
@ -84,7 +84,7 @@
|
|||
int ath9k_init_device(u16 devid, struct ath_softc *sc,
|
||||
const struct ath_bus_ops *bus_ops)
|
||||
{
|
||||
@@ -951,6 +964,8 @@ int ath9k_init_device(u16 devid, struct
|
||||
@@ -993,6 +1006,8 @@ int ath9k_init_device(u16 devid, struct
|
||||
ARRAY_SIZE(ath9k_tpt_blink));
|
||||
#endif
|
||||
|
||||
|
|
|
@ -349,16 +349,6 @@ Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|||
-
|
||||
- integer = swab32(eep->modalHeader.antCtrlCommon);
|
||||
- eep->modalHeader.antCtrlCommon = integer;
|
||||
-
|
||||
- for (i = 0; i < AR5416_EEP4K_MAX_CHAINS; i++) {
|
||||
- integer = swab32(eep->modalHeader.antCtrlChain[i]);
|
||||
- eep->modalHeader.antCtrlChain[i] = integer;
|
||||
- }
|
||||
-
|
||||
- for (i = 0; i < AR_EEPROM_MODAL_SPURS; i++) {
|
||||
- word = swab16(eep->modalHeader.spurChans[i].spurChan);
|
||||
- eep->modalHeader.spurChans[i].spurChan = word;
|
||||
- }
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.length);
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.checksum);
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.version);
|
||||
|
@ -368,10 +358,18 @@ Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.blueToothOptions);
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.deviceCap);
|
||||
+ EEPROM_FIELD_SWAB32(eep->modalHeader.antCtrlCommon);
|
||||
+
|
||||
|
||||
- for (i = 0; i < AR5416_EEP4K_MAX_CHAINS; i++) {
|
||||
- integer = swab32(eep->modalHeader.antCtrlChain[i]);
|
||||
- eep->modalHeader.antCtrlChain[i] = integer;
|
||||
- }
|
||||
+ for (i = 0; i < AR5416_EEP4K_MAX_CHAINS; i++)
|
||||
+ EEPROM_FIELD_SWAB32(eep->modalHeader.antCtrlChain[i]);
|
||||
+
|
||||
|
||||
- for (i = 0; i < AR_EEPROM_MODAL_SPURS; i++) {
|
||||
- word = swab16(eep->modalHeader.spurChans[i].spurChan);
|
||||
- eep->modalHeader.spurChans[i].spurChan = word;
|
||||
- }
|
||||
+ for (i = 0; i < AR_EEPROM_MODAL_SPURS; i++)
|
||||
+ EEPROM_FIELD_SWAB16(
|
||||
+ eep->modalHeader.spurChans[i].spurChan);
|
||||
|
@ -542,16 +540,6 @@ Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|||
-
|
||||
- integer = swab32(eep->modalHeader.antCtrlCommon);
|
||||
- eep->modalHeader.antCtrlCommon = integer;
|
||||
-
|
||||
- for (i = 0; i < AR9287_MAX_CHAINS; i++) {
|
||||
- integer = swab32(eep->modalHeader.antCtrlChain[i]);
|
||||
- eep->modalHeader.antCtrlChain[i] = integer;
|
||||
- }
|
||||
-
|
||||
- for (i = 0; i < AR_EEPROM_MODAL_SPURS; i++) {
|
||||
- word = swab16(eep->modalHeader.spurChans[i].spurChan);
|
||||
- eep->modalHeader.spurChans[i].spurChan = word;
|
||||
- }
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.length);
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.checksum);
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.version);
|
||||
|
@ -561,10 +549,18 @@ Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.blueToothOptions);
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.deviceCap);
|
||||
+ EEPROM_FIELD_SWAB32(eep->modalHeader.antCtrlCommon);
|
||||
+
|
||||
|
||||
- for (i = 0; i < AR9287_MAX_CHAINS; i++) {
|
||||
- integer = swab32(eep->modalHeader.antCtrlChain[i]);
|
||||
- eep->modalHeader.antCtrlChain[i] = integer;
|
||||
- }
|
||||
+ for (i = 0; i < AR9287_MAX_CHAINS; i++)
|
||||
+ EEPROM_FIELD_SWAB32(eep->modalHeader.antCtrlChain[i]);
|
||||
+
|
||||
|
||||
- for (i = 0; i < AR_EEPROM_MODAL_SPURS; i++) {
|
||||
- word = swab16(eep->modalHeader.spurChans[i].spurChan);
|
||||
- eep->modalHeader.spurChans[i].spurChan = word;
|
||||
- }
|
||||
+ for (i = 0; i < AR_EEPROM_MODAL_SPURS; i++)
|
||||
+ EEPROM_FIELD_SWAB16(
|
||||
+ eep->modalHeader.spurChans[i].spurChan);
|
||||
|
@ -716,8 +712,7 @@ Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|||
if (need_swap) {
|
||||
- u32 integer, j;
|
||||
- u16 word;
|
||||
+ u32 j;
|
||||
|
||||
-
|
||||
- word = swab16(eep->baseEepHeader.length);
|
||||
- eep->baseEepHeader.length = word;
|
||||
-
|
||||
|
@ -738,7 +733,8 @@ Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
|
|||
-
|
||||
- word = swab16(eep->baseEepHeader.blueToothOptions);
|
||||
- eep->baseEepHeader.blueToothOptions = word;
|
||||
-
|
||||
+ u32 j;
|
||||
|
||||
- word = swab16(eep->baseEepHeader.deviceCap);
|
||||
- eep->baseEepHeader.deviceCap = word;
|
||||
+ EEPROM_FIELD_SWAB16(eep->baseEepHeader.length);
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/.local-symbols
|
||||
+++ b/.local-symbols
|
||||
@@ -331,6 +331,7 @@ RT2X00_LIB_FIRMWARE=
|
||||
@@ -332,6 +332,7 @@ RT2X00_LIB_FIRMWARE=
|
||||
RT2X00_LIB_CRYPTO=
|
||||
RT2X00_LIB_LEDS=
|
||||
RT2X00_LIB_DEBUGFS=
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
#include "rt2x00.h"
|
||||
#include "rt2800lib.h"
|
||||
@@ -8186,6 +8187,27 @@ static const struct rf_channel rf_vals_5
|
||||
@@ -8183,6 +8184,27 @@ static const struct rf_channel rf_vals_5
|
||||
{196, 83, 0, 12, 1},
|
||||
};
|
||||
|
||||
|
@ -36,7 +36,7 @@
|
|||
static int rt2800_probe_hw_mode(struct rt2x00_dev *rt2x00dev)
|
||||
{
|
||||
struct hw_mode_spec *spec = &rt2x00dev->spec;
|
||||
@@ -8276,7 +8298,10 @@ static int rt2800_probe_hw_mode(struct r
|
||||
@@ -8273,7 +8295,10 @@ static int rt2800_probe_hw_mode(struct r
|
||||
case RF5390:
|
||||
case RF5392:
|
||||
spec->num_channels = 14;
|
||||
|
@ -48,7 +48,7 @@
|
|||
break;
|
||||
|
||||
case RF3052:
|
||||
@@ -8460,6 +8485,20 @@ static int rt2800_probe_rt(struct rt2x00
|
||||
@@ -8457,6 +8482,20 @@ static int rt2800_probe_rt(struct rt2x00
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -69,7 +69,7 @@
|
|||
int rt2800_probe_hw(struct rt2x00_dev *rt2x00dev)
|
||||
{
|
||||
struct rt2800_drv_data *drv_data = rt2x00dev->drv_data;
|
||||
@@ -8502,6 +8541,15 @@ int rt2800_probe_hw(struct rt2x00_dev *r
|
||||
@@ -8499,6 +8538,15 @@ int rt2800_probe_hw(struct rt2x00_dev *r
|
||||
rt2800_register_write(rt2x00dev, GPIO_CTRL, reg);
|
||||
|
||||
/*
|
||||
|
|
Loading…
Reference in a new issue