iptables: bump to 1.4.19.1
SVN-Revision: 36760
This commit is contained in:
parent
0edabea0b1
commit
56a3396bf2
4 changed files with 20 additions and 67 deletions
|
@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=iptables
|
||||
PKG_VERSION:=1.4.18
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=1.4.19.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
|
||||
ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
|
||||
ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
|
||||
ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
|
||||
PKG_MD5SUM:=a819199d5ec013b82da13a8ffbba857e
|
||||
PKG_MD5SUM:=be97ce9007fa42c867901b496c935a0a
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
Index: iptables-1.4.18/extensions/GNUmakefile.in
|
||||
===================================================================
|
||||
--- iptables-1.4.18.orig/extensions/GNUmakefile.in 2013-03-03 22:40:11.000000000 +0100
|
||||
+++ iptables-1.4.18/extensions/GNUmakefile.in 2013-03-06 17:13:04.074584735 +0100
|
||||
@@ -33,7 +33,6 @@
|
||||
AM_VERBOSE_CXXLD = @echo " CXXLD " $@;
|
||||
AM_VERBOSE_AR = @echo " AR " $@;
|
||||
AM_VERBOSE_GEN = @echo " GEN " $@;
|
||||
-AM_VERBOSE_NULL = @
|
||||
endif
|
||||
|
||||
#
|
||||
@@ -76,7 +75,7 @@
|
||||
if test -n "${targets_install}"; then install -pm0755 $^ "${DESTDIR}${xtlibdir}/"; fi;
|
||||
|
||||
clean:
|
||||
- rm -f *.la *.o *.lo *.so *.a {matches,targets}.man initext.c initext4.c initext6.c;
|
||||
+ rm -f *.o *.oo *.so *.a {matches,targets}.man initext.c initext4.c initext6.c;
|
||||
rm -f .*.d .*.dd;
|
||||
|
||||
distclean: clean
|
||||
@@ -90,22 +89,19 @@
|
||||
#
|
||||
# Shared libraries
|
||||
#
|
||||
-lib%.so: lib%.la
|
||||
- ${AM_VERBOSE_NULL} ln -fs .libs/$@ $@
|
||||
+lib%.so: lib%.oo
|
||||
+ ${AM_VERBOSE_CCLD} ${CCLD} ${AM_LDFLAGS} -shared ${LDFLAGS} -o $@ $< -L../libxtables/.libs -L../libiptc/.libs -lxtables ${$*_LIBADD};
|
||||
|
||||
-lib%.la: lib%.lo
|
||||
- ${AM_VERBOSE_CCLD} ../libtool ${AM_LIBTOOL_SILENT} --tag=CC --mode=link ${CCLD} ${AM_LDFLAGS} -module ${LDFLAGS} -o $@ $< ../libxtables/libxtables.la ${$*_LIBADD} -rpath ${xtlibdir}
|
||||
-
|
||||
-lib%.lo: ${srcdir}/lib%.c
|
||||
- ${AM_VERBOSE_CC} ../libtool ${AM_LIBTOOL_SILENT} --tag=CC --mode=compile ${CC} ${AM_CPPFLAGS} ${AM_DEPFLAGS} ${AM_CFLAGS} -D_INIT=lib$*_init ${CFLAGS} -o $@ -c $<
|
||||
+lib%.oo: ${srcdir}/lib%.c
|
||||
+ ${AM_VERBOSE_CC} ${CC} ${AM_CPPFLAGS} ${AM_DEPFLAGS} ${AM_CFLAGS} -D_INIT=lib$*_init -DPIC -fPIC ${CFLAGS} -o $@ -c $<;
|
||||
|
||||
libxt_NOTRACK.so: libxt_CT.so
|
||||
- ${AM_VERBOSE_GEN} ln -fs $< $@
|
||||
+ ln -fs $< $@
|
||||
libxt_state.so: libxt_conntrack.so
|
||||
- ${AM_VERBOSE_GEN} ln -fs $< $@
|
||||
+ ln -fs $< $@
|
||||
|
||||
# Need the LIBADDs in iptables/Makefile.am too for libxtables_la_LIBADD
|
||||
-ip6t_NETMAP_LIBADD = ../libiptc/libip6tc.la
|
||||
+ip6t_NETMAP_LIBADD = -lip6tc
|
||||
xt_RATEEST_LIBADD = -lm
|
||||
xt_statistic_LIBADD = -lm
|
||||
|
|
@ -1,6 +1,8 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -12173,77 +12173,7 @@ $as_echo "no" >&6; }
|
||||
Index: iptables-1.4.19.1/configure
|
||||
===================================================================
|
||||
--- iptables-1.4.19.1.orig/configure 2013-05-29 16:37:33.176674855 +0200
|
||||
+++ iptables-1.4.19.1/configure 2013-05-29 16:37:33.168674855 +0200
|
||||
@@ -12198,77 +12198,7 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
|
@ -79,11 +81,13 @@
|
|||
HAVE_LIBNFNETLINK_TRUE=
|
||||
HAVE_LIBNFNETLINK_FALSE='#'
|
||||
else
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -89,9 +89,7 @@ AM_CONDITIONAL([ENABLE_LARGEFILE], [test
|
||||
AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
|
||||
Index: iptables-1.4.19.1/configure.ac
|
||||
===================================================================
|
||||
--- iptables-1.4.19.1.orig/configure.ac 2013-05-29 16:37:33.176674855 +0200
|
||||
+++ iptables-1.4.19.1/configure.ac 2013-05-29 16:37:33.168674855 +0200
|
||||
@@ -93,9 +93,7 @@
|
||||
AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
|
||||
AM_CONDITIONAL([ENABLE_BPFC], [test "$enable_bpfc" = "yes"])
|
||||
|
||||
-PKG_CHECK_MODULES([libnfnetlink], [libnfnetlink >= 1.0],
|
||||
- [nfnetlink=1], [nfnetlink=0])
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: iptables-1.4.18/extensions/GNUmakefile.in
|
||||
Index: iptables-1.4.19.1/extensions/GNUmakefile.in
|
||||
===================================================================
|
||||
--- iptables-1.4.18.orig/extensions/GNUmakefile.in 2013-03-03 22:40:11.000000000 +0100
|
||||
+++ iptables-1.4.18/extensions/GNUmakefile.in 2013-03-05 16:37:07.583256974 +0100
|
||||
@@ -46,9 +46,24 @@
|
||||
--- iptables-1.4.19.1.orig/extensions/GNUmakefile.in 2013-05-29 16:37:41.304675049 +0200
|
||||
+++ iptables-1.4.19.1/extensions/GNUmakefile.in 2013-05-29 16:37:41.296675048 +0200
|
||||
@@ -45,9 +45,24 @@
|
||||
pfx_build_mod := $(filter-out @blacklist_modules@,${pfx_build_mod})
|
||||
pf4_build_mod := $(filter-out @blacklist_modules@,${pf4_build_mod})
|
||||
pf6_build_mod := $(filter-out @blacklist_modules@,${pf6_build_mod})
|
||||
|
@ -30,7 +30,7 @@ Index: iptables-1.4.18/extensions/GNUmakefile.in
|
|||
pfx_solibs := $(patsubst %,libxt_%.so,${pfx_build_mod} ${pfx_symlinks})
|
||||
pf4_solibs := $(patsubst %,libipt_%.so,${pf4_build_mod})
|
||||
pf6_solibs := $(patsubst %,libip6t_%.so,${pf6_build_mod})
|
||||
@@ -59,11 +74,11 @@
|
||||
@@ -58,11 +73,11 @@
|
||||
#
|
||||
targets := libext.a libext4.a libext6.a matches.man targets.man
|
||||
targets_install :=
|
||||
|
@ -47,7 +47,7 @@ Index: iptables-1.4.18/extensions/GNUmakefile.in
|
|||
|
||||
.SECONDARY:
|
||||
|
||||
@@ -128,9 +143,9 @@
|
||||
@@ -123,9 +138,9 @@
|
||||
libext6.a: initext6.o ${libext6_objs}
|
||||
${AM_VERBOSE_AR} ${AR} crs $@ $^;
|
||||
|
||||
|
|
Loading…
Reference in a new issue