xtables-addons: update to version 2.5

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 42256
This commit is contained in:
Felix Fietkau 2014-08-21 19:12:34 +00:00
parent bb6905bd23
commit 53d1cb9409
7 changed files with 1940 additions and 127 deletions

View file

@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons
PKG_VERSION:=2.3
PKG_VERSION:=2.5
PKG_RELEASE:=1
PKG_MD5SUM:=7d942729c365a549513511061f74c3e3
PKG_MD5SUM:=335663ece5fb17c7d0bb24dbdc697eb1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/xtables-addons
@ -126,7 +126,6 @@ endef
#$(eval $(call BuildTemplate,SUFFIX,DESCRIPTION,EXTENSION,MODULE,PRIORITY,DEPENDS))
$(eval $(call BuildTemplate,compat-xtables,API compatibilty layer,,compat_xtables,+IPV6:kmod-ip6tables,CONFIG_NF_CONNTRACK_MARK=y))
$(eval $(call BuildTemplate,rawpost,RAWPOST,,iptable_rawpost $(if $(CONFIG_IPV6),ip6table_rawpost),+kmod-ipt-compat-xtables +IPV6:kmod-ip6tables))
$(eval $(call BuildTemplate,nathelper-rtsp,RTSP Conntrack and NAT,,rtsp/nf_conntrack_rtsp rtsp/nf_nat_rtsp,+kmod-ipt-conntrack-extra +kmod-ipt-nat))
$(eval $(call BuildTemplate,account,ACCOUNT,xt_ACCOUNT,ACCOUNT/xt_ACCOUNT,+kmod-ipt-compat-xtables))
@ -147,8 +146,6 @@ $(eval $(call BuildTemplate,lscan,lscan,xt_lscan,xt_lscan,))
$(eval $(call BuildTemplate,lua,Lua PacketScript,xt_LUA,LUA/xt_LUA,+kmod-ipt-conntrack-extra))
$(eval $(call BuildTemplate,psd,psd,xt_psd,xt_psd,))
$(eval $(call BuildTemplate,quota2,quota2,xt_quota2,xt_quota2,))
$(eval $(call BuildTemplate,rawnat,RAWNAT,xt_RAWDNAT xt_RAWSNAT,xt_RAWNAT,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,steal,STEAL,xt_STEAL,xt_STEAL,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,+kmod-ipt-compat-xtables +IPV6:kmod-ipv6))

View file

@ -1,16 +0,0 @@
---
Makefile.in | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,9 +11,6 @@ FORCE:
xtables-addons.8: FORCE
${MAKE} -f Makefile.mans all;
-install-exec-hook:
- depmod -a || :;
-
clean-local-mans:
${MAKE} -f Makefile.mans clean;

View file

@ -1,14 +0,0 @@
--- a/extensions/compat_xtables.h
+++ b/extensions/compat_xtables.h
@@ -82,4 +82,11 @@ static inline void proc_remove(struct pr
}
#endif
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 9, 0)
+static inline void proc_net_remove(struct net *net, const char *name)
+{
+ remove_proc_entry(name, net->proc_net);
+}
+#endif
+
#endif /* _XTABLES_COMPAT_H */

View file

@ -1,14 +0,0 @@
--- a/extensions/compat_xtables.h
+++ b/extensions/compat_xtables.h
@@ -89,4 +89,11 @@ static inline void proc_net_remove(struc
}
#endif
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
+static inline u32 net_random(void)
+{
+ return prandom_u32();
+}
+#endif
+
#endif /* _XTABLES_COMPAT_H */

View file

@ -1317,7 +1317,7 @@
+module_exit(fini);
--- a/extensions/Kbuild
+++ b/extensions/Kbuild
@@ -33,6 +33,7 @@ obj-${build_lscan} += xt_lscan.o
@@ -28,6 +28,7 @@ obj-${build_lscan} += xt_lscan.o
obj-${build_pknock} += pknock/
obj-${build_psd} += xt_psd.o
obj-${build_quota2} += xt_quota2.o
@ -1327,7 +1327,7 @@
-include ${M}/Kbuild.*
--- a/mconfig
+++ b/mconfig
@@ -24,3 +24,4 @@ build_lscan=m
@@ -22,3 +22,4 @@ build_lscan=m
build_pknock=m
build_psd=m
build_quota2=m

View file

@ -17844,78 +17844,6 @@
+
+#endif /* XT_LUA_H_ */
--- /dev/null
+++ b/extensions/LUA/xt_LUA.mod.c
@@ -0,0 +1,69 @@
+#include <linux/module.h>
+#include <linux/vermagic.h>
+#include <linux/compiler.h>
+
+MODULE_INFO(vermagic, VERMAGIC_STRING);
+
+struct module __this_module
+__attribute__((section(".gnu.linkonce.this_module"))) = {
+ .name = KBUILD_MODNAME,
+ .init = init_module,
+#ifdef CONFIG_MODULE_UNLOAD
+ .exit = cleanup_module,
+#endif
+ .arch = MODULE_ARCH_INIT,
+};
+
+static const struct modversion_info ____versions[]
+__used
+__attribute__((section("__versions"))) = {
+ { 0xa3379c4b, "module_layout" },
+ { 0x5cf97727, "xt_unregister_target" },
+ { 0x9a1dfd65, "strpbrk" },
+ { 0x56fb5417, "kmalloc_caches" },
+ { 0x12da5bb2, "__kmalloc" },
+ { 0xb85f3bbe, "pv_lock_ops" },
+ { 0x349cba85, "strchr" },
+ { 0xd0d8621b, "strlen" },
+ { 0x79aa04a2, "get_random_bytes" },
+ { 0x20000329, "simple_strtoul" },
+ { 0x105e2727, "__tracepoint_kmalloc" },
+ { 0xbf7e1481, "inet_proto_csum_replace4" },
+ { 0x6c1ce5ce, "strcspn" },
+ { 0x3c2c5af5, "sprintf" },
+ { 0xe2d5255a, "strcmp" },
+ { 0xe24d3a97, "jiffies_64" },
+ { 0x2bc95bd4, "memset" },
+ { 0x87fc9bcc, "kmem_cache_alloc_notrace" },
+ { 0x11089ac7, "_ctype" },
+ { 0x37befc70, "jiffies_to_msecs" },
+ { 0x70d1f8f3, "strncat" },
+ { 0xb72397d5, "printk" },
+ { 0x42224298, "sscanf" },
+ { 0x5152e605, "memcmp" },
+ { 0xb6ed1e53, "strncpy" },
+ { 0x1e6d26a8, "strstr" },
+ { 0xc3fa6a59, "memchr" },
+ { 0x61651be, "strcat" },
+ { 0x7d8c0d13, "xt_register_target" },
+ { 0x8ff4079b, "pv_irq_ops" },
+ { 0x93fca811, "__get_free_pages" },
+ { 0xf0fdf6cb, "__stack_chk_fail" },
+ { 0xbbe2391b, "kfree_skb" },
+ { 0xf333a2fb, "_raw_spin_lock_irq" },
+ { 0x37a0cba, "kfree" },
+ { 0x2e60bace, "memcpy" },
+ { 0x59e7cb79, "skb_make_writable" },
+ { 0xb742fd7, "simple_strtol" },
+ { 0x7d50a24, "csum_partial" },
+ { 0xc2d711e1, "krealloc" },
+ { 0xe914e41e, "strcpy" },
+};
+
+static const char __module_depends[]
+__used
+__attribute__((section(".modinfo"))) =
+"depends=x_tables";
+
+
+MODULE_INFO(srcversion, "33A1481C4AA71D1B5A8CA8A");
--- /dev/null
+++ b/extensions/LUA/xt_LUA_target.c
@@ -0,0 +1,286 @@
+/*
@ -18206,7 +18134,7 @@
+
--- a/extensions/Kbuild
+++ b/extensions/Kbuild
@@ -34,6 +34,7 @@ obj-${build_pknock} += pknock/
@@ -29,6 +29,7 @@ obj-${build_pknock} += pknock/
obj-${build_psd} += xt_psd.o
obj-${build_quota2} += xt_quota2.o
obj-${build_rtsp} += rtsp/
@ -18216,14 +18144,14 @@
-include ${M}/Kbuild.*
--- a/extensions/Mbuild
+++ b/extensions/Mbuild
@@ -24,3 +24,4 @@ obj-${build_pknock} += pknock/
@@ -22,3 +22,4 @@ obj-${build_pknock} += pknock/
obj-${build_psd} += libxt_psd.so
obj-${build_quota2} += libxt_quota2.so
obj-${build_gradm} += libxt_gradm.so
+obj-${build_LUA} += LUA/
--- a/mconfig
+++ b/mconfig
@@ -25,3 +25,4 @@ build_pknock=m
@@ -23,3 +23,4 @@ build_pknock=m
build_psd=m
build_quota2=m
build_rtsp=m