lua: link library with -Bsymbolic-functions
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45509
This commit is contained in:
parent
d2ecd10f2f
commit
5199a23165
1 changed files with 11 additions and 0 deletions
11
package/utils/lua/patches/040-use-symbolic-functions.patch
Normal file
11
package/utils/lua/patches/040-use-symbolic-functions.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -56,7 +56,7 @@ $(LUA_A): $(CORE_O) $(LIB_O)
|
||||
$(RANLIB) $@
|
||||
|
||||
$(LUA_SO): $(CORE_O) $(LIB_O)
|
||||
- $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
|
||||
+ $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
|
||||
ln -fs $@.$(PKG_VERSION) $@
|
||||
|
||||
$(LUA_T): $(LUA_O) $(LUA_SO)
|
Loading…
Reference in a new issue