refresh kernel patches

SVN-Revision: 21218
This commit is contained in:
Alexandros C. Couloumbis 2010-04-28 09:28:13 +00:00
parent ee7569f3e5
commit 4c78fa0492
17 changed files with 58 additions and 58 deletions

View file

@ -32,7 +32,7 @@
source "arch/mips/bcm63xx/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -191,6 +191,22 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
@@ -193,6 +193,22 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#

View file

@ -55,7 +55,7 @@
static struct cfi_fixup cfi_fixup_table[] = {
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
#ifdef AMD_BOOTLOC_BUG
@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
*/
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_erase_chip, NULL },
{ CFI_MFR_ATMEL, AT49BV6416, fixup_use_atmel_lock, NULL },

View file

@ -267,7 +267,7 @@
}
static void
@@ -565,8 +564,8 @@ pl010_console_write(struct console *co,
@@ -565,8 +564,8 @@ pl010_console_write(struct console *co,
/*
* First save the CR then disable the interrupts
*/
@ -278,7 +278,7 @@
uart_console_write(&uap->port, s, count, pl010_console_putchar);
@@ -575,10 +574,10 @@ pl010_console_write(struct console *co,
@@ -575,10 +574,10 @@ pl010_console_write(struct console *co,
* and restore the TCR
*/
do {

View file

@ -1,6 +1,6 @@
--- a/drivers/usb/host/adm5120-dbg.c
+++ b/drivers/usb/host/adm5120-dbg.c
@@ -632,7 +632,7 @@ static ssize_t fill_registers_buffer(str
@@ -642,7 +642,7 @@ static ssize_t fill_registers_buffer(str
hcd->product_desc,
hcd_name);

View file

@ -26,7 +26,7 @@
spin_lock_irqsave(&ahcd->lock, flags);
temp = show_list(ahcd, buf->page, PAGE_SIZE, ahcd->ed_head);
@@ -516,8 +512,6 @@ static ssize_t fill_async_buffer(struct
@@ -516,8 +512,6 @@ static ssize_t fill_async_buffer(struct
static ssize_t fill_periodic_buffer(struct debug_buffer *buf)
{

View file

@ -1,6 +1,6 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -20,6 +20,21 @@ choice
@@ -23,6 +23,21 @@ choice
prompt "System type"
default SGI_IP22
@ -21,18 +21,18 @@
+
config MACH_ALCHEMY
bool "Alchemy processor based machines"
@@ -673,6 +688,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
select SYS_SUPPORTS_ZBOOT
@@ -681,6 +696,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
endchoice
+source "arch/mips/adm5120/Kconfig"
source "arch/mips/alchemy/Kconfig"
source "arch/mips/basler/excite/Kconfig"
source "arch/mips/bcm63xx/Kconfig"
source "arch/mips/jazz/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -191,6 +191,22 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
@@ -214,6 +214,22 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#

View file

@ -1,8 +1,8 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -557,4 +557,8 @@ config MTD_VMU
To build this as a module select M here, the module will be called
vmu-flash.
@@ -551,4 +551,8 @@ config MTD_PISMO
When built as a module, it will be called pismo.ko
+config MTD_ADM5120
+ tristate "Map driver for ADM5120 based boards"
@ -11,7 +11,7 @@
endmenu
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -40,6 +40,7 @@
@@ -40,6 +40,7 @@ obj-$(CONFIG_MTD_SCx200_DOCFLASH)+= scx2
obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.o
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o

View file

@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -602,6 +602,10 @@ config MIPS_AU1X00_ENET
@@ -614,6 +614,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@ -13,7 +13,7 @@
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -208,6 +208,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
@@ -213,6 +213,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o

View file

@ -10,7 +10,7 @@
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -1748,6 +1748,9 @@
@@ -1752,6 +1752,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111

View file

@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -315,4 +315,12 @@ config LEDS_TRIGGER_NETDEV
@@ -365,4 +365,12 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
@ -15,7 +15,7 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -42,3 +42,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
@@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o

View file

@ -55,7 +55,7 @@
static struct cfi_fixup cfi_fixup_table[] = {
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
#ifdef AMD_BOOTLOC_BUG
@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
*/
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_erase_chip, NULL },
{ CFI_MFR_ATMEL, AT49BV6416, fixup_use_atmel_lock, NULL },
@ -67,7 +67,7 @@
--- a/drivers/mtd/chips/Kconfig
+++ b/drivers/mtd/chips/Kconfig
@@ -198,6 +198,14 @@ config MTD_CFI_AMDSTD
@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
provides support for one of those command sets, used on chips
including the AMD Am29LV320.

View file

@ -1,6 +1,6 @@
--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
@@ -77,6 +77,7 @@ obj-$(CONFIG_PATA_PLATFORM) += pata_plat
@@ -79,6 +79,7 @@ obj-$(CONFIG_PATA_PLATFORM) += pata_plat
obj-$(CONFIG_PATA_AT91) += pata_at91.o
obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
@ -10,7 +10,7 @@
# Should be last but one libata driver
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -597,6 +597,15 @@ config PATA_RADISYS
@@ -604,6 +604,15 @@ config PATA_RADISYS
If unsure, say N.

View file

@ -1,6 +1,6 @@
--- a/drivers/serial/amba-pl010.c
+++ b/drivers/serial/amba-pl010.c
@@ -50,11 +50,10 @@
@@ -51,11 +51,10 @@
#include <asm/io.h>
@ -14,7 +14,7 @@
#define AMBA_ISR_PASS_LIMIT 256
@@ -80,9 +79,9 @@ static void pl010_stop_tx(struct uart_po
@@ -81,9 +80,9 @@ static void pl010_stop_tx(struct uart_po
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@ -26,7 +26,7 @@
}
static void pl010_start_tx(struct uart_port *port)
@@ -90,9 +89,9 @@ static void pl010_start_tx(struct uart_p
@@ -91,9 +90,9 @@ static void pl010_start_tx(struct uart_p
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@ -38,7 +38,7 @@
}
static void pl010_stop_rx(struct uart_port *port)
@@ -100,9 +99,9 @@ static void pl010_stop_rx(struct uart_po
@@ -101,9 +100,9 @@ static void pl010_stop_rx(struct uart_po
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@ -50,7 +50,7 @@
}
static void pl010_enable_ms(struct uart_port *port)
@@ -110,9 +109,9 @@ static void pl010_enable_ms(struct uart_
@@ -111,9 +110,9 @@ static void pl010_enable_ms(struct uart_
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@ -62,7 +62,7 @@
}
static void pl010_rx_chars(struct uart_amba_port *uap)
@@ -120,9 +119,9 @@ static void pl010_rx_chars(struct uart_a
@@ -121,9 +120,9 @@ static void pl010_rx_chars(struct uart_a
struct tty_struct *tty = uap->port.state->port.tty;
unsigned int status, ch, flag, rsr, max_count = 256;
@ -74,7 +74,7 @@
flag = TTY_NORMAL;
uap->port.icount.rx++;
@@ -131,9 +130,9 @@ static void pl010_rx_chars(struct uart_a
@@ -132,9 +131,9 @@ static void pl010_rx_chars(struct uart_a
* Note that the error handling code is
* out of the main execution path
*/
@ -86,7 +86,7 @@
if (rsr & UART01x_RSR_BE) {
rsr &= ~(UART01x_RSR_FE | UART01x_RSR_PE);
@@ -163,7 +162,7 @@ static void pl010_rx_chars(struct uart_a
@@ -164,7 +163,7 @@ static void pl010_rx_chars(struct uart_a
uart_insert_char(&uap->port, rsr, UART01x_RSR_OE, ch, flag);
ignore_char:
@ -95,7 +95,7 @@
}
spin_unlock(&uap->port.lock);
tty_flip_buffer_push(tty);
@@ -176,7 +175,7 @@ static void pl010_tx_chars(struct uart_a
@@ -177,7 +176,7 @@ static void pl010_tx_chars(struct uart_a
int count;
if (uap->port.x_char) {
@ -104,7 +104,7 @@
uap->port.icount.tx++;
uap->port.x_char = 0;
return;
@@ -188,7 +187,7 @@ static void pl010_tx_chars(struct uart_a
@@ -189,7 +188,7 @@ static void pl010_tx_chars(struct uart_a
count = uap->port.fifosize >> 1;
do {
@ -113,7 +113,7 @@
xmit->tail = (xmit->tail + 1) & (UART_XMIT_SIZE - 1);
uap->port.icount.tx++;
if (uart_circ_empty(xmit))
@@ -206,9 +205,9 @@ static void pl010_modem_status(struct ua
@@ -207,9 +206,9 @@ static void pl010_modem_status(struct ua
{
unsigned int status, delta;
@ -125,7 +125,7 @@
delta = status ^ uap->old_status;
uap->old_status = status;
@@ -236,7 +235,7 @@ static irqreturn_t pl010_int(int irq, vo
@@ -237,7 +236,7 @@ static irqreturn_t pl010_int(int irq, vo
spin_lock(&uap->port.lock);
@ -134,7 +134,7 @@
if (status) {
do {
if (status & (UART010_IIR_RTIS | UART010_IIR_RIS))
@@ -249,7 +248,7 @@ static irqreturn_t pl010_int(int irq, vo
@@ -250,7 +249,7 @@ static irqreturn_t pl010_int(int irq, vo
if (pass_counter-- == 0)
break;
@ -143,7 +143,7 @@
} while (status & (UART010_IIR_RTIS | UART010_IIR_RIS |
UART010_IIR_TIS));
handled = 1;
@@ -263,7 +262,7 @@ static irqreturn_t pl010_int(int irq, vo
@@ -264,7 +263,7 @@ static irqreturn_t pl010_int(int irq, vo
static unsigned int pl010_tx_empty(struct uart_port *port)
{
struct uart_amba_port *uap = (struct uart_amba_port *)port;
@ -152,7 +152,7 @@
return status & UART01x_FR_BUSY ? 0 : TIOCSER_TEMT;
}
@@ -273,7 +272,7 @@ static unsigned int pl010_get_mctrl(stru
@@ -274,7 +273,7 @@ static unsigned int pl010_get_mctrl(stru
unsigned int result = 0;
unsigned int status;
@ -161,7 +161,7 @@
if (status & UART01x_FR_DCD)
result |= TIOCM_CAR;
if (status & UART01x_FR_DSR)
@@ -299,12 +298,12 @@ static void pl010_break_ctl(struct uart_
@@ -300,12 +299,12 @@ static void pl010_break_ctl(struct uart_
unsigned int lcr_h;
spin_lock_irqsave(&uap->port.lock, flags);
@ -176,7 +176,7 @@
spin_unlock_irqrestore(&uap->port.lock, flags);
}
@@ -332,12 +331,12 @@ static int pl010_startup(struct uart_por
@@ -333,12 +332,12 @@ static int pl010_startup(struct uart_por
/*
* initialise the old status of the modem signals
*/
@ -191,7 +191,7 @@
uap->port.membase + UART010_CR);
return 0;
@@ -360,10 +359,10 @@ static void pl010_shutdown(struct uart_p
@@ -361,10 +360,10 @@ static void pl010_shutdown(struct uart_p
/*
* disable all interrupts, disable the port
*/
@ -204,7 +204,7 @@
~(UART01x_LCRH_BRK | UART01x_LCRH_FEN),
uap->port.membase + UART010_LCRH);
@@ -385,7 +384,7 @@ pl010_set_termios(struct uart_port *port
@@ -386,7 +385,7 @@ pl010_set_termios(struct uart_port *port
/*
* Ask the core to calculate the divisor for us.
*/
@ -213,7 +213,7 @@
quot = uart_get_divisor(port, baud);
switch (termios->c_cflag & CSIZE) {
@@ -448,25 +447,25 @@ pl010_set_termios(struct uart_port *port
@@ -449,25 +448,25 @@ pl010_set_termios(struct uart_port *port
uap->port.ignore_status_mask |= UART_DUMMY_RSR_RX;
/* first, disable everything */
@ -245,7 +245,7 @@
spin_unlock_irqrestore(&uap->port.lock, flags);
}
@@ -538,7 +537,7 @@ static struct uart_ops amba_pl010_pops =
@@ -554,7 +553,7 @@ static struct uart_ops amba_pl010_pops =
.verify_port = pl010_verify_port,
};
@ -254,7 +254,7 @@
#ifdef CONFIG_SERIAL_AMBA_PL010_CONSOLE
@@ -548,10 +547,10 @@ static void pl010_console_putchar(struct
@@ -564,10 +563,10 @@ static void pl010_console_putchar(struct
unsigned int status;
do {
@ -267,7 +267,7 @@
}
static void
@@ -565,8 +564,8 @@ pl010_console_write(struct console *co,
@@ -581,8 +580,8 @@ pl010_console_write(struct console *co,
/*
* First save the CR then disable the interrupts
*/
@ -278,7 +278,7 @@
uart_console_write(&uap->port, s, count, pl010_console_putchar);
@@ -575,10 +574,10 @@ pl010_console_write(struct console *co,
@@ -591,10 +590,10 @@ pl010_console_write(struct console *co,
* and restore the TCR
*/
do {
@ -291,7 +291,7 @@
clk_disable(uap->clk);
}
@@ -587,9 +586,9 @@ static void __init
@@ -603,9 +602,9 @@ static void __init
pl010_console_get_options(struct uart_amba_port *uap, int *baud,
int *parity, int *bits)
{
@ -303,7 +303,7 @@
*parity = 'n';
if (lcr_h & UART01x_LCRH_PEN) {
@@ -604,8 +603,8 @@ pl010_console_get_options(struct uart_am
@@ -620,8 +619,8 @@ pl010_console_get_options(struct uart_am
else
*bits = 8;
@ -314,7 +314,7 @@
*baud = uap->port.uartclk / (16 * (quot + 1));
}
}
@@ -623,7 +622,7 @@ static int __init pl010_console_setup(st
@@ -639,7 +638,7 @@ static int __init pl010_console_setup(st
* if so, search for the first available port that does have
* console support.
*/
@ -323,7 +323,7 @@
co->index = 0;
uap = amba_ports[co->index];
if (!uap)
@@ -641,7 +640,7 @@ static int __init pl010_console_setup(st
@@ -657,7 +656,7 @@ static int __init pl010_console_setup(st
static struct uart_driver amba_reg;
static struct console amba_console = {
@ -332,7 +332,7 @@
.write = pl010_console_write,
.device = uart_console_device,
.setup = pl010_console_setup,
@@ -657,11 +656,11 @@ static struct console amba_console = {
@@ -673,11 +672,11 @@ static struct console amba_console = {
static struct uart_driver amba_reg = {
.owner = THIS_MODULE,

View file

@ -1,6 +1,6 @@
--- a/drivers/leds/leds-gpio.c
+++ b/drivers/leds/leds-gpio.c
@@ -44,13 +44,17 @@ static void gpio_led_set(struct led_clas
@@ -45,13 +45,17 @@ static void gpio_led_set(struct led_clas
container_of(led_cdev, struct gpio_led_data, cdev);
int level;

View file

@ -1,6 +1,6 @@
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -790,6 +790,18 @@ config RC32434_WDT
@@ -807,6 +807,18 @@ config RC32434_WDT
To compile this driver as a module, choose M here: the
module will be called rc32434_wdt.
@ -21,7 +21,7 @@
depends on SGI_HAS_INDYDOG
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -113,6 +113,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
@@ -113,6 +113,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o

View file

@ -1,6 +1,6 @@
--- a/drivers/usb/host/adm5120-dbg.c
+++ b/drivers/usb/host/adm5120-dbg.c
@@ -632,7 +632,7 @@ static ssize_t fill_registers_buffer(str
@@ -642,7 +642,7 @@ static ssize_t fill_registers_buffer(str
hcd->product_desc,
hcd_name);

View file

@ -26,7 +26,7 @@
spin_lock_irqsave(&ahcd->lock, flags);
temp = show_list(ahcd, buf->page, PAGE_SIZE, ahcd->ed_head);
@@ -516,8 +512,6 @@ static ssize_t fill_async_buffer(struct
@@ -516,8 +512,6 @@ static ssize_t fill_async_buffer(struct
static ssize_t fill_periodic_buffer(struct debug_buffer *buf)
{