kernel: refresh patches for 2.6.34-rc5 and update md5sum
SVN-Revision: 21082
This commit is contained in:
parent
81062a12ac
commit
4be3c3e48c
28 changed files with 78 additions and 92 deletions
|
@ -26,8 +26,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),2.6.33.2)
|
||||
LINUX_KERNEL_MD5SUM:=80c5ff544b0ee4d9b5d8b8b89d4a0ef9
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.34-rc4)
|
||||
LINUX_KERNEL_MD5SUM:=45b185f33300bbd69034779748b52c5f
|
||||
ifeq ($(LINUX_VERSION),2.6.34-rc5)
|
||||
LINUX_KERNEL_MD5SUM:=c09ea93cd4e2684ebb506866c65a4c9f
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -166,6 +166,13 @@ ifeq (,$(findstring march=octeon, $(cfla
|
||||
@@ -168,6 +168,13 @@ ifeq (,$(findstring march=octeon, $(cfla
|
||||
cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
|
||||
endif
|
||||
|
||||
|
|
|
@ -44,7 +44,7 @@
|
|||
#error "missing bus glue for ehci-hcd"
|
||||
--- a/drivers/usb/host/ohci-hcd.c
|
||||
+++ b/drivers/usb/host/ohci-hcd.c
|
||||
@@ -1085,6 +1085,11 @@ MODULE_LICENSE ("GPL");
|
||||
@@ -1090,6 +1090,11 @@ MODULE_LICENSE ("GPL");
|
||||
#define TMIO_OHCI_DRIVER ohci_hcd_tmio_driver
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/Kconfig
|
||||
+++ b/drivers/net/Kconfig
|
||||
@@ -2128,6 +2128,8 @@ config ACENIC_OMIT_TIGON_I
|
||||
@@ -2161,6 +2161,8 @@ config ACENIC_OMIT_TIGON_I
|
||||
|
||||
The safe and default value for this is N.
|
||||
|
||||
|
@ -11,7 +11,7 @@
|
|||
depends on PCI
|
||||
--- a/drivers/net/Makefile
|
||||
+++ b/drivers/net/Makefile
|
||||
@@ -106,6 +106,7 @@ obj-$(CONFIG_STMMAC_ETH) += stmmac/
|
||||
@@ -109,6 +109,7 @@ obj-$(CONFIG_STMMAC_ETH) += stmmac/
|
||||
# end link order section
|
||||
#
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/watchdog/Kconfig
|
||||
+++ b/drivers/watchdog/Kconfig
|
||||
@@ -840,6 +840,13 @@ config TXX9_WDT
|
||||
@@ -857,6 +857,13 @@ config TXX9_WDT
|
||||
help
|
||||
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
||||
|
||||
|
@ -16,7 +16,7 @@
|
|||
# POWERPC Architecture
|
||||
--- a/drivers/watchdog/Makefile
|
||||
+++ b/drivers/watchdog/Makefile
|
||||
@@ -112,6 +112,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
|
||||
@@ -113,6 +113,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
|
||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
||||
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/drivers/mtd/maps/Kconfig
|
||||
+++ b/drivers/mtd/maps/Kconfig
|
||||
@@ -257,6 +257,13 @@ config MTD_ALCHEMY
|
||||
@@ -251,6 +251,13 @@ config MTD_NETtel
|
||||
help
|
||||
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
|
||||
Support for flash chips on NETtel/SecureEdge/SnapGear boards.
|
||||
|
||||
+config MTD_AR91XX_FLASH
|
||||
+ tristate "Atheros AR91xx parallel flash support"
|
||||
|
@ -16,7 +16,7 @@
|
|||
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT && BROKEN
|
||||
--- a/drivers/mtd/maps/Makefile
|
||||
+++ b/drivers/mtd/maps/Makefile
|
||||
@@ -40,6 +40,7 @@
|
||||
@@ -40,6 +40,7 @@ obj-$(CONFIG_MTD_SCx200_DOCFLASH)+= scx2
|
||||
obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.o
|
||||
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
|
||||
obj-$(CONFIG_MTD_PCI) += pci.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -922,6 +922,16 @@ static int __devinit m25p_probe(struct s
|
||||
@@ -923,6 +923,16 @@ static int __devinit m25p_probe(struct s
|
||||
part_probes, &parts, 0);
|
||||
}
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -932,6 +932,15 @@ static int __devinit m25p_probe(struct s
|
||||
@@ -933,6 +933,15 @@ static int __devinit m25p_probe(struct s
|
||||
}
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -941,6 +941,16 @@ static int __devinit m25p_probe(struct s
|
||||
@@ -942,6 +942,16 @@ static int __devinit m25p_probe(struct s
|
||||
part_probes, &parts, 0);
|
||||
}
|
||||
#endif
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/net/dsa/tag_trailer.c
|
||||
+++ b/net/dsa/tag_trailer.c
|
||||
@@ -86,7 +86,7 @@ static int trailer_rcv(struct sk_buff *s
|
||||
@@ -87,7 +87,7 @@ static int trailer_rcv(struct sk_buff *s
|
||||
|
||||
trailer = skb_tail_pointer(skb) - 4;
|
||||
if (trailer[0] != 0x80 || (trailer[1] & 0xf8) != 0x00 ||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -365,6 +365,11 @@ config SPI_TLE62X0
|
||||
@@ -386,6 +386,11 @@ config SPI_TLE62X0
|
||||
sysfs interface, with each line presented as a kind of GPIO
|
||||
exposing both switch control and diagnostic feedback.
|
||||
|
||||
|
@ -14,7 +14,7 @@
|
|||
#
|
||||
--- a/drivers/spi/Makefile
|
||||
+++ b/drivers/spi/Makefile
|
||||
@@ -54,6 +54,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
|
||||
@@ -57,6 +57,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
|
||||
|
||||
# SPI protocol drivers (device/link on bus)
|
||||
obj-$(CONFIG_SPI_SPIDEV) += spidev.o
|
||||
|
|
|
@ -17,7 +17,7 @@
|
|||
depends on (ARCH_AT91 || AVR32)
|
||||
--- a/drivers/spi/Makefile
|
||||
+++ b/drivers/spi/Makefile
|
||||
@@ -24,6 +24,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
|
||||
@@ -27,6 +27,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
|
||||
obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
|
||||
obj-$(CONFIG_SPI_IMX) += spi_imx.o
|
||||
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/drivers/leds/Kconfig
|
||||
+++ b/drivers/leds/Kconfig
|
||||
@@ -269,6 +269,13 @@ config LEDS_ADP5520
|
||||
To compile this driver as a module, choose M here: the module will
|
||||
be called leds-adp5520.
|
||||
@@ -294,6 +294,13 @@ config LEDS_TRIGGERS
|
||||
|
||||
if LEDS_TRIGGERS
|
||||
|
||||
+config LEDS_WNDR3700_USB
|
||||
+ tristate "NETGEAR WNDR3700 USB LED driver"
|
||||
|
@ -13,10 +13,10 @@
|
|||
+
|
||||
comment "LED Triggers"
|
||||
|
||||
config LEDS_TRIGGERS
|
||||
config LEDS_TRIGGER_TIMER
|
||||
--- a/drivers/leds/Makefile
|
||||
+++ b/drivers/leds/Makefile
|
||||
@@ -29,6 +29,7 @@ obj-$(CONFIG_LEDS_DA903X) += leds-da903
|
||||
@@ -30,6 +30,7 @@ obj-$(CONFIG_LEDS_DA903X) += leds-da903
|
||||
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
|
||||
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
||||
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/gpio/Kconfig
|
||||
+++ b/drivers/gpio/Kconfig
|
||||
@@ -255,4 +255,12 @@ config GPIO_UCB1400
|
||||
@@ -310,4 +310,12 @@ config GPIO_UCB1400
|
||||
To compile this driver as a module, choose M here: the
|
||||
module will be called ucb1400_gpio.
|
||||
|
||||
|
@ -15,7 +15,7 @@
|
|||
endif
|
||||
--- a/drivers/gpio/Makefile
|
||||
+++ b/drivers/gpio/Makefile
|
||||
@@ -11,6 +11,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
|
||||
@@ -13,6 +13,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
|
||||
obj-$(CONFIG_GPIO_MAX732X) += max732x.o
|
||||
obj-$(CONFIG_GPIO_MC33880) += mc33880.o
|
||||
obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/leds/Kconfig
|
||||
+++ b/drivers/leds/Kconfig
|
||||
@@ -276,6 +276,10 @@ config LEDS_WNDR3700_USB
|
||||
@@ -301,6 +301,10 @@ config LEDS_WNDR3700_USB
|
||||
This option enables support for the USB LED found on the
|
||||
NETGEAR WNDR3700 board.
|
||||
|
||||
|
@ -10,13 +10,13 @@
|
|||
+
|
||||
comment "LED Triggers"
|
||||
|
||||
config LEDS_TRIGGERS
|
||||
config LEDS_TRIGGER_TIMER
|
||||
--- a/drivers/leds/Makefile
|
||||
+++ b/drivers/leds/Makefile
|
||||
@@ -34,6 +34,7 @@ obj-$(CONFIG_LEDS_REGULATOR) += leds-re
|
||||
obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
|
||||
@@ -36,6 +36,7 @@ obj-$(CONFIG_LEDS_INTEL_SS4200) += leds
|
||||
obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o
|
||||
obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
|
||||
obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
|
||||
+obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
|
||||
|
||||
# LED SPI Drivers
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -188,6 +188,7 @@ endif
|
||||
@@ -190,6 +190,7 @@ endif
|
||||
#
|
||||
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
||||
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
extern void check_wait(void);
|
||||
extern asmlinkage void r4k_wait(void);
|
||||
@@ -1501,6 +1502,8 @@
|
||||
@@ -1501,6 +1502,8 @@ void __cpuinit per_cpu_trap_init(void)
|
||||
if (cpu_has_mips_r2) {
|
||||
cp0_compare_irq_shift = CAUSEB_TI - CAUSEB_IP;
|
||||
cp0_compare_irq = (read_c0_intctl() >> INTCTLB_IPTI) & 7;
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/drivers/net/b44.c
|
||||
+++ b/drivers/net/b44.c
|
||||
+++ b/drivers/net/b44.c
|
||||
@@ -384,7 +384,7 @@ static void b44_set_flow_ctrl(struct b44
|
||||
__b44_set_flow_ctrl(bp, pause_enab);
|
||||
}
|
||||
|
|
|
@ -968,7 +968,7 @@
|
|||
{
|
||||
u16 queue_index;
|
||||
struct sock *sk = skb->sk;
|
||||
@@ -1997,6 +2003,7 @@ static struct netdev_queue *dev_pick_tx(
|
||||
@@ -2001,6 +2007,7 @@ static struct netdev_queue *dev_pick_tx(
|
||||
skb_set_queue_mapping(skb, queue_index);
|
||||
return netdev_get_tx_queue(dev, queue_index);
|
||||
}
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale MX2
|
|||
FEATURES:=jffs2
|
||||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.34-rc3
|
||||
LINUX_VERSION:=2.6.34-rc5
|
||||
|
||||
DEVICE_TYPE=phone
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/arm/mach-mx2/Kconfig 2010-04-10 13:56:17.000000000 +0200
|
||||
+++ b/arch/arm/mach-mx2/Kconfig 2010-04-10 13:42:38.000000000 +0200
|
||||
@@ -27,6 +27,12 @@
|
||||
--- a/arch/arm/mach-mx2/Kconfig
|
||||
+++ b/arch/arm/mach-mx2/Kconfig
|
||||
@@ -27,6 +27,12 @@ config MACH_MX21ADS
|
||||
Include support for MX21ADS platform. This includes specific
|
||||
configurations for the board and its peripherals.
|
||||
|
||||
|
@ -13,9 +13,9 @@
|
|||
config MACH_MX27ADS
|
||||
bool "MX27ADS platform"
|
||||
depends on MACH_MX27
|
||||
--- a/arch/arm/mach-mx2/Makefile 2010-04-10 13:56:17.000000000 +0200
|
||||
+++ b/arch/arm/mach-mx2/Makefile 2010-04-10 13:49:32.000000000 +0200
|
||||
@@ -21,3 +21,4 @@
|
||||
--- a/arch/arm/mach-mx2/Makefile
|
||||
+++ b/arch/arm/mach-mx2/Makefile
|
||||
@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_CPUIMX27) += mach-cpui
|
||||
obj-$(CONFIG_MACH_EUKREA_MBIMX27_BASEBOARD) += eukrea_mbimx27-baseboard.o
|
||||
obj-$(CONFIG_MACH_PCA100) += mach-pca100.o
|
||||
obj-$(CONFIG_MACH_MXT_TD60) += mach-mxt_td60.o
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/arm/tools/mach-types 2010-04-10 13:56:20.000000000 +0200
|
||||
+++ b/arch/arm/tools/mach-types 2010-04-10 15:24:46.000000000 +0200
|
||||
@@ -530,7 +530,7 @@
|
||||
--- a/arch/arm/tools/mach-types
|
||||
+++ b/arch/arm/tools/mach-types
|
||||
@@ -530,7 +530,7 @@ sg560 MACH_SG560 SG560 513
|
||||
dp1000 MACH_DP1000 DP1000 514
|
||||
omap_osk MACH_OMAP_OSK OMAP_OSK 515
|
||||
rg100v3 MACH_RG100V3 RG100V3 516
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/arm/mach-mx2/devices.c 2010-04-10 13:56:17.000000000 +0200
|
||||
+++ b/arch/arm/mach-mx2/devices.c 2010-04-10 15:15:17.000000000 +0200
|
||||
@@ -304,7 +304,7 @@
|
||||
--- a/arch/arm/mach-mx2/devices.c
|
||||
+++ b/arch/arm/mach-mx2/devices.c
|
||||
@@ -304,7 +304,7 @@ DEFINE_MXC_MMC_DEVICE(1, MX2x_SDHC2_BASE
|
||||
#ifdef CONFIG_MACH_MX27
|
||||
static struct resource otg_resources[] = {
|
||||
{
|
||||
|
@ -9,7 +9,7 @@
|
|||
.end = MX27_USBOTG_BASE_ADDR + 0x1ff,
|
||||
.flags = IORESOURCE_MEM,
|
||||
}, {
|
||||
@@ -483,8 +483,8 @@
|
||||
@@ -483,8 +483,8 @@ int __init mxc_register_gpios(void)
|
||||
#ifdef CONFIG_MACH_MX21
|
||||
static struct resource mx21_usbhc_resources[] = {
|
||||
{
|
||||
|
|
|
@ -17,8 +17,6 @@ v2: Updated to apply on top of 2.6.34-rc1
|
|||
4 files changed, 12 insertions(+), 0 deletions(-)
|
||||
create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
|
||||
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index 3b18128..3ebc7c3 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -21,6 +21,7 @@ config ARM
|
||||
|
@ -29,26 +27,22 @@ index 3b18128..3ebc7c3 100644
|
|||
select HAVE_PERF_EVENTS
|
||||
select PERF_USE_VMALLOC
|
||||
help
|
||||
diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
|
||||
index 97c89e7..53faa90 100644
|
||||
--- a/arch/arm/boot/compressed/Makefile
|
||||
+++ b/arch/arm/boot/compressed/Makefile
|
||||
@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
|
||||
|
||||
@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/
|
||||
|
||||
suffix_$(CONFIG_KERNEL_GZIP) = gzip
|
||||
suffix_$(CONFIG_KERNEL_LZO) = lzo
|
||||
+suffix_$(CONFIG_KERNEL_LZMA) = lzma
|
||||
|
||||
|
||||
targets := vmlinux vmlinux.lds \
|
||||
piggy.$(suffix_y) piggy.$(suffix_y).o \
|
||||
diff --git a/arch/arm/boot/compressed/decompress.c b/arch/arm/boot/compressed/decompress.c
|
||||
index 0da382f..d554df6 100644
|
||||
--- a/arch/arm/boot/compressed/decompress.c
|
||||
+++ b/arch/arm/boot/compressed/decompress.c
|
||||
@@ -39,6 +39,10 @@ extern void error(char *);
|
||||
@@ -40,6 +40,10 @@ extern void error(char *);
|
||||
#include "../../../../lib/decompress_unlzo.c"
|
||||
#endif
|
||||
|
||||
|
||||
+#ifdef CONFIG_KERNEL_LZMA
|
||||
+#include "../../../../lib/decompress_unlzma.c"
|
||||
+#endif
|
||||
|
@ -56,9 +50,6 @@ index 0da382f..d554df6 100644
|
|||
void do_decompress(u8 *input, int len, u8 *output, void (*error)(char *x))
|
||||
{
|
||||
decompress(input, len, NULL, NULL, output, NULL, error);
|
||||
diff --git a/arch/arm/boot/compressed/piggy.lzma.S b/arch/arm/boot/compressed/piggy.lzma.S
|
||||
new file mode 100644
|
||||
index 0000000..d7e69cf
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/compressed/piggy.lzma.S
|
||||
@@ -0,0 +1,6 @@
|
||||
|
@ -68,6 +59,3 @@ index 0000000..d7e69cf
|
|||
+ .incbin "arch/arm/boot/compressed/piggy.lzma"
|
||||
+ .globl input_data_end
|
||||
+input_data_end:
|
||||
--
|
||||
1.7.0
|
||||
|
||||
|
|
|
@ -1,5 +1,3 @@
|
|||
diff --git a/arch/arm/plat-mxc/pwm.c b/arch/arm/plat-mxc/pwm.c
|
||||
index c36f263..acc5dc1 100644
|
||||
--- a/arch/arm/plat-mxc/pwm.c
|
||||
+++ b/arch/arm/plat-mxc/pwm.c
|
||||
@@ -25,6 +25,11 @@
|
||||
|
@ -14,7 +12,7 @@ index c36f263..acc5dc1 100644
|
|||
|
||||
/* i.MX27, i.MX31, i.MX35 share the same PWM function block: */
|
||||
|
||||
@@ -54,25 +59,32 @@ struct pwm_device {
|
||||
@@ -54,26 +59,33 @@ struct pwm_device {
|
||||
|
||||
int pwm_config(struct pwm_device *pwm, int duty_ns, int period_ns)
|
||||
{
|
||||
|
@ -24,43 +22,45 @@ index c36f263..acc5dc1 100644
|
|||
if (pwm == NULL || period_ns == 0 || duty_ns > period_ns)
|
||||
return -EINVAL;
|
||||
|
||||
- if (cpu_is_mx27() || cpu_is_mx3() || cpu_is_mx25()) {
|
||||
- unsigned long long c;
|
||||
- unsigned long period_cycles, duty_cycles, prescale;
|
||||
- u32 cr;
|
||||
+ c = clk_get_rate(pwm->clk);
|
||||
+
|
||||
+ c = c * period_ns;
|
||||
+
|
||||
+ if (cpu_is_mx1() || cpu_is_mx2())
|
||||
+ c >>= 1;
|
||||
|
||||
- c = clk_get_rate(pwm->clk);
|
||||
- c = c * period_ns;
|
||||
- do_div(c, 1000000000);
|
||||
- period_cycles = c;
|
||||
+
|
||||
+ do_div(c, 1000000000);
|
||||
+ period_cycles = c;
|
||||
|
||||
- prescale = period_cycles / 0x10000 + 1;
|
||||
+
|
||||
+ prescale = period_cycles / 0x10000 + 1;
|
||||
|
||||
- period_cycles /= prescale;
|
||||
- c = (unsigned long long)period_cycles * duty_ns;
|
||||
- do_div(c, period_ns);
|
||||
- duty_cycles = c;
|
||||
+
|
||||
+ period_cycles /= prescale;
|
||||
+ c = (unsigned long long)period_cycles * duty_ns;
|
||||
+ do_div(c, period_ns);
|
||||
+ duty_cycles = c;
|
||||
+
|
||||
+
|
||||
+ if (cpu_is_mx27() || cpu_is_mx3() || cpu_is_mx25()) {
|
||||
+ u32 cr;
|
||||
if (cpu_is_mx27() || cpu_is_mx3() || cpu_is_mx25()) {
|
||||
- unsigned long long c;
|
||||
- unsigned long period_cycles, duty_cycles, prescale;
|
||||
u32 cr;
|
||||
|
||||
- c = clk_get_rate(pwm->clk);
|
||||
- c = c * period_ns;
|
||||
- do_div(c, 1000000000);
|
||||
- period_cycles = c;
|
||||
-
|
||||
- prescale = period_cycles / 0x10000 + 1;
|
||||
-
|
||||
- period_cycles /= prescale;
|
||||
- c = (unsigned long long)period_cycles * duty_ns;
|
||||
- do_div(c, period_ns);
|
||||
- duty_cycles = c;
|
||||
-
|
||||
writel(duty_cycles, pwm->mmio_base + MX3_PWMSAR);
|
||||
writel(period_cycles, pwm->mmio_base + MX3_PWMPR);
|
||||
@@ -86,25 +98,28 @@ int pwm_config(struct pwm_device *pwm, int duty_ns, int period_ns)
|
||||
|
||||
@@ -86,25 +98,28 @@ int pwm_config(struct pwm_device *pwm, i
|
||||
|
||||
writel(cr, pwm->mmio_base + MX3_PWMCR);
|
||||
} else if (cpu_is_mx1() || cpu_is_mx21()) {
|
||||
|
@ -108,7 +108,7 @@ index c36f263..acc5dc1 100644
|
|||
} else {
|
||||
BUG();
|
||||
}
|
||||
@@ -116,6 +130,11 @@ EXPORT_SYMBOL(pwm_config);
|
||||
@@ -116,6 +131,11 @@ EXPORT_SYMBOL(pwm_config);
|
||||
int pwm_enable(struct pwm_device *pwm)
|
||||
{
|
||||
int rc = 0;
|
||||
|
@ -120,7 +120,7 @@ index c36f263..acc5dc1 100644
|
|||
|
||||
if (!pwm->clk_enabled) {
|
||||
rc = clk_enable(pwm->clk);
|
||||
@@ -128,7 +147,13 @@ EXPORT_SYMBOL(pwm_enable);
|
||||
@@ -128,7 +148,13 @@ EXPORT_SYMBOL(pwm_enable);
|
||||
|
||||
void pwm_disable(struct pwm_device *pwm)
|
||||
{
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
+extern char __image_cmdline[];
|
||||
void __init prom_setup_cmdline(void)
|
||||
{
|
||||
static char cmd_line[CL_SIZE] __initdata;
|
||||
static char cmd_line[COMMAND_LINE_SIZE] __initdata;
|
||||
@@ -109,6 +110,9 @@ void __init prom_setup_cmdline(void)
|
||||
}
|
||||
*(cp++) = ' ';
|
||||
|
|
|
@ -25,8 +25,6 @@ Cc: user-mode-linux-devel@lists.sourceforge.net
|
|||
arch/um/kernel/uml.lds.S | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/arch/um/kernel/uml.lds.S b/arch/um/kernel/uml.lds.S
|
||||
index e7a6cca..664f942 100644
|
||||
--- a/arch/um/kernel/uml.lds.S
|
||||
+++ b/arch/um/kernel/uml.lds.S
|
||||
@@ -22,7 +22,7 @@ SECTIONS
|
||||
|
|
|
@ -3,7 +3,7 @@ or as a module
|
|||
|
||||
--- a/lib/Kconfig
|
||||
+++ b/lib/Kconfig
|
||||
@@ -92,7 +92,7 @@ config ZLIB_INFLATE
|
||||
@@ -95,7 +95,7 @@ config ZLIB_INFLATE
|
||||
tristate
|
||||
|
||||
config ZLIB_DEFLATE
|
||||
|
|
Loading…
Reference in a new issue