tools: improve and simplify dosfstools
- use default host install and clean. - backport compatibility patch for OS X and LEDE (avoids having to force iconv for OS X). - use default HOST_BUILD_DIR. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
87b2b89959
commit
4bbc6fb7b7
2 changed files with 27 additions and 11 deletions
|
@ -15,21 +15,10 @@ PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PK
|
||||||
http://fossies.org/linux/misc
|
http://fossies.org/linux/misc
|
||||||
PKG_MD5SUM:=9037738953559d1efe04fc5408b6846216cc0138f7f9d32de80b6ec3c35e7daf
|
PKG_MD5SUM:=9037738953559d1efe04fc5408b6846216cc0138f7f9d32de80b6ec3c35e7daf
|
||||||
|
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
ifeq ($(HOST_OS),Darwin)
|
ifeq ($(HOST_OS),Darwin)
|
||||||
HOST_CFLAGS += -UHAVE_ENDIAN_H
|
HOST_CFLAGS += -UHAVE_ENDIAN_H
|
||||||
LDLIBS += -liconv
|
|
||||||
endif
|
endif
|
||||||
|
|
||||||
define Host/Install
|
|
||||||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/src/mkfs.fat $(STAGING_DIR_HOST)/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Host/Clean
|
|
||||||
rm -f $(STAGING_DIR_HOST)/bin/mk{dosfs,fs.fat}
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call HostBuild))
|
$(eval $(call HostBuild))
|
||||||
|
|
|
@ -0,0 +1,27 @@
|
||||||
|
From 1c6c135ee15e449c1bf2e76d5307f83a3a1d7425 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
|
||||||
|
Date: Tue, 11 Oct 2016 12:07:48 +0200
|
||||||
|
Subject: [PATCH] Switch to AC_CHECK_LIB for iconv library linking.
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
AC_SEARCH_LIB doesn't work properly for openwrt/lede when building dosfstools
|
||||||
|
as a package.
|
||||||
|
|
||||||
|
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -59,7 +59,7 @@ if test "x$with_udev" != "xno"; then
|
||||||
|
[true])
|
||||||
|
fi
|
||||||
|
|
||||||
|
-AC_SEARCH_LIBS(iconv_open, iconv)
|
||||||
|
+AC_CHECK_LIB(iconv, iconv_open)
|
||||||
|
|
||||||
|
AC_CONFIG_FILES([Makefile src/Makefile src/version.h
|
||||||
|
manpages/Makefile manpages/mkfs.fat.8
|
Loading…
Reference in a new issue