adds patch to make Tantos (psb6970) switch buildable again
SVN-Revision: 32006
This commit is contained in:
parent
5aefe3b277
commit
47ef62d1b8
3 changed files with 26 additions and 0 deletions
|
@ -2162,6 +2162,7 @@ CONFIG_PRINTK=y
|
|||
# CONFIG_PRINTK_TIME is not set
|
||||
# CONFIG_PRISM2_USB is not set
|
||||
# CONFIG_PRISM54 is not set
|
||||
# CONFIG_PSB6970_PHY is not set
|
||||
# CONFIG_PROBE_INITRD_HEADER is not set
|
||||
CONFIG_PROC_FS=y
|
||||
# CONFIG_PROC_KCORE is not set
|
||||
|
|
24
target/linux/generic/patches-3.3/729-phy-tantos.patch
Normal file
24
target/linux/generic/patches-3.3/729-phy-tantos.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
Index: linux-3.3.7/drivers/net/phy/Kconfig
|
||||
===================================================================
|
||||
--- linux-3.3.7.orig/drivers/net/phy/Kconfig 2012-05-27 18:09:00.129697447 +0200
|
||||
+++ linux-3.3.7/drivers/net/phy/Kconfig 2012-05-29 18:31:44.462611635 +0200
|
||||
@@ -207,3 +207,7 @@
|
||||
config MICREL_KS8995MA
|
||||
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
|
||||
depends on SPI
|
||||
+
|
||||
+config PSB6970_PHY
|
||||
+ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
|
||||
+ select SWCONFIG
|
||||
Index: linux-3.3.7/drivers/net/phy/Makefile
|
||||
===================================================================
|
||||
--- linux-3.3.7.orig/drivers/net/phy/Makefile 2012-05-27 18:09:00.129697447 +0200
|
||||
+++ linux-3.3.7/drivers/net/phy/Makefile 2012-05-29 18:30:59.286610634 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
|
||||
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
||||
obj-$(CONFIG_MICREL_PHY) += micrel.o
|
||||
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
|
||||
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
||||
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|
||||
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
|
|
@ -107,3 +107,4 @@ CONFIG_SYS_SUPPORTS_BIG_ENDIAN=y
|
|||
CONFIG_SYS_SUPPORTS_MULTITHREADING=y
|
||||
CONFIG_XZ_DEC=y
|
||||
CONFIG_ZONE_DMA_FLAG=0
|
||||
CONFIG_PSB6970_PHY=y
|
||||
|
|
Loading…
Reference in a new issue