kernel: update linux 3.6 to 3.6.11
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34748
This commit is contained in:
parent
b9d314aee9
commit
44b9898251
16 changed files with 17 additions and 80 deletions
|
@ -5,8 +5,8 @@ LINUX_RELEASE?=1
|
||||||
ifeq ($(LINUX_VERSION),3.3.8)
|
ifeq ($(LINUX_VERSION),3.3.8)
|
||||||
LINUX_KERNEL_MD5SUM:=f1058f64eed085deb44f10cee8541d50
|
LINUX_KERNEL_MD5SUM:=f1058f64eed085deb44f10cee8541d50
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.6.10)
|
ifeq ($(LINUX_VERSION),3.6.11)
|
||||||
LINUX_KERNEL_MD5SUM:=a8c2dcd268d3ca2b81908990abd5d382
|
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.7)
|
ifeq ($(LINUX_VERSION),3.7)
|
||||||
LINUX_KERNEL_MD5SUM:=21223369d682bcf44bcdfe1521095983
|
LINUX_KERNEL_MD5SUM:=21223369d682bcf44bcdfe1521095983
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
SUBTARGETS:=generic nand
|
SUBTARGETS:=generic nand
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
||||||
BOARDNAME:=Broadcom BCM947xx/953xx
|
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||||
FEATURES:=squashfs usb pcmcia
|
FEATURES:=squashfs usb pcmcia
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
||||||
BOARD:=brcm63xx
|
BOARD:=brcm63xx
|
||||||
BOARDNAME:=Broadcom BCM63xx
|
BOARDNAME:=Broadcom BCM63xx
|
||||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
|
@ -9,7 +9,7 @@ Subject: [PATCH 6/8] * [rtl8367r] Fix RGMII support
|
||||||
|
|
||||||
--- a/drivers/net/phy/rtl8367.c
|
--- a/drivers/net/phy/rtl8367.c
|
||||||
+++ b/drivers/net/phy/rtl8367.c
|
+++ b/drivers/net/phy/rtl8367.c
|
||||||
@@ -144,6 +144,10 @@
|
@@ -146,6 +146,10 @@
|
||||||
#define RTL8367_EXT_RGMXF_TXDELAY_MASK 1
|
#define RTL8367_EXT_RGMXF_TXDELAY_MASK 1
|
||||||
#define RTL8367_EXT_RGMXF_RXDELAY_MASK 0x7
|
#define RTL8367_EXT_RGMXF_RXDELAY_MASK 0x7
|
||||||
|
|
||||||
|
@ -20,7 +20,7 @@ Subject: [PATCH 6/8] * [rtl8367r] Fix RGMII support
|
||||||
#define RTL8367_DI_FORCE_REG(_x) (0x1310 + (_x))
|
#define RTL8367_DI_FORCE_REG(_x) (0x1310 + (_x))
|
||||||
#define RTL8367_DI_FORCE_MODE BIT(12)
|
#define RTL8367_DI_FORCE_MODE BIT(12)
|
||||||
#define RTL8367_DI_FORCE_NWAY BIT(7)
|
#define RTL8367_DI_FORCE_NWAY BIT(7)
|
||||||
@@ -892,6 +896,7 @@ static int rtl8367_extif_set_mode(struct
|
@@ -894,6 +898,7 @@ static int rtl8367_extif_set_mode(struct
|
||||||
case RTL8367_EXTIF_MODE_RGMII_33V:
|
case RTL8367_EXTIF_MODE_RGMII_33V:
|
||||||
REG_WR(smi, RTL8367_CHIP_DEBUG0_REG, 0x0367);
|
REG_WR(smi, RTL8367_CHIP_DEBUG0_REG, 0x0367);
|
||||||
REG_WR(smi, RTL8367_CHIP_DEBUG1_REG, 0x7777);
|
REG_WR(smi, RTL8367_CHIP_DEBUG1_REG, 0x7777);
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
|
||||||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
From 961a7aeafab477f63d9eef26afde9cbb8badcd0f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Ujfalusi <peter.ujfalusi@ti.com>
|
|
||||||
Date: Mon, 1 Oct 2012 12:29:26 +0300
|
|
||||||
Subject: [PATCH] ASoC: dmaengine: Correct Makefile when sound is built as
|
|
||||||
module
|
|
||||||
|
|
||||||
soc-dmaengine-pcm library need to be part of the snd-soc-core in order to
|
|
||||||
be able to compile ASoC as modules when dmaengine is enabled on the platform.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Ujfalusi <peter.ujfalusi@ti.com>
|
|
||||||
Signed-off-by: Mark Brown <broonie@opensource.wolfsonmicro.com>
|
|
||||||
---
|
|
||||||
sound/soc/Makefile | 5 +++--
|
|
||||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/sound/soc/Makefile
|
|
||||||
+++ b/sound/soc/Makefile
|
|
||||||
@@ -1,8 +1,9 @@
|
|
||||||
snd-soc-core-objs := soc-core.o soc-dapm.o soc-jack.o soc-cache.o soc-utils.o
|
|
||||||
snd-soc-core-objs += soc-pcm.o soc-io.o
|
|
||||||
|
|
||||||
-snd-soc-dmaengine-pcm-objs := soc-dmaengine-pcm.o
|
|
||||||
-obj-$(CONFIG_SND_SOC_DMAENGINE_PCM) += snd-soc-dmaengine-pcm.o
|
|
||||||
+ifneq ($(CONFIG_SND_SOC_DMAENGINE_PCM),)
|
|
||||||
+snd-soc-core-objs += soc-dmaengine-pcm.o
|
|
||||||
+endif
|
|
||||||
|
|
||||||
obj-$(CONFIG_SND_SOC) += snd-soc-core.o
|
|
||||||
obj-$(CONFIG_SND_SOC) += codecs/
|
|
|
@ -1,34 +0,0 @@
|
||||||
From 07b9a6cde27d690ea3331fc2ca2778902d929aaa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Florian Fainelli <florian@openwrt.org>
|
|
||||||
Date: Mon, 10 Dec 2012 20:55:54 +0100
|
|
||||||
Subject: [PATCH] Input: matrix-keymap - provide a proper module license
|
|
||||||
|
|
||||||
The matrix-keymap module is currently lacking a proper module license,
|
|
||||||
add one so we don't have this module tainting the entire kernel. This
|
|
||||||
issue has been present since commit 1932811f (Input: matrix-keymap -
|
|
||||||
uninline and prepare for device tree support)
|
|
||||||
|
|
||||||
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
|
||||||
CC: stable@vger.kernel.org
|
|
||||||
---
|
|
||||||
Dmitry, can you try to push this to Linus before 3.7 final? Thank you
|
|
||||||
|
|
||||||
drivers/input/matrix-keymap.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
--- a/drivers/input/matrix-keymap.c
|
|
||||||
+++ b/drivers/input/matrix-keymap.c
|
|
||||||
@@ -23,6 +23,7 @@
|
|
||||||
#include <linux/input.h>
|
|
||||||
#include <linux/of.h>
|
|
||||||
#include <linux/export.h>
|
|
||||||
+#include <linux/module.h>
|
|
||||||
#include <linux/input/matrix_keypad.h>
|
|
||||||
|
|
||||||
static bool matrix_keypad_map_key(struct input_dev *input_dev,
|
|
||||||
@@ -161,3 +162,5 @@ int matrix_keypad_build_keymap(const str
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
EXPORT_SYMBOL(matrix_keypad_build_keymap);
|
|
||||||
+
|
|
||||||
+MODULE_LICENSE("GPL");
|
|
|
@ -12,7 +12,7 @@
|
||||||
help
|
help
|
||||||
--- a/net/core/Makefile
|
--- a/net/core/Makefile
|
||||||
+++ b/net/core/Makefile
|
+++ b/net/core/Makefile
|
||||||
@@ -8,9 +8,9 @@ obj-y := sock.o request_sock.o skbuff.o
|
@@ -8,9 +8,9 @@ obj-y := sock.o request_sock.o skbuff.o
|
||||||
obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
|
obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
|
||||||
|
|
||||||
obj-y += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
|
obj-y += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
|
||||||
|
|
|
@ -122,7 +122,7 @@
|
||||||
return -ENOMEM;
|
return -ENOMEM;
|
||||||
--- a/mm/vmalloc.c
|
--- a/mm/vmalloc.c
|
||||||
+++ b/mm/vmalloc.c
|
+++ b/mm/vmalloc.c
|
||||||
@@ -2641,6 +2641,8 @@ static const struct file_operations proc
|
@@ -2639,6 +2639,8 @@ static const struct file_operations proc
|
||||||
|
|
||||||
static int __init proc_vmalloc_init(void)
|
static int __init proc_vmalloc_init(void)
|
||||||
{
|
{
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/mm/shmem.c
|
--- a/mm/shmem.c
|
||||||
+++ b/mm/shmem.c
|
+++ b/mm/shmem.c
|
||||||
@@ -2914,6 +2914,16 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
|
@@ -2920,6 +2920,16 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
|
||||||
|
|
||||||
/* common code */
|
/* common code */
|
||||||
|
|
||||||
|
@ -17,7 +17,7 @@
|
||||||
/**
|
/**
|
||||||
* shmem_file_setup - get an unlinked file living in tmpfs
|
* shmem_file_setup - get an unlinked file living in tmpfs
|
||||||
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
||||||
@@ -2991,11 +3001,8 @@ int shmem_zero_setup(struct vm_area_stru
|
@@ -2997,11 +3007,8 @@ int shmem_zero_setup(struct vm_area_stru
|
||||||
if (IS_ERR(file))
|
if (IS_ERR(file))
|
||||||
return PTR_ERR(file);
|
return PTR_ERR(file);
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=\
|
DEFAULT_PACKAGES+=\
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
||||||
BOARDNAME:=Sun UltraSPARC
|
BOARDNAME:=Sun UltraSPARC
|
||||||
FEATURES+=fpu tgz jffs2 ext4 squashfs
|
FEATURES+=fpu tgz jffs2 ext4 squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
||||||
kmod-cpu-msr \
|
kmod-cpu-msr \
|
||||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||||
hwclock wpad flashrom tc
|
hwclock wpad flashrom tc
|
||||||
LINUX_VERSION:=3.6.10
|
LINUX_VERSION:=3.6.11
|
||||||
CS5535_MASK:=0x0E000048
|
CS5535_MASK:=0x0E000048
|
||||||
|
|
||||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||||
|
|
Loading…
Reference in a new issue