mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after lzma and ~12k squashfs size in the default configuration
SVN-Revision: 34909
This commit is contained in:
parent
e7719bb4aa
commit
41a039f464
7 changed files with 27 additions and 5 deletions
|
@ -193,7 +193,7 @@ ifeq ($(DUMP),1)
|
||||||
DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -fno-caller-saves
|
DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -fno-caller-saves
|
||||||
DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -fno-caller-saves
|
DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -fno-caller-saves
|
||||||
DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -fno-caller-saves
|
DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -fno-caller-saves
|
||||||
DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves
|
DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -mno-branch-likely
|
||||||
DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
|
DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
|
||||||
DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -fno-caller-saves
|
DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -fno-caller-saves
|
||||||
DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
|
DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
|
||||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
||||||
BOARD:=ar71xx
|
BOARD:=ar71xx
|
||||||
BOARDNAME:=Atheros AR7xxx/AR9xxx
|
BOARDNAME:=Atheros AR7xxx/AR9xxx
|
||||||
FEATURES:=squashfs jffs2 targz
|
FEATURES:=squashfs jffs2 targz
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
SUBTARGETS:=generic nand
|
SUBTARGETS:=generic nand
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.11
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/arch/mips/Makefile
|
||||||
|
+++ b/arch/mips/Makefile
|
||||||
|
@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
|
||||||
|
# machines may also. Since BFD is incredibly buggy with respect to
|
||||||
|
# crossformat linking we rely on the elf2ecoff tool for format conversion.
|
||||||
|
#
|
||||||
|
-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
||||||
|
+cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
|
||||||
|
cflags-y += -msoft-float
|
||||||
|
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
|
||||||
|
KBUILD_AFLAGS_MODULE += -mlong-calls
|
|
@ -1,7 +1,7 @@
|
||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -90,8 +90,8 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
|
@@ -90,8 +90,8 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
|
||||||
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
|
||||||
cflags-y += -msoft-float
|
cflags-y += -msoft-float
|
||||||
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
|
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
|
||||||
-KBUILD_AFLAGS_MODULE += -mlong-calls
|
-KBUILD_AFLAGS_MODULE += -mlong-calls
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/arch/mips/Makefile
|
||||||
|
+++ b/arch/mips/Makefile
|
||||||
|
@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
|
||||||
|
# machines may also. Since BFD is incredibly buggy with respect to
|
||||||
|
# crossformat linking we rely on the elf2ecoff tool for format conversion.
|
||||||
|
#
|
||||||
|
-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
||||||
|
+cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
|
||||||
|
cflags-y += -msoft-float
|
||||||
|
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
|
||||||
|
KBUILD_AFLAGS_MODULE += -mlong-calls
|
|
@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.1
|
LINUX_VERSION:=3.7.1
|
||||||
|
|
||||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
|
|
||||||
define Target/Description
|
define Target/Description
|
||||||
Build firmware images for Lantiq SoC
|
Build firmware images for Lantiq SoC
|
||||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mipsel
|
||||||
BOARD:=ramips
|
BOARD:=ramips
|
||||||
BOARDNAME:=Ralink RT288x/RT3xxx
|
BOARDNAME:=Ralink RT288x/RT3xxx
|
||||||
SUBTARGETS:=rt288x rt305x rt3883
|
SUBTARGETS:=rt288x rt305x rt3883
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.6.11
|
LINUX_VERSION:=3.6.11
|
||||||
|
|
Loading…
Reference in a new issue