iptables: Update to 1.4.20
SVN-Revision: 37865
This commit is contained in:
parent
e532d65373
commit
3e647ac9b6
3 changed files with 7 additions and 20 deletions
|
@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=iptables
|
||||
PKG_VERSION:=1.4.19.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.4.20
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
|
||||
ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
|
||||
ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
|
||||
ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
|
||||
PKG_MD5SUM:=be97ce9007fa42c867901b496c935a0a
|
||||
PKG_MD5SUM:=387b92d3efcf4f07fe31c3bf0f1d18f5
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -77,10 +77,10 @@ Index: iptables-1.4.18/iptables/ip6tables-restore.c
|
|||
DEBUGP("argv[%u]: %s\n", a, newargv[a]);
|
||||
|
||||
- ret = do_command6(newargc, newargv,
|
||||
- &newargv[2], &handle);
|
||||
- &newargv[2], &handle, true);
|
||||
+ if (!setjmp(jmp))
|
||||
+ ret = do_command6(newargc, newargv,
|
||||
+ &newargv[2], &handle);
|
||||
+ &newargv[2], &handle, true);
|
||||
+ else
|
||||
+ ret = 1;
|
||||
|
||||
|
@ -165,10 +165,10 @@ Index: iptables-1.4.18/iptables/iptables-restore.c
|
|||
DEBUGP("argv[%u]: %s\n", a, newargv[a]);
|
||||
|
||||
- ret = do_command4(newargc, newargv,
|
||||
- &newargv[2], &handle);
|
||||
- &newargv[2], &handle, true);
|
||||
+ if (!setjmp(jmp))
|
||||
+ ret = do_command4(newargc, newargv,
|
||||
+ &newargv[2], &handle);
|
||||
+ &newargv[2], &handle, true);
|
||||
+ else
|
||||
+ ret = 1;
|
||||
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Index: iptables-1.4.19.1/extensions/libxt_recent.c
|
||||
===================================================================
|
||||
--- iptables-1.4.19.1.orig/extensions/libxt_recent.c
|
||||
+++ iptables-1.4.19.1/extensions/libxt_recent.c
|
||||
@@ -63,6 +63,8 @@ static const struct xt_option_entry rece
|
||||
.excl = F_ANY_OP, .flags = XTOPT_INVERT},
|
||||
{.name = "seconds", .id = O_SECONDS, .type = XTTYPE_UINT32,
|
||||
.flags = XTOPT_PUT, XTOPT_POINTER(s, seconds)},
|
||||
+ {.name = "reap", .id = O_REAP, .type = XTTYPE_NONE,
|
||||
+ .also = F_SECONDS },
|
||||
{.name = "hitcount", .id = O_HITCOUNT, .type = XTTYPE_UINT32,
|
||||
.flags = XTOPT_PUT, XTOPT_POINTER(s, hit_count)},
|
||||
{.name = "rttl", .id = O_RTTL, .type = XTTYPE_NONE,
|
Loading…
Reference in a new issue