package/busybox: update to 1.16.2 (bug fix release)
SVN-Revision: 21813
This commit is contained in:
parent
3e52d05296
commit
3dc2c3bb4d
9 changed files with 3 additions and 322 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=busybox
|
||||
PKG_VERSION:=1.16.1
|
||||
PKG_RELEASE:=7
|
||||
PKG_VERSION:=1.16.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
||||
http://distfiles.gentoo.org/distfiles/
|
||||
PKG_MD5SUM:=319486ec65078d07fde26eb620fecde7
|
||||
PKG_MD5SUM:=2ba980f720a5bdce4ec05423519acc35
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- a/shell/ash.c
|
||||
+++ b/shell/ash.c
|
||||
@@ -5424,7 +5424,11 @@ rmescapes(char *str, int flag)
|
||||
size_t fulllen = len + strlen(p) + 1;
|
||||
|
||||
if (flag & RMESCAPE_GROW) {
|
||||
+ int strloc = str - (char *)stackblock();
|
||||
r = makestrspace(fulllen, expdest);
|
||||
+ /* p and str may be invalidated by makestrspace */
|
||||
+ str = (char *)stackblock() + strloc;
|
||||
+ p = str + len;
|
||||
} else if (flag & RMESCAPE_HEAP) {
|
||||
r = ckmalloc(fulllen);
|
||||
} else {
|
|
@ -1,49 +0,0 @@
|
|||
--- a/archival/cpio.c
|
||||
+++ b/archival/cpio.c
|
||||
@@ -424,7 +424,7 @@ int cpio_main(int argc UNUSED_PARAM, cha
|
||||
if (archive_handle->cpio__blocks != (off_t)-1
|
||||
&& !(opt & CPIO_OPT_QUIET)
|
||||
) {
|
||||
- printf("%"OFF_FMT"u blocks\n", archive_handle->cpio__blocks);
|
||||
+ fprintf(stderr, "%"OFF_FMT"u blocks\n", archive_handle->cpio__blocks);
|
||||
}
|
||||
|
||||
return EXIT_SUCCESS;
|
||||
--- a/testsuite/cpio.tests
|
||||
+++ b/testsuite/cpio.tests
|
||||
@@ -32,7 +32,7 @@ rm -rf cpio.testdir cpio.testdir2 2>/dev
|
||||
# testing "test name" "command" "expected result" "file input" "stdin"
|
||||
|
||||
testing "cpio extracts zero-sized hardlinks" \
|
||||
-"$ECHO -ne '$hexdump' | bzcat | cpio -i; echo \$?;
|
||||
+"$ECHO -ne '$hexdump' | bzcat | cpio -i 2>&1; echo \$?;
|
||||
ls -ln cpio.testdir | $FILTER_LS" \
|
||||
"\
|
||||
1 blocks
|
||||
@@ -45,7 +45,7 @@ ls -ln cpio.testdir | $FILTER_LS" \
|
||||
|
||||
test x"$SKIP_KNOWN_BUGS" = x"" && {
|
||||
# Currently fails. Numerous buglets: "1 blocks" versus "1 block",
|
||||
-# "1 block" must go to stderr, does not list cpio.testdir/x and cpio.testdir/y
|
||||
+# does not list cpio.testdir/x and cpio.testdir/y
|
||||
testing "cpio lists hardlinks" \
|
||||
"$ECHO -ne '$hexdump' | bzcat | cpio -t 2>&1; echo \$?" \
|
||||
"\
|
||||
@@ -70,7 +70,7 @@ ln cpio.testdir/nonempty cpio.testdir/no
|
||||
mkdir cpio.testdir2
|
||||
|
||||
testing "cpio extracts zero-sized hardlinks 2" \
|
||||
-"find cpio.testdir | cpio -H newc --create | (cd cpio.testdir2 && cpio -i); echo \$?;
|
||||
+"find cpio.testdir | cpio -H newc --create | (cd cpio.testdir2 && cpio -i 2>&1); echo \$?;
|
||||
ls -ln cpio.testdir2/cpio.testdir | $FILTER_LS" \
|
||||
"\
|
||||
2 blocks
|
||||
@@ -87,7 +87,7 @@ ls -ln cpio.testdir2/cpio.testdir | $FIL
|
||||
# Was trying to create "/usr/bin", correct is "usr/bin".
|
||||
rm -rf cpio.testdir
|
||||
testing "cpio -p with absolute paths" \
|
||||
-"echo /usr/bin | cpio -dp cpio.testdir; echo \$?;
|
||||
+"echo /usr/bin | cpio -dp cpio.testdir 2>&1; echo \$?;
|
||||
ls cpio.testdir" \
|
||||
"\
|
||||
1 blocks
|
|
@ -1,11 +0,0 @@
|
|||
--- a/networking/udhcp/leases.c
|
||||
+++ b/networking/udhcp/leases.c
|
||||
@@ -64,6 +64,8 @@ struct dyn_lease* FAST_FUNC add_lease(
|
||||
oldest->hostname[0] = '\0';
|
||||
if (hostname) {
|
||||
char *p;
|
||||
+
|
||||
+ hostname_len++; /* include NUL */
|
||||
if (hostname_len > sizeof(oldest->hostname))
|
||||
hostname_len = sizeof(oldest->hostname);
|
||||
p = safe_strncpy(oldest->hostname, hostname, hostname_len);
|
|
@ -1,27 +0,0 @@
|
|||
--- a/include/platform.h
|
||||
+++ b/include/platform.h
|
||||
@@ -291,10 +291,12 @@ typedef unsigned smalluint;
|
||||
#if 1 /* if needed: !defined(arch1) && !defined(arch2) */
|
||||
# define ALIGN1 __attribute__((aligned(1)))
|
||||
# define ALIGN2 __attribute__((aligned(2)))
|
||||
+# define ALIGN4 __attribute__((aligned(4)))
|
||||
#else
|
||||
/* Arches which MUST have 2 or 4 byte alignment for everything are here */
|
||||
# define ALIGN1
|
||||
# define ALIGN2
|
||||
+# define ALIGN4
|
||||
#endif
|
||||
|
||||
|
||||
--- a/networking/dnsd.c
|
||||
+++ b/networking/dnsd.c
|
||||
@@ -459,7 +459,8 @@ int dnsd_main(int argc UNUSED_PARAM, cha
|
||||
unsigned lsa_size;
|
||||
int udps, opts;
|
||||
uint16_t port = 53;
|
||||
- uint8_t buf[MAX_PACK_LEN + 1];
|
||||
+ /* Ensure buf is 32bit aligned (we need 16bit, but 32bit can't hurt) */
|
||||
+ uint8_t buf[MAX_PACK_LEN + 1] ALIGN4;
|
||||
|
||||
opts = getopt32(argv, "vi:c:t:p:d", &listen_interface, &fileconf, &sttl, &sport);
|
||||
//if (opts & 0x1) // -v
|
|
@ -1,11 +0,0 @@
|
|||
--- a/shell/hush.c
|
||||
+++ b/shell/hush.c
|
||||
@@ -6944,7 +6944,7 @@ int hush_main(int argc, char **argv)
|
||||
/* -c 'script' (no params): prevent empty $0 */
|
||||
G.global_argv--; /* points to argv[i] of 'script' */
|
||||
G.global_argv[0] = argv[0];
|
||||
- G.global_argc--;
|
||||
+ G.global_argc++;
|
||||
} /* else -c 'script' ARG0 [ARG1...]: $0 is ARG0 */
|
||||
init_sigmasks();
|
||||
parse_and_run_string(optarg);
|
|
@ -1,151 +0,0 @@
|
|||
--- a/util-linux/hwclock.c
|
||||
+++ b/util-linux/hwclock.c
|
||||
@@ -109,10 +109,53 @@ static void to_sys_clock(const char **pp
|
||||
|
||||
static void from_sys_clock(const char **pp_rtcname, int utc)
|
||||
{
|
||||
-#define TWEAK_USEC 200
|
||||
- struct tm tm_time;
|
||||
+#if 1
|
||||
struct timeval tv;
|
||||
+ struct tm tm_time;
|
||||
+ int rtc;
|
||||
+
|
||||
+ rtc = rtc_xopen(pp_rtcname, O_WRONLY);
|
||||
+ gettimeofday(&tv, NULL);
|
||||
+ /* Prepare tm_time */
|
||||
+ if (sizeof(time_t) == sizeof(tv.tv_sec)) {
|
||||
+ if (utc)
|
||||
+ gmtime_r((time_t*)&tv.tv_sec, &tm_time);
|
||||
+ else
|
||||
+ localtime_r((time_t*)&tv.tv_sec, &tm_time);
|
||||
+ } else {
|
||||
+ time_t t = tv.tv_sec;
|
||||
+ if (utc)
|
||||
+ gmtime_r(&t, &tm_time);
|
||||
+ else
|
||||
+ localtime_r(&t, &tm_time);
|
||||
+ }
|
||||
+#else
|
||||
+/* Bloated code which tries to set hw clock with better precision.
|
||||
+ * On x86, even though code does set hw clock within <1ms of exact
|
||||
+ * whole seconds, apparently hw clock (at least on some machines)
|
||||
+ * doesn't reset internal fractional seconds to 0,
|
||||
+ * making all this a pointless excercise.
|
||||
+ */
|
||||
+ /* If we see that we are N usec away from whole second,
|
||||
+ * we'll sleep for N-ADJ usecs. ADJ corrects for the fact
|
||||
+ * that CPU is not infinitely fast.
|
||||
+ * On infinitely fast CPU, next wakeup would be
|
||||
+ * on (exactly_next_whole_second - ADJ). On real CPUs,
|
||||
+ * this difference between current time and whole second
|
||||
+ * is less than ADJ (assuming system isn't heavily loaded).
|
||||
+ */
|
||||
+ /* Small value of 256us gives very precise sync for 2+ GHz CPUs.
|
||||
+ * Slower CPUs will fail to sync and will go to bigger
|
||||
+ * ADJ values. qemu-emulated armv4tl with ~100 MHz
|
||||
+ * performance ends up using ADJ ~= 4*1024 and it takes
|
||||
+ * 2+ secs (2 tries with successively larger ADJ)
|
||||
+ * to sync. Even straced one on the same qemu (very slow)
|
||||
+ * takes only 4 tries.
|
||||
+ */
|
||||
+#define TWEAK_USEC 256
|
||||
unsigned adj = TWEAK_USEC;
|
||||
+ struct tm tm_time;
|
||||
+ struct timeval tv;
|
||||
int rtc = rtc_xopen(pp_rtcname, O_WRONLY);
|
||||
|
||||
/* Try to catch the moment when whole second is close */
|
||||
@@ -124,55 +167,64 @@ static void from_sys_clock(const char **
|
||||
|
||||
t = tv.tv_sec;
|
||||
rem_usec = 1000000 - tv.tv_usec;
|
||||
- if (rem_usec < 1024) {
|
||||
- /* Less than 1ms to next second. Good enough */
|
||||
+ if (rem_usec < adj) {
|
||||
+ /* Close enough */
|
||||
small_rem:
|
||||
t++;
|
||||
}
|
||||
|
||||
- /* Prepare tm */
|
||||
+ /* Prepare tm_time from t */
|
||||
if (utc)
|
||||
gmtime_r(&t, &tm_time); /* may read /etc/xxx (it takes time) */
|
||||
else
|
||||
localtime_r(&t, &tm_time); /* same */
|
||||
- tm_time.tm_isdst = 0;
|
||||
+
|
||||
+ if (adj >= 32*1024) {
|
||||
+ break; /* 32 ms diff and still no luck?? give up trying to sync */
|
||||
+ }
|
||||
|
||||
/* gmtime/localtime took some time, re-get cur time */
|
||||
gettimeofday(&tv, NULL);
|
||||
|
||||
- if (tv.tv_sec < t /* may happen if rem_usec was < 1024 */
|
||||
- || (tv.tv_sec == t && tv.tv_usec < 1024)
|
||||
+ if (tv.tv_sec < t /* we are still in old second */
|
||||
+ || (tv.tv_sec == t && tv.tv_usec < adj) /* not too far into next second */
|
||||
) {
|
||||
- /* We are not too far into next second. Good. */
|
||||
- break;
|
||||
- }
|
||||
- adj += 32; /* 2^(10-5) = 2^5 = 32 iterations max */
|
||||
- if (adj >= 1024) {
|
||||
- /* Give up trying to sync */
|
||||
- break;
|
||||
+ break; /* good, we are in sync! */
|
||||
}
|
||||
|
||||
- /* Try to sync up by sleeping */
|
||||
rem_usec = 1000000 - tv.tv_usec;
|
||||
- if (rem_usec < 1024) {
|
||||
- goto small_rem; /* already close, don't sleep */
|
||||
+ if (rem_usec < adj) {
|
||||
+ t = tv.tv_sec;
|
||||
+ goto small_rem; /* already close to next sec, don't sleep */
|
||||
}
|
||||
- /* Need to sleep.
|
||||
- * Note that small adj on slow processors can make us
|
||||
- * to always overshoot tv.tv_usec < 1024 check on next
|
||||
- * iteration. That's why adj is increased on each iteration.
|
||||
- * This also allows it to be reused as a loop limiter.
|
||||
- */
|
||||
- usleep(rem_usec - adj);
|
||||
- }
|
||||
|
||||
- xioctl(rtc, RTC_SET_TIME, &tm_time);
|
||||
+ /* Try to sync up by sleeping */
|
||||
+ usleep(rem_usec - adj);
|
||||
|
||||
- /* Debug aid to find "good" TWEAK_USEC.
|
||||
+ /* Jump to 1ms diff, then increase fast (x2): EVERY loop
|
||||
+ * takes ~1 sec, people won't like slowly converging code here!
|
||||
+ */
|
||||
+ //bb_error_msg("adj:%d tv.tv_usec:%d", adj, (int)tv.tv_usec);
|
||||
+ if (adj < 512)
|
||||
+ adj = 512;
|
||||
+ /* ... and if last "overshoot" does not look insanely big,
|
||||
+ * just use it as adj increment. This makes convergence faster.
|
||||
+ */
|
||||
+ if (tv.tv_usec < adj * 8) {
|
||||
+ adj += tv.tv_usec;
|
||||
+ continue;
|
||||
+ }
|
||||
+ adj *= 2;
|
||||
+ }
|
||||
+ /* Debug aid to find "optimal" TWEAK_USEC with nearly exact sync.
|
||||
* Look for a value which makes tv_usec close to 999999 or 0.
|
||||
- * for 2.20GHz Intel Core 2: TWEAK_USEC ~= 200
|
||||
+ * For 2.20GHz Intel Core 2: optimal TWEAK_USEC ~= 200
|
||||
*/
|
||||
- //bb_error_msg("tv.tv_usec:%d adj:%d", (int)tv.tv_usec, adj);
|
||||
+ //bb_error_msg("tv.tv_usec:%d", (int)tv.tv_usec);
|
||||
+#endif
|
||||
+
|
||||
+ tm_time.tm_isdst = 0;
|
||||
+ xioctl(rtc, RTC_SET_TIME, &tm_time);
|
||||
|
||||
if (ENABLE_FEATURE_CLEAN_UP)
|
||||
close(rtc);
|
|
@ -1,11 +0,0 @@
|
|||
--- a/networking/httpd_indexcgi.c
|
||||
+++ b/networking/httpd_indexcgi.c
|
||||
@@ -315,7 +315,7 @@ int main(int argc, char *argv[])
|
||||
if (S_ISREG(cdir->dl_mode))
|
||||
fmt_ull(cdir->dl_size);
|
||||
fmt_str("<td class=dt>");
|
||||
- tm = gmtime(&cdir->dl_mtime);
|
||||
+ ptm = gmtime(&cdir->dl_mtime);
|
||||
fmt_04u(1900 + ptm->tm_year); *dst++ = '-';
|
||||
fmt_02u(ptm->tm_mon + 1); *dst++ = '-';
|
||||
fmt_02u(ptm->tm_mday); *dst++ = ' ';
|
|
@ -1,45 +0,0 @@
|
|||
--- a/editors/sed.c
|
||||
+++ b/editors/sed.c
|
||||
@@ -936,7 +936,15 @@ static void process_files(void)
|
||||
/* Skip blocks of commands we didn't match */
|
||||
if (sed_cmd->cmd == '{') {
|
||||
if (sed_cmd->invert ? matched : !matched) {
|
||||
- while (sed_cmd->cmd != '}') {
|
||||
+ unsigned nest_cnt = 0;
|
||||
+ while (1) {
|
||||
+ if (sed_cmd->cmd == '{')
|
||||
+ nest_cnt++;
|
||||
+ if (sed_cmd->cmd == '}') {
|
||||
+ nest_cnt--;
|
||||
+ if (nest_cnt == 0)
|
||||
+ break;
|
||||
+ }
|
||||
sed_cmd = sed_cmd->next;
|
||||
if (!sed_cmd)
|
||||
bb_error_msg_and_die("unterminated {");
|
||||
@@ -1031,7 +1039,7 @@ static void process_files(void)
|
||||
case 'c':
|
||||
/* Only triggers on last line of a matching range. */
|
||||
if (!sed_cmd->in_match)
|
||||
- sed_puts(sed_cmd->string, NO_EOL_CHAR);
|
||||
+ sed_puts(sed_cmd->string, '\n');
|
||||
goto discard_line;
|
||||
|
||||
/* Read file, append contents to output */
|
||||
--- a/testsuite/sed.tests
|
||||
+++ b/testsuite/sed.tests
|
||||
@@ -248,4 +248,14 @@ testing "sed beginning (^) matches only
|
||||
">/usr</>lib<\n" "" \
|
||||
"/usr/lib\n"
|
||||
|
||||
+testing "sed c" \
|
||||
+ "sed 'crepl'" \
|
||||
+ "repl\nrepl\n" "" \
|
||||
+ "first\nsecond\n"
|
||||
+
|
||||
+testing "sed nested {}s" \
|
||||
+ "sed '/asd/ { p; /s/ { s/s/c/ }; p; q }'" \
|
||||
+ "qwe\nasd\nacd\nacd\n" "" \
|
||||
+ "qwe\nasd\nzxc\n"
|
||||
+
|
||||
exit $FAILCOUNT
|
Loading…
Reference in a new issue