moko: Fix patch so it applies properly. This fixes kernel boot due to other patches in the stack that weren't applied due to the failure.
SVN-Revision: 13617
This commit is contained in:
parent
562ff99c2c
commit
3b7b17ac65
1 changed files with 53 additions and 38 deletions
|
@ -1,6 +1,7 @@
|
|||
diff -ruN linux-2.6.26.orig/Documentation/gpiommc.txt linux-2.6.26/Documentation/gpiommc.txt
|
||||
--- linux-2.6.26.orig/Documentation/gpiommc.txt 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/Documentation/gpiommc.txt 1970-01-01 01:00:00.000000000 +0100
|
||||
Index: linux-2.6.26/Documentation/gpiommc.txt
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/Documentation/gpiommc.txt 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
@@ -1,97 +0,0 @@
|
||||
-GPIOMMC - Driver for an MMC/SD card on a bitbanging GPIO SPI bus
|
||||
-================================================================
|
||||
|
@ -99,10 +100,11 @@ diff -ruN linux-2.6.26.orig/Documentation/gpiommc.txt linux-2.6.26/Documentation
|
|||
-(/config/gpiommc/my_mmc in this example).
|
||||
-There's no need to first unregister the device before removing it. That will
|
||||
-be done automatically.
|
||||
diff -ruN linux-2.6.26.orig/drivers/mmc/host/gpiommc.c linux-2.6.26/drivers/mmc/host/gpiommc.c
|
||||
--- linux-2.6.26.orig/drivers/mmc/host/gpiommc.c 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/drivers/mmc/host/gpiommc.c 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,619 +0,0 @@
|
||||
Index: linux-2.6.26/drivers/mmc/host/gpiommc.c
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/drivers/mmc/host/gpiommc.c 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
@@ -1,624 +0,0 @@
|
||||
-/*
|
||||
- * Driver an MMC/SD card on a bitbanging GPIO SPI bus.
|
||||
- * This module hooks up the mmc_spi and spi_gpio modules and also
|
||||
|
@ -113,11 +115,13 @@ diff -ruN linux-2.6.26.orig/drivers/mmc/host/gpiommc.c linux-2.6.26/drivers/mmc/
|
|||
- * Licensed under the GNU/GPL. See COPYING for details.
|
||||
- */
|
||||
-
|
||||
-#include <linux/mmc/gpiommc.h>
|
||||
-#include <linux/platform_device.h>
|
||||
-#include <linux/list.h>
|
||||
-#include <linux/mutex.h>
|
||||
-#include <linux/mmc/gpiommc.h>
|
||||
-#include <linux/mmc/host.h>
|
||||
-#include <linux/spi/spi_gpio.h>
|
||||
-#include <linux/spi/mmc_spi.h>
|
||||
-#include <linux/configfs.h>
|
||||
-#include <linux/gpio.h>
|
||||
-#include <asm/atomic.h>
|
||||
|
@ -130,6 +134,7 @@ diff -ruN linux-2.6.26.orig/drivers/mmc/host/gpiommc.c linux-2.6.26/drivers/mmc/
|
|||
- struct platform_device *pdev;
|
||||
- struct platform_device *spi_pdev;
|
||||
- struct spi_board_info boardinfo;
|
||||
- struct mmc_spi_platform_data mmc_spi_data;
|
||||
-};
|
||||
-
|
||||
-
|
||||
|
@ -151,6 +156,7 @@ diff -ruN linux-2.6.26.orig/drivers/mmc/host/gpiommc.c linux-2.6.26/drivers/mmc/
|
|||
- bi->max_speed_hz = pdata->max_bus_speed;
|
||||
- bi->bus_num = master->bus_num;
|
||||
- bi->mode = pdata->mode;
|
||||
- bi->platform_data = &d->mmc_spi_data;
|
||||
-
|
||||
- return 0;
|
||||
-}
|
||||
|
@ -180,6 +186,7 @@ diff -ruN linux-2.6.26.orig/drivers/mmc/host/gpiommc.c linux-2.6.26/drivers/mmc/
|
|||
- if (!d)
|
||||
- goto error;
|
||||
- d->pdev = pdev;
|
||||
- d->mmc_spi_data.ocr_mask = MMC_VDD_32_33 | MMC_VDD_33_34;
|
||||
-
|
||||
- /* Create the SPI-GPIO device */
|
||||
- d->spi_pdev = platform_device_alloc(SPI_GPIO_PLATDEV_NAME,
|
||||
|
@ -722,10 +729,11 @@ diff -ruN linux-2.6.26.orig/drivers/mmc/host/gpiommc.c linux-2.6.26/drivers/mmc/
|
|||
- platform_driver_unregister(&gpiommc_plat_driver);
|
||||
-}
|
||||
-module_exit(gpiommc_modexit);
|
||||
diff -ruN linux-2.6.26.orig/drivers/mmc/host/Kconfig linux-2.6.26/drivers/mmc/host/Kconfig
|
||||
--- linux-2.6.26.orig/drivers/mmc/host/Kconfig 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/drivers/mmc/host/Kconfig 2008-10-24 21:03:47.000000000 +0200
|
||||
@@ -130,27 +130,3 @@
|
||||
Index: linux-2.6.26/drivers/mmc/host/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/drivers/mmc/host/Kconfig 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ linux-2.6.26/drivers/mmc/host/Kconfig 2008-12-12 21:55:25.000000000 +0100
|
||||
@@ -130,27 +130,3 @@ config MMC_SPI
|
||||
|
||||
If unsure, or if your system has no SPI master driver, say N.
|
||||
|
||||
|
@ -753,19 +761,21 @@ diff -ruN linux-2.6.26.orig/drivers/mmc/host/Kconfig linux-2.6.26/drivers/mmc/ho
|
|||
- help
|
||||
- This option automatically enables configfs support for gpiommc
|
||||
- if configfs is available.
|
||||
diff -ruN linux-2.6.26.orig/drivers/mmc/host/Makefile linux-2.6.26/drivers/mmc/host/Makefile
|
||||
--- linux-2.6.26.orig/drivers/mmc/host/Makefile 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/drivers/mmc/host/Makefile 2008-10-24 21:03:47.000000000 +0200
|
||||
@@ -17,4 +17,4 @@
|
||||
Index: linux-2.6.26/drivers/mmc/host/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/drivers/mmc/host/Makefile 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ linux-2.6.26/drivers/mmc/host/Makefile 2008-12-12 21:55:25.000000000 +0100
|
||||
@@ -17,4 +17,4 @@ obj-$(CONFIG_MMC_OMAP) += omap.o
|
||||
obj-$(CONFIG_MMC_AT91) += at91_mci.o
|
||||
obj-$(CONFIG_MMC_TIFM_SD) += tifm_sd.o
|
||||
obj-$(CONFIG_MMC_SPI) += mmc_spi.o
|
||||
-obj-$(CONFIG_GPIOMMC) += gpiommc.o
|
||||
+
|
||||
diff -ruN linux-2.6.26.orig/drivers/spi/Kconfig linux-2.6.26/drivers/spi/Kconfig
|
||||
--- linux-2.6.26.orig/drivers/spi/Kconfig 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/drivers/spi/Kconfig 2008-10-24 21:03:47.000000000 +0200
|
||||
@@ -100,19 +100,6 @@
|
||||
Index: linux-2.6.26/drivers/spi/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/drivers/spi/Kconfig 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ linux-2.6.26/drivers/spi/Kconfig 2008-12-12 21:55:25.000000000 +0100
|
||||
@@ -100,19 +100,6 @@ config SPI_BUTTERFLY
|
||||
inexpensive battery powered microcontroller evaluation board.
|
||||
This same cable can be used to flash new firmware.
|
||||
|
||||
|
@ -785,10 +795,11 @@ diff -ruN linux-2.6.26.orig/drivers/spi/Kconfig linux-2.6.26/drivers/spi/Kconfig
|
|||
config SPI_IMX
|
||||
tristate "Freescale iMX SPI controller"
|
||||
depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
|
||||
diff -ruN linux-2.6.26.orig/drivers/spi/Makefile linux-2.6.26/drivers/spi/Makefile
|
||||
--- linux-2.6.26.orig/drivers/spi/Makefile 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/drivers/spi/Makefile 2008-10-24 21:03:47.000000000 +0200
|
||||
@@ -16,7 +16,6 @@
|
||||
Index: linux-2.6.26/drivers/spi/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/drivers/spi/Makefile 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ linux-2.6.26/drivers/spi/Makefile 2008-12-12 21:55:25.000000000 +0100
|
||||
@@ -16,7 +16,6 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
|
||||
obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
|
||||
obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
|
||||
obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
|
||||
|
@ -796,9 +807,10 @@ diff -ruN linux-2.6.26.orig/drivers/spi/Makefile linux-2.6.26/drivers/spi/Makefi
|
|||
obj-$(CONFIG_SPI_IMX) += spi_imx.o
|
||||
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
|
||||
obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
|
||||
diff -ruN linux-2.6.26.orig/drivers/spi/spi_gpio.c linux-2.6.26/drivers/spi/spi_gpio.c
|
||||
--- linux-2.6.26.orig/drivers/spi/spi_gpio.c 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/drivers/spi/spi_gpio.c 1970-01-01 01:00:00.000000000 +0100
|
||||
Index: linux-2.6.26/drivers/spi/spi_gpio.c
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/drivers/spi/spi_gpio.c 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
@@ -1,251 +0,0 @@
|
||||
-/*
|
||||
- * Bitbanging SPI bus driver using GPIO API
|
||||
|
@ -1051,9 +1063,10 @@ diff -ruN linux-2.6.26.orig/drivers/spi/spi_gpio.c linux-2.6.26/drivers/spi/spi_
|
|||
-MODULE_AUTHOR("Michael Buesch");
|
||||
-MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
|
||||
-MODULE_LICENSE("GPL v2");
|
||||
diff -ruN linux-2.6.26.orig/include/linux/mmc/gpiommc.h linux-2.6.26/include/linux/mmc/gpiommc.h
|
||||
--- linux-2.6.26.orig/include/linux/mmc/gpiommc.h 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/include/linux/mmc/gpiommc.h 1970-01-01 01:00:00.000000000 +0100
|
||||
Index: linux-2.6.26/include/linux/mmc/gpiommc.h
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/include/linux/mmc/gpiommc.h 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
@@ -1,71 +0,0 @@
|
||||
-/*
|
||||
- * Device driver for MMC/SD cards driven over a GPIO bus.
|
||||
|
@ -1126,9 +1139,10 @@ diff -ruN linux-2.6.26.orig/include/linux/mmc/gpiommc.h linux-2.6.26/include/lin
|
|||
-int gpiommc_next_id(void);
|
||||
-
|
||||
-#endif /* LINUX_GPIOMMC_H_ */
|
||||
diff -ruN linux-2.6.26.orig/include/linux/spi/spi_gpio.h linux-2.6.26/include/linux/spi/spi_gpio.h
|
||||
--- linux-2.6.26.orig/include/linux/spi/spi_gpio.h 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/include/linux/spi/spi_gpio.h 1970-01-01 01:00:00.000000000 +0100
|
||||
Index: linux-2.6.26/include/linux/spi/spi_gpio.h
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/include/linux/spi/spi_gpio.h 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
@@ -1,73 +0,0 @@
|
||||
-/*
|
||||
- * spi_gpio interface to platform code
|
||||
|
@ -1203,10 +1217,11 @@ diff -ruN linux-2.6.26.orig/include/linux/spi/spi_gpio.h linux-2.6.26/include/li
|
|||
-int spi_gpio_next_id(void);
|
||||
-
|
||||
-#endif /* _LINUX_SPI_SPI_GPIO */
|
||||
diff -ruN linux-2.6.26.orig/MAINTAINERS linux-2.6.26/MAINTAINERS
|
||||
--- linux-2.6.26.orig/MAINTAINERS 2008-10-24 21:04:46.000000000 +0200
|
||||
+++ linux-2.6.26/MAINTAINERS 2008-10-24 21:04:02.000000000 +0200
|
||||
@@ -1818,11 +1818,6 @@
|
||||
Index: linux-2.6.26/MAINTAINERS
|
||||
===================================================================
|
||||
--- linux-2.6.26.orig/MAINTAINERS 2008-12-12 21:55:07.000000000 +0100
|
||||
+++ linux-2.6.26/MAINTAINERS 2008-12-12 21:55:25.000000000 +0100
|
||||
@@ -1818,11 +1818,6 @@ L: gigaset307x-common@lists.sourceforge.
|
||||
W: http://gigaset307x.sourceforge.net/
|
||||
S: Maintained
|
||||
|
||||
|
@ -1218,7 +1233,7 @@ diff -ruN linux-2.6.26.orig/MAINTAINERS linux-2.6.26/MAINTAINERS
|
|||
HARDWARE MONITORING
|
||||
P: Mark M. Hoffman
|
||||
M: mhoffman@lightlink.com
|
||||
@@ -3800,11 +3795,6 @@
|
||||
@@ -3800,11 +3795,6 @@ L: cbe-oss-dev@ozlabs.org
|
||||
W: http://www.ibm.com/developerworks/power/cell/
|
||||
S: Supported
|
||||
|
||||
|
|
Loading…
Reference in a new issue