add support for more lantiq AR9 boards
SVN-Revision: 27694
This commit is contained in:
parent
fee32761f3
commit
3833b7be24
4 changed files with 180 additions and 1 deletions
11
target/linux/lantiq/ar9/profiles/003-buffalo.mk
Normal file
11
target/linux/lantiq/ar9/profiles/003-buffalo.mk
Normal file
|
@ -0,0 +1,11 @@
|
|||
define Profile/WBMR
|
||||
NAME:=WBMR - Buffalo WBMR-HP-G300H
|
||||
PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-leds-gpio \
|
||||
kmod-ltq-dsl-firmware-b kmod-ledtrig-usbdev
|
||||
endef
|
||||
|
||||
define Profile/WBMR/Description
|
||||
Package set optimized for the Buffalo WBMR routers
|
||||
endef
|
||||
|
||||
$(eval $(call Profile,WBMR))
|
|
@ -28,6 +28,7 @@ CONFIG_LANTIQ_MACH_ARV45XX=y
|
|||
CONFIG_LANTIQ_MACH_EASY50712=y
|
||||
# CONFIG_LANTIQ_MACH_NETGEAR is not set
|
||||
CONFIG_LANTIQ_MACH_GIGASX76X=y
|
||||
CONFIG_LANTIQ_MACH_WBMR=y
|
||||
CONFIG_MACH_NO_WESTBRIDGE=y
|
||||
# CONFIG_MINIX_FS_NATIVE_ENDIAN is not set
|
||||
CONFIG_NEED_DMA_MAP_STATE=y
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
|
|||
|
||||
JFFS2_BLOCKSIZE = 64k 128k 256k
|
||||
|
||||
ase_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
|
||||
ase_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
|
||||
xway_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
|
||||
falcon_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
|
||||
|
||||
|
@ -199,6 +199,14 @@ endef
|
|||
endif
|
||||
|
||||
ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
|
||||
define Image/BuildKernel/Profile/WBMR
|
||||
$(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
|
||||
endef
|
||||
|
||||
define Image/Build/Profile/WBMR
|
||||
$(call Image/Build/$(1),$(1),WBMR)
|
||||
endef
|
||||
|
||||
define Image/BuildKernel/Profile/DGN3500B
|
||||
$(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
|
||||
endef
|
||||
|
@ -208,11 +216,13 @@ define Image/Build/Profile/DGN3500B
|
|||
endef
|
||||
|
||||
define Image/BuildKernel/Profile/Generic
|
||||
$(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
|
||||
$(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
|
||||
$(call Image/BuildKernel/Template,NONE)
|
||||
endef
|
||||
|
||||
define Image/Build/Profile/Generic
|
||||
$(call Image/Build/$(1),$(1),WBMR)
|
||||
$(call Image/Build/$(1),$(1),DGN3500B)
|
||||
$(call Image/Build/$(1),$(1),NONE)
|
||||
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
|
||||
|
|
157
target/linux/lantiq/patches-2.6.39/602-wbmr.patch
Normal file
157
target/linux/lantiq/patches-2.6.39/602-wbmr.patch
Normal file
|
@ -0,0 +1,157 @@
|
|||
--- a/arch/mips/lantiq/machtypes.h
|
||||
+++ b/arch/mips/lantiq/machtypes.h
|
||||
@@ -40,6 +40,9 @@
|
||||
|
||||
/* Gigaset */
|
||||
LANTIQ_MACH_GIGASX76X, /* Gigaset SX76x */
|
||||
+
|
||||
+ /* Buffalo */
|
||||
+ LANTIQ_MACH_WBMR, /* WBMR-HP-G300H */
|
||||
};
|
||||
|
||||
#endif
|
||||
--- a/arch/mips/lantiq/xway/Kconfig
|
||||
+++ b/arch/mips/lantiq/xway/Kconfig
|
||||
@@ -19,6 +19,11 @@
|
||||
select LTQ_DEV_GPIO_BUTTONS
|
||||
default y
|
||||
|
||||
+config LANTIQ_MACH_WBMR
|
||||
+ bool "WBMR-HP-G300H"
|
||||
+ select LTQ_DEV_GPIO_BUTTONS
|
||||
+ default y
|
||||
+
|
||||
endmenu
|
||||
|
||||
endif
|
||||
--- a/arch/mips/lantiq/xway/Makefile
|
||||
+++ b/arch/mips/lantiq/xway/Makefile
|
||||
@@ -8,4 +8,5 @@
|
||||
obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
|
||||
obj-$(CONFIG_LANTIQ_MACH_NETGEAR) += mach-netgear.o
|
||||
obj-$(CONFIG_LANTIQ_MACH_GIGASX76X) += mach-gigasx76x.o
|
||||
+obj-$(CONFIG_LANTIQ_MACH_WBMR) += mach-wbmr.o
|
||||
obj-y += dev-dwc_otg.o
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/lantiq/xway/mach-wbmr.c
|
||||
@@ -0,0 +1,120 @@
|
||||
+/*
|
||||
+ * This program is free software; you can redistribute it and/or modify it
|
||||
+ * under the terms of the GNU General Public License version 2 as published
|
||||
+ * by the Free Software Foundation.
|
||||
+ *
|
||||
+ * Copyright (C) 2010 John Crispin <blogic@openwrt.org>
|
||||
+ */
|
||||
+
|
||||
+#include <linux/init.h>
|
||||
+#include <linux/platform_device.h>
|
||||
+#include <linux/leds.h>
|
||||
+#include <linux/gpio.h>
|
||||
+#include <linux/gpio_buttons.h>
|
||||
+#include <linux/mtd/mtd.h>
|
||||
+#include <linux/mtd/partitions.h>
|
||||
+#include <linux/mtd/physmap.h>
|
||||
+#include <linux/input.h>
|
||||
+
|
||||
+#include <lantiq_soc.h>
|
||||
+#include <irq.h>
|
||||
+
|
||||
+#include "../machtypes.h"
|
||||
+#include "devices.h"
|
||||
+#include "dev-leds-gpio.h"
|
||||
+#include "dev-dwc_otg.h"
|
||||
+#include "../dev-gpio-buttons.h"
|
||||
+
|
||||
+static struct mtd_partition wbmr_partitions[] =
|
||||
+{
|
||||
+ {
|
||||
+ .name = "uboot",
|
||||
+ .offset = 0x0,
|
||||
+ .size = 0x40000,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "uboot-env",
|
||||
+ .offset = 0x40000,
|
||||
+ .size = 0x20000,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "linux",
|
||||
+ .offset = 0x60000,
|
||||
+ .size = 0x1f20000,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "calibration",
|
||||
+ .offset = 0x1fe0000,
|
||||
+ .size = 0x20000,
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct physmap_flash_data wbmr_flash_data = {
|
||||
+ .nr_parts = ARRAY_SIZE(wbmr_partitions),
|
||||
+ .parts = wbmr_partitions,
|
||||
+};
|
||||
+
|
||||
+static struct gpio_led
|
||||
+wbmr_leds_gpio[] __initdata = {
|
||||
+ { .name = "soc:blue:movie", .gpio = 20, .active_low = 1, },
|
||||
+ { .name = "soc:red:internet", .gpio = 18, .active_low = 1, },
|
||||
+ { .name = "soc:green:internet", .gpio = 17, .active_low = 1, },
|
||||
+ { .name = "soc:green:adsl", .gpio = 16, .active_low = 1, },
|
||||
+ { .name = "soc:green:wlan", .gpio = 15, .active_low = 1, },
|
||||
+ { .name = "soc:red:security", .gpio = 14, .active_low = 1, },
|
||||
+ { .name = "soc:green:power", .gpio = 1, .active_low = 1, },
|
||||
+ { .name = "soc:red:power", .gpio = 5, .active_low = 1, },
|
||||
+ { .name = "soc:green:usb", .gpio = 28, .active_low = 1, },
|
||||
+};
|
||||
+
|
||||
+static struct gpio_keys_button
|
||||
+wbmr_gpio_keys[] __initdata = {
|
||||
+ {
|
||||
+ .desc = "aoss",
|
||||
+ .type = EV_KEY,
|
||||
+ .code = BTN_0,
|
||||
+ .debounce_interval = LTQ_KEYS_DEBOUNCE_INTERVAL,
|
||||
+ .gpio = 0,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .desc = "reset",
|
||||
+ .type = EV_KEY,
|
||||
+ .code = BTN_1,
|
||||
+ .debounce_interval = LTQ_KEYS_DEBOUNCE_INTERVAL,
|
||||
+ .gpio = 37,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct ltq_pci_data ltq_pci_data = {
|
||||
+ .clock = PCI_CLOCK_INT,
|
||||
+ .gpio = PCI_GNT1 | PCI_REQ1,
|
||||
+ .irq = {
|
||||
+ [14] = INT_NUM_IM0_IRL0 + 22,
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
+static struct ltq_eth_data ltq_eth_data = {
|
||||
+ .mii_mode = PHY_INTERFACE_MODE_MII,
|
||||
+};
|
||||
+
|
||||
+static void __init
|
||||
+wbmr_init(void)
|
||||
+{
|
||||
+#define WMBR_BRN_MAC 0x1fd0024
|
||||
+
|
||||
+ ltq_add_device_leds_gpio(-1, ARRAY_SIZE(wbmr_leds_gpio), wbmr_leds_gpio);
|
||||
+ ltq_register_gpio_keys_polled(-1, LTQ_KEYS_POLL_INTERVAL, ARRAY_SIZE(wbmr_gpio_keys), wbmr_gpio_keys);
|
||||
+ ltq_register_nor(&wbmr_flash_data);
|
||||
+ ltq_register_pci(<q_pci_data);
|
||||
+ memcpy_fromio(<q_eth_data.mac.sa_data,
|
||||
+ (void *)KSEG1ADDR(LTQ_FLASH_START + WMBR_BRN_MAC), 6);
|
||||
+ ltq_register_etop(<q_eth_data);
|
||||
+ xway_register_dwc(36);
|
||||
+}
|
||||
+
|
||||
+MIPS_MACHINE(LANTIQ_MACH_WBMR,
|
||||
+ "WBMR",
|
||||
+ "WBMR",
|
||||
+ wbmr_init);
|
Loading…
Reference in a new issue