Update 2.6.38 to 2.6.38.2
SVN-Revision: 26332
This commit is contained in:
parent
c69977eb8b
commit
371bccb4c0
8 changed files with 64 additions and 39 deletions
|
@ -23,8 +23,8 @@ endif
|
||||||
ifeq ($(LINUX_VERSION),2.6.37.4)
|
ifeq ($(LINUX_VERSION),2.6.37.4)
|
||||||
LINUX_KERNEL_MD5SUM:=1d2dc321017a8dde09b779b4d8233273
|
LINUX_KERNEL_MD5SUM:=1d2dc321017a8dde09b779b4d8233273
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),2.6.38)
|
ifeq ($(LINUX_VERSION),2.6.38.2)
|
||||||
LINUX_KERNEL_MD5SUM:=7d471477bfa67546f902da62227fa976
|
LINUX_KERNEL_MD5SUM:=5e9d0edae15053ea9acd932e6d162d03
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
|
|
@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz
|
||||||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
|
||||||
SUBTARGETS:=netus tqma9263
|
SUBTARGETS:=netus tqma9263
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.38
|
LINUX_VERSION:=2.6.38.2
|
||||||
DEVICE_TYPE=
|
DEVICE_TYPE=
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
|
@ -801,6 +801,7 @@ CONFIG_HAVE_KRETPROBES=y
|
||||||
# CONFIG_HID_WALTOP is not set
|
# CONFIG_HID_WALTOP is not set
|
||||||
# CONFIG_HID_ZEROPLUS is not set
|
# CONFIG_HID_ZEROPLUS is not set
|
||||||
# CONFIG_HID_ZYDACRON is not set
|
# CONFIG_HID_ZYDACRON is not set
|
||||||
|
# CONFIG_HID_ACRUX is not set
|
||||||
# CONFIG_HIGHMEM is not set
|
# CONFIG_HIGHMEM is not set
|
||||||
CONFIG_HIGH_RES_TIMERS=y
|
CONFIG_HIGH_RES_TIMERS=y
|
||||||
# CONFIG_HIPPI is not set
|
# CONFIG_HIPPI is not set
|
||||||
|
|
|
@ -1,5 +1,7 @@
|
||||||
--- a/drivers/pci/Kconfig
|
Index: linux-2.6.38.1/drivers/pci/Kconfig
|
||||||
+++ b/drivers/pci/Kconfig
|
===================================================================
|
||||||
|
--- linux-2.6.38.1.orig/drivers/pci/Kconfig 2011-03-23 21:04:47.000000000 +0100
|
||||||
|
+++ linux-2.6.38.1/drivers/pci/Kconfig 2011-03-28 16:48:00.052118712 +0200
|
||||||
@@ -62,6 +62,12 @@ config XEN_PCIDEV_FE_DEBUG
|
@@ -62,6 +62,12 @@ config XEN_PCIDEV_FE_DEBUG
|
||||||
|
|
||||||
When in doubt, say N.
|
When in doubt, say N.
|
||||||
|
@ -13,8 +15,10 @@
|
||||||
config HT_IRQ
|
config HT_IRQ
|
||||||
bool "Interrupts on hypertransport devices"
|
bool "Interrupts on hypertransport devices"
|
||||||
default y
|
default y
|
||||||
--- a/drivers/pci/quirks.c
|
Index: linux-2.6.38.1/drivers/pci/quirks.c
|
||||||
+++ b/drivers/pci/quirks.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.1.orig/drivers/pci/quirks.c 2011-03-23 21:04:47.000000000 +0100
|
||||||
|
+++ linux-2.6.38.1/drivers/pci/quirks.c 2011-03-28 16:48:13.130041612 +0200
|
||||||
@@ -104,6 +104,7 @@ static void __devinit quirk_mmio_always_
|
@@ -104,6 +104,7 @@ static void __devinit quirk_mmio_always_
|
||||||
}
|
}
|
||||||
DECLARE_PCI_FIXUP_EARLY(PCI_ANY_ID, PCI_ANY_ID, quirk_mmio_always_on);
|
DECLARE_PCI_FIXUP_EARLY(PCI_ANY_ID, PCI_ANY_ID, quirk_mmio_always_on);
|
||||||
|
@ -23,7 +27,7 @@
|
||||||
/* The Mellanox Tavor device gives false positive parity errors
|
/* The Mellanox Tavor device gives false positive parity errors
|
||||||
* Mark this device with a broken_parity_status, to allow
|
* Mark this device with a broken_parity_status, to allow
|
||||||
* PCI scanning code to "skip" this now blacklisted device.
|
* PCI scanning code to "skip" this now blacklisted device.
|
||||||
@@ -1944,7 +1945,9 @@ static void __devinit fixup_rev1_53c810(
|
@@ -1989,7 +1990,9 @@ static void __devinit fixup_rev1_53c810(
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||||
|
@ -33,10 +37,10 @@
|
||||||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||||
{
|
{
|
||||||
@@ -2669,6 +2672,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
@@ -2662,6 +2665,7 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_AT
|
||||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
|
quirk_msi_intx_disable_bug);
|
||||||
|
|
||||||
#endif /* CONFIG_PCI_IOV */
|
#endif /* CONFIG_PCI_MSI */
|
||||||
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
|
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
|
||||||
|
|
||||||
/* Allow manual resource allocation for PCI hotplug bridges
|
/* Allow manual resource allocation for PCI hotplug bridges
|
||||||
|
|
|
@ -1,5 +1,7 @@
|
||||||
--- a/drivers/usb/serial/usb-serial.c
|
Index: linux-2.6.38.1/drivers/usb/serial/usb-serial.c
|
||||||
+++ b/drivers/usb/serial/usb-serial.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.1.orig/drivers/usb/serial/usb-serial.c 2011-03-23 21:04:47.000000000 +0100
|
||||||
|
+++ linux-2.6.38.1/drivers/usb/serial/usb-serial.c 2011-03-28 16:58:26.673254994 +0200
|
||||||
@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
|
@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
|
||||||
drivers depend on it.
|
drivers depend on it.
|
||||||
*/
|
*/
|
||||||
|
@ -8,16 +10,17 @@
|
||||||
static int debug;
|
static int debug;
|
||||||
/* initially all NULL */
|
/* initially all NULL */
|
||||||
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
|
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
|
||||||
@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
|
@@ -912,7 +913,8 @@ int usb_serial_probe(struct usb_interfac
|
||||||
|
goto probe_error;
|
||||||
}
|
}
|
||||||
buffer_size = serial->type->bulk_in_size;
|
buffer_size = max_t(int, serial->type->bulk_in_size,
|
||||||
if (!buffer_size)
|
- le16_to_cpu(endpoint->wMaxPacketSize));
|
||||||
- buffer_size = le16_to_cpu(endpoint->wMaxPacketSize);
|
+ min_t(int, le16_to_cpu(endpoint->wMaxPacketSize),
|
||||||
+ buffer_size = (endpoint->wMaxPacketSize > maxSize) ? endpoint->wMaxPacketSize : maxSize;
|
+ maxSize));
|
||||||
port->bulk_in_size = buffer_size;
|
port->bulk_in_size = buffer_size;
|
||||||
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
||||||
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
||||||
@@ -1392,3 +1393,5 @@ MODULE_LICENSE("GPL");
|
@@ -1391,3 +1393,5 @@ MODULE_LICENSE("GPL");
|
||||||
|
|
||||||
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
||||||
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
||||||
|
|
|
@ -1,5 +1,7 @@
|
||||||
--- a/mm/shmem.c
|
Index: linux-2.6.38.2/mm/shmem.c
|
||||||
+++ b/mm/shmem.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/mm/shmem.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/mm/shmem.c 2011-03-28 17:18:35.142293910 +0200
|
||||||
@@ -30,6 +30,7 @@
|
@@ -30,6 +30,7 @@
|
||||||
#include <linux/module.h>
|
#include <linux/module.h>
|
||||||
#include <linux/percpu_counter.h>
|
#include <linux/percpu_counter.h>
|
||||||
|
@ -25,7 +27,7 @@
|
||||||
/**
|
/**
|
||||||
* shmem_file_setup - get an unlinked file living in tmpfs
|
* shmem_file_setup - get an unlinked file living in tmpfs
|
||||||
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
||||||
@@ -2787,9 +2798,6 @@ int shmem_zero_setup(struct vm_area_stru
|
@@ -2787,10 +2798,7 @@ int shmem_zero_setup(struct vm_area_stru
|
||||||
if (IS_ERR(file))
|
if (IS_ERR(file))
|
||||||
return PTR_ERR(file);
|
return PTR_ERR(file);
|
||||||
|
|
||||||
|
@ -34,10 +36,13 @@
|
||||||
- vma->vm_file = file;
|
- vma->vm_file = file;
|
||||||
- vma->vm_ops = &shmem_vm_ops;
|
- vma->vm_ops = &shmem_vm_ops;
|
||||||
+ shmem_set_file(vma, file);
|
+ shmem_set_file(vma, file);
|
||||||
|
vma->vm_flags |= VM_CAN_NONLINEAR;
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
--- a/fs/file.c
|
Index: linux-2.6.38.2/fs/file.c
|
||||||
+++ b/fs/file.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/fs/file.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/fs/file.c 2011-03-28 17:18:24.755353654 +0200
|
||||||
@@ -264,6 +264,7 @@ int expand_files(struct files_struct *fi
|
@@ -264,6 +264,7 @@ int expand_files(struct files_struct *fi
|
||||||
/* All good, so we try */
|
/* All good, so we try */
|
||||||
return expand_fdtable(files, nr);
|
return expand_fdtable(files, nr);
|
||||||
|
@ -46,8 +51,10 @@
|
||||||
|
|
||||||
static int count_open_files(struct fdtable *fdt)
|
static int count_open_files(struct fdtable *fdt)
|
||||||
{
|
{
|
||||||
--- a/kernel/exit.c
|
Index: linux-2.6.38.2/kernel/exit.c
|
||||||
+++ b/kernel/exit.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/kernel/exit.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/kernel/exit.c 2011-03-28 17:18:24.755353654 +0200
|
||||||
@@ -513,6 +513,7 @@ struct files_struct *get_files_struct(st
|
@@ -513,6 +513,7 @@ struct files_struct *get_files_struct(st
|
||||||
|
|
||||||
return files;
|
return files;
|
||||||
|
@ -64,8 +71,10 @@
|
||||||
|
|
||||||
void reset_files_struct(struct files_struct *files)
|
void reset_files_struct(struct files_struct *files)
|
||||||
{
|
{
|
||||||
--- a/kernel/fork.c
|
Index: linux-2.6.38.2/kernel/fork.c
|
||||||
+++ b/kernel/fork.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/kernel/fork.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/kernel/fork.c 2011-03-28 17:18:24.755353654 +0200
|
||||||
@@ -193,6 +193,7 @@ void __put_task_struct(struct task_struc
|
@@ -193,6 +193,7 @@ void __put_task_struct(struct task_struc
|
||||||
if (!profile_handoff_task(tsk))
|
if (!profile_handoff_task(tsk))
|
||||||
free_task(tsk);
|
free_task(tsk);
|
||||||
|
@ -74,8 +83,10 @@
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* macro override instead of weak attribute alias, to workaround
|
* macro override instead of weak attribute alias, to workaround
|
||||||
--- a/kernel/sched.c
|
Index: linux-2.6.38.2/kernel/sched.c
|
||||||
+++ b/kernel/sched.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/kernel/sched.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/kernel/sched.c 2011-03-28 17:18:24.757353643 +0200
|
||||||
@@ -4641,6 +4641,7 @@ int can_nice(const struct task_struct *p
|
@@ -4641,6 +4641,7 @@ int can_nice(const struct task_struct *p
|
||||||
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
|
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
|
||||||
capable(CAP_SYS_NICE));
|
capable(CAP_SYS_NICE));
|
||||||
|
@ -84,8 +95,10 @@
|
||||||
|
|
||||||
#ifdef __ARCH_WANT_SYS_NICE
|
#ifdef __ARCH_WANT_SYS_NICE
|
||||||
|
|
||||||
--- a/mm/memory.c
|
Index: linux-2.6.38.2/mm/memory.c
|
||||||
+++ b/mm/memory.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/mm/memory.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/mm/memory.c 2011-03-28 17:18:24.757353643 +0200
|
||||||
@@ -1229,6 +1229,7 @@ unsigned long zap_page_range(struct vm_a
|
@@ -1229,6 +1229,7 @@ unsigned long zap_page_range(struct vm_a
|
||||||
tlb_finish_mmu(tlb, address, end);
|
tlb_finish_mmu(tlb, address, end);
|
||||||
return end;
|
return end;
|
||||||
|
@ -102,8 +115,10 @@
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* We enter with non-exclusive mmap_sem (to exclude vma changes,
|
* We enter with non-exclusive mmap_sem (to exclude vma changes,
|
||||||
--- a/mm/vmalloc.c
|
Index: linux-2.6.38.2/mm/vmalloc.c
|
||||||
+++ b/mm/vmalloc.c
|
===================================================================
|
||||||
|
--- linux-2.6.38.2.orig/mm/vmalloc.c 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/mm/vmalloc.c 2011-03-28 17:18:24.758353638 +0200
|
||||||
@@ -1193,6 +1193,7 @@ void unmap_kernel_range(unsigned long ad
|
@@ -1193,6 +1193,7 @@ void unmap_kernel_range(unsigned long ad
|
||||||
vunmap_page_range(addr, end);
|
vunmap_page_range(addr, end);
|
||||||
flush_tlb_kernel_range(addr, end);
|
flush_tlb_kernel_range(addr, end);
|
||||||
|
@ -120,9 +135,11 @@
|
||||||
|
|
||||||
struct vm_struct *get_vm_area_caller(unsigned long size, unsigned long flags,
|
struct vm_struct *get_vm_area_caller(unsigned long size, unsigned long flags,
|
||||||
void *caller)
|
void *caller)
|
||||||
--- a/include/linux/mm.h
|
Index: linux-2.6.38.2/include/linux/mm.h
|
||||||
+++ b/include/linux/mm.h
|
===================================================================
|
||||||
@@ -856,6 +856,7 @@ extern void show_free_areas(void);
|
--- linux-2.6.38.2.orig/include/linux/mm.h 2011-03-27 20:37:20.000000000 +0200
|
||||||
|
+++ linux-2.6.38.2/include/linux/mm.h 2011-03-28 17:18:24.758353638 +0200
|
||||||
|
@@ -863,6 +863,7 @@ extern void show_free_areas(void);
|
||||||
|
|
||||||
int shmem_lock(struct file *file, int lock, struct user_struct *user);
|
int shmem_lock(struct file *file, int lock, struct user_struct *user);
|
||||||
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
|
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
|
||||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
|
||||||
FEATURES:=spe_fpu ramdisk
|
FEATURES:=spe_fpu ramdisk
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.38
|
LINUX_VERSION:=2.6.38.2
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
|
||||||
MAINTAINER:=Michael Buesch <mb@bu3sch.de>
|
MAINTAINER:=Michael Buesch <mb@bu3sch.de>
|
||||||
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
|
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.38
|
LINUX_VERSION:=2.6.38.2
|
||||||
|
|
||||||
define Target/Description
|
define Target/Description
|
||||||
TI OMAP-24xx
|
TI OMAP-24xx
|
||||||
|
|
Loading…
Reference in a new issue