tools/cmake: update to 3.3.2
Update cmake to 3.3.2 and refresh patches. Add a secondary download location. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 47327
This commit is contained in:
parent
faabe8e8e6
commit
35cc181eb2
3 changed files with 15 additions and 17 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -7,11 +7,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cmake
|
||||
PKG_VERSION:=2.8.12.2
|
||||
PKG_VERSION:=3.3.2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
|
||||
PKG_MD5SUM:=17c6513483d23590cbce6957ec6d1e66
|
||||
PKG_SOURCE_URL:=http://www.cmake.org/files/v3.3/ \
|
||||
https://fossies.org/linux/misc/
|
||||
PKG_MD5SUM:=5febbd11bcaac854a27eebaf4a124be2
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
HOST_CONFIGURE_PARALLEL:=1
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/Tests/RunCMake/CMakeLists.txt
|
||||
+++ b/Tests/RunCMake/CMakeLists.txt
|
||||
@@ -101,16 +101,6 @@
|
||||
add_RunCMake_test(TargetPolicies)
|
||||
add_RunCMake_test(alias_targets)
|
||||
@@ -160,15 +160,6 @@
|
||||
add_RunCMake_test(no_install_prefix)
|
||||
add_RunCMake_test(configure_file)
|
||||
|
||||
-find_package(Qt4 QUIET)
|
||||
-find_package(Qt5Core QUIET)
|
||||
|
@ -10,21 +10,20 @@
|
|||
- add_RunCMake_test(IncompatibleQt)
|
||||
-endif()
|
||||
-if (QT4_FOUND)
|
||||
- set(ObsoleteQtMacros_ARGS -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
|
||||
- add_RunCMake_test(ObsoleteQtMacros)
|
||||
- add_RunCMake_test(ObsoleteQtMacros -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
|
||||
-endif()
|
||||
-
|
||||
if("${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio [^6]")
|
||||
add_RunCMake_test(include_external_msproject)
|
||||
add_RunCMake_test(SolutionGlobalSections)
|
||||
find_package(PkgConfig QUIET)
|
||||
if(PKG_CONFIG_FOUND)
|
||||
add_RunCMake_test(FindPkgConfig)
|
||||
--- a/Tests/CMakeLists.txt
|
||||
+++ b/Tests/CMakeLists.txt
|
||||
@@ -262,10 +262,6 @@
|
||||
@@ -358,10 +358,6 @@
|
||||
|
||||
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
|
||||
|
||||
- if(NOT QT4_FOUND)
|
||||
- find_package(Qt4)
|
||||
- find_package(Qt4 QUIET)
|
||||
- endif()
|
||||
-
|
||||
if(QT4_FOUND)
|
||||
|
|
|
@ -23,7 +23,7 @@ diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation
|
|||
index 7c31f3a..2672730 100644
|
||||
--- a/Source/kwsys/SystemInformation.cxx
|
||||
+++ b/Source/kwsys/SystemInformation.cxx
|
||||
@@ -88,6 +88,15 @@ typedef int siginfo_t;
|
||||
@@ -91,6 +91,15 @@ typedef int siginfo_t;
|
||||
# include <ifaddrs.h>
|
||||
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
|
||||
# endif
|
||||
|
@ -39,6 +39,4 @@ index 7c31f3a..2672730 100644
|
|||
#endif
|
||||
|
||||
#if defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
|
Loading…
Reference in a new issue