update ltq-ifxos to version 1.5.14
SVN-Revision: 27531
This commit is contained in:
parent
7aa12362b1
commit
35309dbbc8
5 changed files with 14 additions and 63 deletions
|
@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=lib_ifxos
|
||||
PKG_VERSION:=1.5.12
|
||||
PKG_VERSION:=1.5.14
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
PKG_MD5SUM:=ba775356bdd5e1b73b3e11a152710ed6
|
||||
|
||||
|
|
|
@ -1,29 +1,3 @@
|
|||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -639,7 +639,7 @@ if KERNEL_2_6
|
||||
drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
|
||||
|
||||
drv_ifxos.ko: $(drv_ifxos_SOURCES)
|
||||
- @echo -e "drv_ifxos: Making Linux 2.6.x kernel object"
|
||||
+ @echo "drv_ifxos: Making Linux 2.6.x kernel object"
|
||||
if test ! -e common/ifxos_debug.c ; then \
|
||||
echo "copy source files (as links only!)"; \
|
||||
for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
|
||||
@@ -647,10 +647,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
|
||||
cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
|
||||
done \
|
||||
fi
|
||||
- @echo -e "# drv_ifxos: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
||||
- @echo -e "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
||||
- @echo -e "$(subst .ko,,$@)-y := $(drv_ifxos_OBJS)" >> $(PWD)/Kbuild
|
||||
- @echo -e "EXTRA_CFLAGS := $(CFLAGS) -DHAVE_CONFIG_H $(drv_ifxos_CFLAGS) $(DSL_DRIVER_INCL_PATH) -I@abs_srcdir@/include -I$(PWD)/include" >> $(PWD)/Kbuild
|
||||
+ @echo "# drv_ifxos: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
||||
+ @echo "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
||||
+ @echo "$(subst .ko,,$@)-y := $(drv_ifxos_OBJS)" >> $(PWD)/Kbuild
|
||||
+ @echo "EXTRA_CFLAGS := $(CFLAGS) -DHAVE_CONFIG_H $(drv_ifxos_CFLAGS) $(DSL_DRIVER_INCL_PATH) -I@abs_srcdir@/include -I$(PWD)/include" >> $(PWD)/Kbuild
|
||||
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
|
||||
|
||||
clean-generic:
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -64,7 +64,7 @@ dnl Set kernel build path
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
Index: lib_ifxos-1.5.12/src/linux/ifxos_linux_select_drv.c
|
||||
===================================================================
|
||||
--- lib_ifxos-1.5.12.orig/src/linux/ifxos_linux_select_drv.c 2010-04-24 11:33:55.000000000 +0200
|
||||
+++ lib_ifxos-1.5.12/src/linux/ifxos_linux_select_drv.c 2010-04-24 11:34:21.000000000 +0200
|
||||
@@ -33,6 +33,7 @@
|
||||
#include <linux/fs.h>
|
||||
#include <linux/wait.h>
|
||||
#include <linux/poll.h>
|
||||
+#include <linux/sched.h>
|
||||
|
||||
#include "ifx_types.h"
|
||||
#include "ifxos_rt_if_check.h"
|
12
package/ltq-ifxos/patches/120-fix_smp_lock.patch
Normal file
12
package/ltq-ifxos/patches/120-fix_smp_lock.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/src/linux/ifxos_linux_thread_drv.c
|
||||
+++ b/src/linux/ifxos_linux_thread_drv.c
|
||||
@@ -34,7 +34,9 @@
|
||||
#include <linux/sched.h>
|
||||
#include <linux/version.h>
|
||||
#include <linux/completion.h>
|
||||
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
|
||||
#include <linux/smp_lock.h>
|
||||
+#endif
|
||||
#include <linux/signal.h>
|
||||
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
--- a/src/include/linux/ifxos_linux_common.h
|
||||
+++ b/src/include/linux/ifxos_linux_common.h
|
||||
@@ -73,7 +73,7 @@
|
||||
# define __BYTE_ORDER __BIG_ENDIAN
|
||||
/** set the common IFXOS byte order for BIG endian */
|
||||
# define IFXOS_BYTE_ORDER IFXOS_BIG_ENDIAN
|
||||
-#elif
|
||||
+#else
|
||||
# error "missing endian definiton"
|
||||
#endif
|
||||
|
||||
--- a/src/linux/ifxos_linux_thread_drv.c
|
||||
+++ b/src/linux/ifxos_linux_thread_drv.c
|
||||
@@ -34,7 +34,9 @@
|
||||
#include <linux/sched.h>
|
||||
#include <linux/version.h>
|
||||
#include <linux/completion.h>
|
||||
+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
|
||||
#include <linux/smp_lock.h>
|
||||
+#endif
|
||||
#include <linux/signal.h>
|
||||
|
||||
|
Loading…
Reference in a new issue