refresh kernel patches
SVN-Revision: 11205
This commit is contained in:
parent
7758bda7d0
commit
2f47e41bb1
2 changed files with 28 additions and 28 deletions
|
@ -1,8 +1,8 @@
|
|||
Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Kconfig
|
||||
Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.22-rc6.orig/arch/ppc/platforms/4xx/Kconfig 2007-06-28 08:23:13.508980416 +0200
|
||||
+++ linux-2.6.22-rc6/arch/ppc/platforms/4xx/Kconfig 2007-06-28 08:23:15.637656808 +0200
|
||||
@@ -53,6 +53,12 @@
|
||||
--- linux-2.6.24.7.orig/arch/ppc/platforms/4xx/Kconfig
|
||||
+++ linux-2.6.24.7/arch/ppc/platforms/4xx/Kconfig
|
||||
@@ -53,6 +53,12 @@ config WALNUT
|
||||
help
|
||||
This option enables support for the IBM PPC405GP evaluation board.
|
||||
|
||||
|
@ -15,7 +15,7 @@ Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Kconfig
|
|||
config XILINX_ML300
|
||||
bool "Xilinx-ML300"
|
||||
select XILINX_VIRTEX_II_PRO
|
||||
@@ -184,7 +190,7 @@
|
||||
@@ -184,7 +190,7 @@ config BOOKE
|
||||
|
||||
config IBM_OCP
|
||||
bool
|
||||
|
@ -24,7 +24,7 @@ Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Kconfig
|
|||
default y
|
||||
|
||||
config IBM_EMAC4
|
||||
@@ -194,7 +200,7 @@
|
||||
@@ -194,7 +200,7 @@ config IBM_EMAC4
|
||||
|
||||
config BIOS_FIXUP
|
||||
bool
|
||||
|
@ -33,7 +33,7 @@ Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Kconfig
|
|||
default y
|
||||
|
||||
# OAK doesn't exist but wanted to keep this around for any future 403GCX boards
|
||||
@@ -205,7 +211,7 @@
|
||||
@@ -205,7 +211,7 @@ config 403GCX
|
||||
|
||||
config 405EP
|
||||
bool
|
||||
|
@ -42,11 +42,11 @@ Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Kconfig
|
|||
default y
|
||||
|
||||
config 405GP
|
||||
Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Makefile
|
||||
Index: linux-2.6.24.7/arch/ppc/platforms/4xx/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.22-rc6.orig/arch/ppc/platforms/4xx/Makefile 2007-06-28 08:23:13.516979200 +0200
|
||||
+++ linux-2.6.22-rc6/arch/ppc/platforms/4xx/Makefile 2007-06-28 08:23:15.637656808 +0200
|
||||
@@ -14,6 +14,7 @@
|
||||
--- linux-2.6.24.7.orig/arch/ppc/platforms/4xx/Makefile
|
||||
+++ linux-2.6.24.7/arch/ppc/platforms/4xx/Makefile
|
||||
@@ -14,6 +14,7 @@ obj-$(CONFIG_REDWOOD_6) += redwood6.o
|
||||
obj-$(CONFIG_SYCAMORE) += sycamore.o
|
||||
obj-$(CONFIG_TAISHAN) += taishan.o
|
||||
obj-$(CONFIG_WALNUT) += walnut.o
|
||||
|
@ -54,10 +54,10 @@ Index: linux-2.6.22-rc6/arch/ppc/platforms/4xx/Makefile
|
|||
obj-$(CONFIG_XILINX_ML300) += xilinx_ml300.o
|
||||
obj-$(CONFIG_XILINX_ML403) += xilinx_ml403.o
|
||||
|
||||
Index: linux-2.6.22-rc6/include/asm-ppc/ibm4xx.h
|
||||
Index: linux-2.6.24.7/include/asm-ppc/ibm4xx.h
|
||||
===================================================================
|
||||
--- linux-2.6.22-rc6.orig/include/asm-ppc/ibm4xx.h 2007-06-28 08:23:13.526977680 +0200
|
||||
+++ linux-2.6.22-rc6/include/asm-ppc/ibm4xx.h 2007-06-28 08:23:15.637656808 +0200
|
||||
--- linux-2.6.24.7.orig/include/asm-ppc/ibm4xx.h
|
||||
+++ linux-2.6.24.7/include/asm-ppc/ibm4xx.h
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
#ifdef CONFIG_40x
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: linux-2.6.22-rc6/drivers/ide/ide.c
|
||||
Index: linux-2.6.24.7/drivers/ide/ide.c
|
||||
===================================================================
|
||||
--- linux-2.6.22-rc6.orig/drivers/ide/ide.c 2007-06-28 08:23:49.463514496 +0200
|
||||
+++ linux-2.6.22-rc6/drivers/ide/ide.c 2007-06-28 08:23:54.658724704 +0200
|
||||
@@ -1604,6 +1604,7 @@
|
||||
--- linux-2.6.24.7.orig/drivers/ide/ide.c
|
||||
+++ linux-2.6.24.7/drivers/ide/ide.c
|
||||
@@ -1563,6 +1563,7 @@ done:
|
||||
extern void __init pnpide_init(void);
|
||||
extern void __exit pnpide_exit(void);
|
||||
extern void __init h8300_ide_init(void);
|
||||
|
@ -10,7 +10,7 @@ Index: linux-2.6.22-rc6/drivers/ide/ide.c
|
|||
|
||||
/*
|
||||
* probe_for_hwifs() finds/initializes "known" IDE interfaces
|
||||
@@ -1668,6 +1669,9 @@
|
||||
@@ -1627,6 +1628,9 @@ static void __init probe_for_hwifs (void
|
||||
#ifdef CONFIG_H8300
|
||||
h8300_ide_init();
|
||||
#endif
|
||||
|
@ -20,11 +20,11 @@ Index: linux-2.6.22-rc6/drivers/ide/ide.c
|
|||
}
|
||||
|
||||
/*
|
||||
Index: linux-2.6.22-rc6/drivers/ide/Kconfig
|
||||
Index: linux-2.6.24.7/drivers/ide/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.22-rc6.orig/drivers/ide/Kconfig 2007-06-28 08:23:49.470513432 +0200
|
||||
+++ linux-2.6.22-rc6/drivers/ide/Kconfig 2007-06-28 08:23:54.658724704 +0200
|
||||
@@ -946,6 +946,14 @@
|
||||
--- linux-2.6.24.7.orig/drivers/ide/Kconfig
|
||||
+++ linux-2.6.24.7/drivers/ide/Kconfig
|
||||
@@ -1018,6 +1018,14 @@ config BLK_DEV_MPC8xx_IDE
|
||||
|
||||
If unsure, say N.
|
||||
|
||||
|
@ -39,15 +39,15 @@ Index: linux-2.6.22-rc6/drivers/ide/Kconfig
|
|||
choice
|
||||
prompt "Type of MPC8xx IDE interface"
|
||||
depends on BLK_DEV_MPC8xx_IDE
|
||||
Index: linux-2.6.22-rc6/drivers/ide/Makefile
|
||||
Index: linux-2.6.24.7/drivers/ide/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.22-rc6.orig/drivers/ide/Makefile 2007-06-28 08:23:49.478512216 +0200
|
||||
+++ linux-2.6.22-rc6/drivers/ide/Makefile 2007-06-28 08:23:54.659724552 +0200
|
||||
@@ -37,6 +37,7 @@
|
||||
--- linux-2.6.24.7.orig/drivers/ide/Makefile
|
||||
+++ linux-2.6.24.7/drivers/ide/Makefile
|
||||
@@ -37,6 +37,7 @@ ide-core-$(CONFIG_BLK_DEV_Q40IDE) += leg
|
||||
# built-in only drivers from ppc/
|
||||
ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
|
||||
ide-core-$(CONFIG_BLK_DEV_IDE_PMAC) += ppc/pmac.o
|
||||
+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += ppc/magicbox_ide.o
|
||||
|
||||
# built-in only drivers from h8300/
|
||||
ide-core-$(CONFIG_H8300) += h8300/ide-h8300.o
|
||||
ide-core-$(CONFIG_IDE_H8300) += h8300/ide-h8300.o
|
||||
|
|
Loading…
Reference in a new issue