cns3xxx: add missing callbacks for the laguna machine support
SVN-Revision: 33484
This commit is contained in:
parent
31d9f3d61f
commit
2f39fa872a
4 changed files with 7 additions and 4 deletions
|
@ -1,6 +1,6 @@
|
|||
--- /dev/null
|
||||
+++ b/arch/arm/mach-cns3xxx/laguna.c
|
||||
@@ -0,0 +1,761 @@
|
||||
@@ -0,0 +1,764 @@
|
||||
+/*
|
||||
+ * Gateworks Corporation Laguna Platform
|
||||
+ *
|
||||
|
@ -45,6 +45,7 @@
|
|||
+#include <mach/irqs.h>
|
||||
+#include <mach/platform.h>
|
||||
+#include <mach/pm.h>
|
||||
+#include <asm/hardware/gic.h>
|
||||
+#include "core.h"
|
||||
+#include "devices.h"
|
||||
+
|
||||
|
@ -760,7 +761,9 @@
|
|||
+ .map_io = laguna_map_io,
|
||||
+ .init_irq = cns3xxx_init_irq,
|
||||
+ .timer = &cns3xxx_timer,
|
||||
+ .handle_irq = gic_handle_irq,
|
||||
+ .init_machine = laguna_init,
|
||||
+ .restart = cns3xxx_restart,
|
||||
+MACHINE_END
|
||||
--- a/arch/arm/mach-cns3xxx/Kconfig
|
||||
+++ b/arch/arm/mach-cns3xxx/Kconfig
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/arm/mach-cns3xxx/core.c
|
||||
+++ b/arch/arm/mach-cns3xxx/core.c
|
||||
@@ -125,12 +125,13 @@ static void cns3xxx_timer_set_mode(enum
|
||||
@@ -125,12 +125,13 @@ static void cns3xxx_timer_set_mode(enum
|
||||
|
||||
switch (mode) {
|
||||
case CLOCK_EVT_MODE_PERIODIC:
|
||||
|
|
|
@ -107,7 +107,7 @@
|
|||
void cns3xxx_restart(char, const char *);
|
||||
--- a/arch/arm/mach-cns3xxx/laguna.c
|
||||
+++ b/arch/arm/mach-cns3xxx/laguna.c
|
||||
@@ -611,7 +611,7 @@ static struct map_desc laguna_io_desc[]
|
||||
@@ -612,7 +612,7 @@ static struct map_desc laguna_io_desc[]
|
||||
|
||||
static void __init laguna_map_io(void)
|
||||
{
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/Makefile
|
||||
+++ b/drivers/Makefile
|
||||
@@ -70,6 +70,7 @@ obj-$(CONFIG_PARIDE) += block/paride/
|
||||
@@ -71,6 +71,7 @@ obj-$(CONFIG_PARIDE) += block/paride/
|
||||
obj-$(CONFIG_TC) += tc/
|
||||
obj-$(CONFIG_UWB) += uwb/
|
||||
obj-$(CONFIG_USB_OTG_UTILS) += usb/
|
||||
|
|
Loading…
Reference in a new issue