ccache: update to 3.3.4
Update from 3.3.2 to 3.3.4 & refresh patches. Remove 110-disable-assembler-support as ccache now understands the '.incbin' directive. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
This commit is contained in:
parent
08371a2db7
commit
2cf00b640d
3 changed files with 3 additions and 37 deletions
|
@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
PKG_NAME:=ccache
|
||||
PKG_VERSION:=3.3.2
|
||||
PKG_VERSION:=3.3.4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://download.samba.org/pub/ccache/ \
|
||||
https://samba.org/ftp/ccache/
|
||||
PKG_HASH:=907685cb23d8f82074b8d1a9b4ebabb36914d151ac7b96a840c68c08d1a14530
|
||||
PKG_HASH:=24f15bf389e38c41548c9c259532187774ec0cb9686c3497bbb75504c8dc404f
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
diff --git a/ccache.c b/ccache.c
|
||||
index 88e0ec5..7dffeb4 100644
|
||||
--- a/ccache.c
|
||||
+++ b/ccache.c
|
||||
@@ -1762,6 +1762,7 @@ calculate_object_hash(struct args *args, struct mdfour *hash, int direct_mode)
|
||||
@@ -1790,6 +1790,7 @@ calculate_object_hash(struct args *args,
|
||||
"CPLUS_INCLUDE_PATH",
|
||||
"OBJC_INCLUDE_PATH",
|
||||
"OBJCPLUS_INCLUDE_PATH", // clang
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
--- a/language.c
|
||||
+++ b/language.c
|
||||
@@ -37,14 +37,18 @@ static const struct {
|
||||
{".m", "objective-c"},
|
||||
{".M", "objective-c++"},
|
||||
{".mm", "objective-c++"},
|
||||
+#if 0
|
||||
{".sx", "assembler-with-cpp"},
|
||||
{".S", "assembler-with-cpp"},
|
||||
+#endif
|
||||
// Preprocessed:
|
||||
{".i", "cpp-output"},
|
||||
{".ii", "c++-cpp-output"},
|
||||
{".mi", "objective-c-cpp-output"},
|
||||
{".mii", "objective-c++-cpp-output"},
|
||||
+#if 0
|
||||
{".s", "assembler"},
|
||||
+#endif
|
||||
// Header file (for precompilation):
|
||||
{".h", "c-header"},
|
||||
{".H", "c++-header"},
|
||||
@@ -109,8 +113,10 @@ static const struct {
|
||||
{"objective-c++-header", "objective-c++-cpp-output"},
|
||||
{"objective-c++-cpp-output", "objective-c++-cpp-output"},
|
||||
{"cuda", "cuda-output"},
|
||||
+#if 0
|
||||
{"assembler-with-cpp", "assembler"},
|
||||
{"assembler", "assembler"},
|
||||
+#endif
|
||||
{"f77-cpp-input", "f77"},
|
||||
{"f77", "f77"},
|
||||
#if 0 // Could generate module files, ignore for now!
|
Loading…
Reference in a new issue