add trace-cmd
SVN-Revision: 34002
This commit is contained in:
parent
96f31bf6ae
commit
2b81aaa9ee
3 changed files with 110 additions and 0 deletions
60
package/devel/trace-cmd/Makefile
Normal file
60
package/devel/trace-cmd/Makefile
Normal file
|
@ -0,0 +1,60 @@
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=trace-cmd
|
||||||
|
PKG_VERSION:=v2.0.1
|
||||||
|
PKG_RELEASE=1
|
||||||
|
|
||||||
|
PKG_SOURCE_PROTO:=git
|
||||||
|
PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE_VERSION:=1776cf9a24f95b2623fe7ee380d708bb8c6d8a73
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
# PKG_MIRROR_MD5SUM:=6a08dfa2519a969d184e7bb5bb390620
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/trace-cmd
|
||||||
|
SECTION:=devel
|
||||||
|
CATEGORY:=Development
|
||||||
|
TITLE:=Linux trace command line utility
|
||||||
|
DEPENDS:=
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/trace-cmd-extra
|
||||||
|
SECTION:=devel
|
||||||
|
CATEGORY:=Development
|
||||||
|
TITLE:=Extra plugins for trace-cmd
|
||||||
|
DEPENDS:=
|
||||||
|
endef
|
||||||
|
|
||||||
|
MAKE_FLAGS += \
|
||||||
|
NO_PYTHON=1 \
|
||||||
|
prefix=/usr
|
||||||
|
|
||||||
|
PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins
|
||||||
|
PLUGINS_ALL = $(patsubst $(PLUGINS_DIR)/plugin_%.so,%,$(wildcard $(PLUGINS_DIR)/plugin_*.so))
|
||||||
|
PLUGINS_MAIN := function hrtimer mac80211 sched_switch
|
||||||
|
PLUGINS_EXTRA = $(filter-out $(PLUGINS_MAIN),$(PLUGINS_ALL))
|
||||||
|
|
||||||
|
TARGET_CFLAGS += --std=gnu99
|
||||||
|
|
||||||
|
define Package/trace-cmd/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/trace-cmd/plugins
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/trace-cmd $(1)/usr/bin/
|
||||||
|
$(CP) \
|
||||||
|
$(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_MAIN)) \
|
||||||
|
$(1)/usr/lib/trace-cmd/plugins
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/trace-cmd-extra/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib/trace-cmd/plugins
|
||||||
|
$(CP) \
|
||||||
|
$(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_EXTRA)) \
|
||||||
|
$(1)/usr/lib/trace-cmd/plugins
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,trace-cmd))
|
||||||
|
$(eval $(call BuildPackage,trace-cmd-extra))
|
30
package/devel/trace-cmd/patches/100-compile_fix.patch
Normal file
30
package/devel/trace-cmd/patches/100-compile_fix.patch
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
--- a/event-utils.h
|
||||||
|
+++ b/event-utils.h
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
|
||||||
|
#include <string.h>
|
||||||
|
#include <ctype.h>
|
||||||
|
+#include <stdarg.h>
|
||||||
|
|
||||||
|
/* Can be overridden */
|
||||||
|
void die(const char *fmt, ...);
|
||||||
|
--- a/trace-listen.c
|
||||||
|
+++ b/trace-listen.c
|
||||||
|
@@ -17,6 +17,7 @@
|
||||||
|
*
|
||||||
|
* ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
*/
|
||||||
|
+#define _GNU_SOURCE
|
||||||
|
#define _LARGEFILE64_SOURCE
|
||||||
|
#include <dirent.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
--- a/trace-record.c
|
||||||
|
+++ b/trace-record.c
|
||||||
|
@@ -17,6 +17,7 @@
|
||||||
|
*
|
||||||
|
* ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||||
|
*/
|
||||||
|
+#define _GNU_SOURCE
|
||||||
|
#include <dirent.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdlib.h>
|
20
package/devel/trace-cmd/patches/110-fix_sscanf_alloc.patch
Normal file
20
package/devel/trace-cmd/patches/110-fix_sscanf_alloc.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
--- a/trace-util.c
|
||||||
|
+++ b/trace-util.c
|
||||||
|
@@ -110,7 +110,7 @@ void parse_cmdlines(struct pevent *peven
|
||||||
|
|
||||||
|
line = strtok_r(file, "\n", &next);
|
||||||
|
while (line) {
|
||||||
|
- sscanf(line, "%d %as", &pid,
|
||||||
|
+ sscanf(line, "%d %ms", &pid,
|
||||||
|
(float *)(void *)&comm); /* workaround gcc warning */
|
||||||
|
pevent_register_comm(pevent, comm, pid);
|
||||||
|
free(comm);
|
||||||
|
@@ -133,7 +133,7 @@ void parse_proc_kallsyms(struct pevent *
|
||||||
|
line = strtok_r(file, "\n", &next);
|
||||||
|
while (line) {
|
||||||
|
mod = NULL;
|
||||||
|
- ret = sscanf(line, "%as %c %as\t[%as",
|
||||||
|
+ ret = sscanf(line, "%ms %c %ms\t[%ms",
|
||||||
|
(float *)(void *)&addr_str, /* workaround gcc warning */
|
||||||
|
&ch,
|
||||||
|
(float *)(void *)&func,
|
Loading…
Reference in a new issue