Update UML target to 3.10 and various improvements
Updated target to 3.10.36. Added mconsole exec patch. Added pseudo-random MAC patch (from NetKit). Signed-off-by: Markus Stenberg <markus.stenberg@iki.fi> Reviewed-by: Steven Barth <steven@midlink.org> SVN-Revision: 41172
This commit is contained in:
parent
691d7bbbf7
commit
285af2ff08
7 changed files with 382 additions and 45 deletions
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.8.13
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -3,7 +3,6 @@ CONFIG_64BIT=y
|
|||
# CONFIG_ARCH_HAS_SC_SIGNALS is not set
|
||||
# CONFIG_ARCH_REUSE_HOST_VSYSCALL_AREA is not set
|
||||
CONFIG_BINFMT_MISC=m
|
||||
CONFIG_BKL=y
|
||||
CONFIG_BLK_DEV_COW_COMMON=y
|
||||
CONFIG_BLK_DEV_UBD=y
|
||||
CONFIG_BLK_DEV_UBD_SYNC=y
|
||||
|
@ -15,50 +14,54 @@ CONFIG_CPU_SUP_INTEL=y
|
|||
CONFIG_CRAMFS=y
|
||||
# CONFIG_CRASHLOG is not set
|
||||
CONFIG_CRC16=y
|
||||
# CONFIG_CRYPTO_AES_NI_INTEL is not set
|
||||
# CONFIG_CRYPTO_AES_X86_64 is not set
|
||||
# CONFIG_CRYPTO_BLOWFISH_X86_64 is not set
|
||||
CONFIG_CRYPTO_CRC32C=y
|
||||
CONFIG_CRYPTO_HASH=y
|
||||
CONFIG_CRYPTO_HASH2=y
|
||||
# CONFIG_CRYPTO_SALSA20_X86_64 is not set
|
||||
CONFIG_CRYPTO_SHA1=y
|
||||
# CONFIG_CRYPTO_TWOFISH_X86_64 is not set
|
||||
# CONFIG_CRYPTO_TWOFISH_X86_64_3WAY is not set
|
||||
CONFIG_DEBUG_BUGVERBOSE=y
|
||||
CONFIG_DEBUG_MEMORY_INIT=y
|
||||
CONFIG_DECOMPRESS_BZIP2=y
|
||||
CONFIG_DECOMPRESS_GZIP=y
|
||||
CONFIG_DECOMPRESS_LZMA=y
|
||||
CONFIG_DEFAULT_CFQ=y
|
||||
# CONFIG_DEFAULT_DEADLINE is not set
|
||||
CONFIG_DEFAULT_IOSCHED="cfq"
|
||||
CONFIG_DEFCONFIG_LIST="arch/$ARCH/defconfig"
|
||||
CONFIG_DNOTIFY=y
|
||||
CONFIG_ELF_CORE=y
|
||||
# CONFIG_EARLY_PRINTK is not set
|
||||
CONFIG_EXT2_FS=y
|
||||
CONFIG_EXT3_FS=y
|
||||
CONFIG_EXT4_FS=y
|
||||
CONFIG_FS_MBCACHE=y
|
||||
CONFIG_GENERIC_BUG=y
|
||||
CONFIG_GENERIC_CLOCKEVENTS=y
|
||||
CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
|
||||
# CONFIG_GENERIC_CPU is not set
|
||||
CONFIG_GENERIC_CPU_DEVICES=y
|
||||
CONFIG_GENERIC_FIND_FIRST_BIT=y
|
||||
CONFIG_GENERIC_FIND_LAST_BIT=y
|
||||
CONFIG_GENERIC_FIND_NEXT_BIT=y
|
||||
CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ=y
|
||||
CONFIG_GENERIC_IO=y
|
||||
CONFIG_GENERIC_IRQ_SHOW=y
|
||||
# CONFIG_HAMRADIO is not set
|
||||
CONFIG_HAVE_64BIT_ALIGNED_ACCESS=y
|
||||
# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
|
||||
# CONFIG_HAVE_GENERIC_DMA_COHERENT is not set
|
||||
# CONFIG_HAVE_GENERIC_HARDIRQS is not set
|
||||
CONFIG_HAVE_GENERIC_HARDIRQS=y
|
||||
CONFIG_HAVE_NET_DSA=y
|
||||
CONFIG_HAVE_UID16=y
|
||||
CONFIG_HOSTAUDIO=m
|
||||
CONFIG_HOSTFS=y
|
||||
# CONFIG_HPPFS is not set
|
||||
CONFIG_HZ_PERIODIC=y
|
||||
CONFIG_INITRAMFS_SOURCE=""
|
||||
CONFIG_INIT_ENV_ARG_LIMIT=128
|
||||
CONFIG_IOSCHED_CFQ=y
|
||||
CONFIG_IRQ_RELEASE_METHOD=y
|
||||
CONFIG_IRQ_WORK=y
|
||||
CONFIG_ISO9660_FS=y
|
||||
CONFIG_JBD=y
|
||||
CONFIG_JBD2=y
|
||||
CONFIG_KALLSYMS=y
|
||||
CONFIG_KALLSYMS_EXTRA_PASS=y
|
||||
CONFIG_KERNEL_STACK_ORDER=2
|
||||
CONFIG_LD_SCRIPT_STATIC=y
|
||||
CONFIG_LEGACY_PTYS=y
|
||||
|
@ -66,9 +69,9 @@ CONFIG_LEGACY_PTY_COUNT=256
|
|||
# CONFIG_MATOM is not set
|
||||
CONFIG_MCONSOLE=y
|
||||
# CONFIG_MCORE2 is not set
|
||||
# CONFIG_MINI_FO is not set
|
||||
CONFIG_MK8=y
|
||||
# CONFIG_MMAPPER is not set
|
||||
CONFIG_MODULES_USE_ELF_RELA=y
|
||||
# CONFIG_MPSC is not set
|
||||
CONFIG_NAMESPACES=y
|
||||
CONFIG_NEED_PER_CPU_KM=y
|
||||
|
@ -85,8 +88,8 @@ CONFIG_POSIX_MQUEUE=y
|
|||
CONFIG_POSIX_MQUEUE_SYSCTL=y
|
||||
# CONFIG_PREEMPT_RCU is not set
|
||||
# CONFIG_PRINT_QUOTA_WARNING is not set
|
||||
CONFIG_PROC_PAGE_MONITOR=y
|
||||
# CONFIG_PROCESSOR_SELECT is not set
|
||||
CONFIG_PROC_PAGE_MONITOR=y
|
||||
CONFIG_PTY_CHAN=y
|
||||
CONFIG_QFMT_V1=y
|
||||
CONFIG_QFMT_V2=y
|
||||
|
@ -94,13 +97,13 @@ CONFIG_QUOTA=y
|
|||
CONFIG_QUOTACTL=y
|
||||
# CONFIG_QUOTA_NETLINK_INTERFACE is not set
|
||||
CONFIG_QUOTA_TREE=y
|
||||
# CONFIG_RCU_STALL_COMMON is not set
|
||||
CONFIG_RD_BZIP2=y
|
||||
CONFIG_RD_GZIP=y
|
||||
CONFIG_RELAY=y
|
||||
# CONFIG_RWSEM_GENERIC_SPINLOCK is not set
|
||||
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
|
||||
# CONFIG_SCSI_DMA is not set
|
||||
CONFIG_SMP_BROKEN=y
|
||||
CONFIG_SOFT_WATCHDOG=m
|
||||
CONFIG_SOUND=m
|
||||
CONFIG_SOUND_OSS_CORE=y
|
||||
|
@ -112,15 +115,18 @@ CONFIG_SSL_CHAN="pty"
|
|||
CONFIG_STATIC_LINK=y
|
||||
CONFIG_STDERR_CONSOLE=y
|
||||
CONFIG_STDIO_CONSOLE=y
|
||||
CONFIG_TICK_CPU_ACCOUNTING=y
|
||||
# CONFIG_TRACE_IRQFLAGS_SUPPORT is not set
|
||||
CONFIG_TTY_CHAN=y
|
||||
CONFIG_UID16=y
|
||||
CONFIG_UIDGID_CONVERTED=y
|
||||
CONFIG_UML=y
|
||||
CONFIG_UML_NET=y
|
||||
CONFIG_UML_NET_DAEMON=y
|
||||
CONFIG_UML_NET_ETHERTAP=y
|
||||
CONFIG_UML_NET_MCAST=y
|
||||
# CONFIG_UML_NET_PCAP is not set
|
||||
# CONFIG_UML_NET_RANDOM_MAC is not set
|
||||
CONFIG_UML_NET_SLIP=y
|
||||
CONFIG_UML_NET_SLIRP=y
|
||||
CONFIG_UML_NET_TUNTAP=y
|
||||
|
@ -129,19 +135,22 @@ CONFIG_UML_RANDOM=y
|
|||
CONFIG_UML_SOUND=m
|
||||
CONFIG_UML_WATCHDOG=m
|
||||
CONFIG_UML_X86=y
|
||||
# CONFIG_USB_ARCH_HAS_EHCI is not set
|
||||
# CONFIG_USB_ARCH_HAS_OHCI is not set
|
||||
# CONFIG_USB_ARCH_HAS_XHCI is not set
|
||||
# CONFIG_USER_NS is not set
|
||||
CONFIG_VM_EVENT_COUNTERS=y
|
||||
CONFIG_WATCHDOG_CORE=y
|
||||
# CONFIG_X86_32 is not set
|
||||
CONFIG_X86_64=y
|
||||
CONFIG_X86_CMOV=y
|
||||
# CONFIG_X86_CMPXCHG is not set
|
||||
CONFIG_X86_CPU=y
|
||||
CONFIG_X86_CMPXCHG64=y
|
||||
CONFIG_X86_INTEL_USERCOPY=y
|
||||
CONFIG_X86_INTERNODE_CACHE_SHIFT=6
|
||||
CONFIG_X86_L1_CACHE_SHIFT=6
|
||||
CONFIG_X86_MINIMUM_CPU_FAMILY=3
|
||||
CONFIG_X86_MINIMUM_CPU_FAMILY=64
|
||||
CONFIG_X86_TSC=y
|
||||
CONFIG_X86_USE_PPRO_CHECKSUM=y
|
||||
CONFIG_X86_WP_WORKS_OK=y
|
||||
CONFIG_X86_XADD=y
|
||||
CONFIG_XTERM_CHAN=y
|
||||
CONFIG_ZLIB_INFLATE=y
|
||||
CONFIG_ZONE_DMA_FLAG=0
|
||||
|
|
223
target/linux/uml/patches-3.10/101-mconsole-exec.patch
Normal file
223
target/linux/uml/patches-3.10/101-mconsole-exec.patch
Normal file
|
@ -0,0 +1,223 @@
|
|||
#
|
||||
# Minimalist mconsole exec patch
|
||||
#
|
||||
# 3.10 version (with bit more synchronous behavior) by fingon at iki dot fi
|
||||
# Adaptation to kernel 3.3.8 made by David Fernández (david at dit.upm.es) for
|
||||
# Starting point: mconsole-exec-2.6.30.patch for kernel 2.6.30
|
||||
# Author of original patch: Paolo Giarrusso, aka Blaisorblade
|
||||
# (http://www.user-mode-linux.org/~blaisorblade)
|
||||
#
|
||||
# Known misfeatures:
|
||||
#
|
||||
# - If output is too long, blocks (and breaks horribly)
|
||||
# (this misfeature from 3.10 patches, when minimalizing the patch;
|
||||
# workaround: redirect to a shared filesystem if long output is expected)
|
||||
#
|
||||
# - Nothing useful is done with stdin
|
||||
#
|
||||
diff --git a/arch/um/drivers/mconsole.h b/arch/um/drivers/mconsole.h
|
||||
index 8b22535..77cc5f7 100644
|
||||
--- a/arch/um/drivers/mconsole.h
|
||||
+++ b/arch/um/drivers/mconsole.h
|
||||
@@ -85,6 +85,7 @@ extern void mconsole_cad(struct mc_request *req);
|
||||
extern void mconsole_stop(struct mc_request *req);
|
||||
extern void mconsole_go(struct mc_request *req);
|
||||
extern void mconsole_log(struct mc_request *req);
|
||||
+extern void mconsole_exec(struct mc_request *req);
|
||||
extern void mconsole_proc(struct mc_request *req);
|
||||
extern void mconsole_stack(struct mc_request *req);
|
||||
|
||||
diff --git a/arch/um/drivers/mconsole_kern.c b/arch/um/drivers/mconsole_kern.c
|
||||
index 3df3bd5..307bf75 100644
|
||||
--- a/arch/um/drivers/mconsole_kern.c
|
||||
+++ b/arch/um/drivers/mconsole_kern.c
|
||||
@@ -4,6 +4,7 @@
|
||||
* Licensed under the GPL
|
||||
*/
|
||||
|
||||
+#include "linux/kmod.h"
|
||||
#include <linux/console.h>
|
||||
#include <linux/ctype.h>
|
||||
#include <linux/string.h>
|
||||
@@ -24,6 +25,7 @@
|
||||
#include <linux/fs.h>
|
||||
#include <linux/mount.h>
|
||||
#include <linux/file.h>
|
||||
+#include <linux/completion.h>
|
||||
#include <asm/uaccess.h>
|
||||
#include <asm/switch_to.h>
|
||||
|
||||
@@ -121,6 +123,59 @@ void mconsole_log(struct mc_request *req)
|
||||
mconsole_reply(req, "", 0, 0);
|
||||
}
|
||||
|
||||
+void mconsole_exec(struct mc_request *req)
|
||||
+{
|
||||
+ struct subprocess_info *sub_info;
|
||||
+ int res, len;
|
||||
+ struct file *out;
|
||||
+ char buf[MCONSOLE_MAX_DATA];
|
||||
+
|
||||
+ char *envp[] = {
|
||||
+ "HOME=/", "TERM=linux",
|
||||
+ "PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin",
|
||||
+ NULL
|
||||
+ };
|
||||
+ char *argv[] = {
|
||||
+ "/bin/sh", "-c",
|
||||
+ req->request.data + strlen("exec "),
|
||||
+ NULL
|
||||
+ };
|
||||
+
|
||||
+ sub_info = call_usermodehelper_setup("/bin/sh", argv, envp, GFP_ATOMIC, NULL, NULL, NULL);
|
||||
+ if (sub_info == NULL) {
|
||||
+ mconsole_reply(req, "call_usermodehelper_setup failed", 1, 0);
|
||||
+ return;
|
||||
+ }
|
||||
+ res = call_usermodehelper_stdoutpipe(sub_info, &out);
|
||||
+ if (res < 0) {
|
||||
+ kfree(sub_info);
|
||||
+ mconsole_reply(req, "call_usermodehelper_stdoutpipe failed", 1, 0);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ res = call_usermodehelper_exec(sub_info, UMH_WAIT_PROC);
|
||||
+ if (res < 0) {
|
||||
+ kfree(sub_info);
|
||||
+ mconsole_reply(req, "call_usermodehelper_exec failed", 1, 0);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ for (;;) {
|
||||
+ len = out->f_op->read(out, buf, sizeof(buf), &out->f_pos);
|
||||
+ if (len < 0) {
|
||||
+ mconsole_reply(req, "reading output failed", 1, 0);
|
||||
+ break;
|
||||
+ }
|
||||
+ if (len == 0)
|
||||
+ break;
|
||||
+ mconsole_reply_len(req, buf, len, 0, 1);
|
||||
+ }
|
||||
+ fput(out);
|
||||
+
|
||||
+ mconsole_reply_len(req, NULL, 0, 0, 0);
|
||||
+}
|
||||
+
|
||||
+
|
||||
void mconsole_proc(struct mc_request *req)
|
||||
{
|
||||
struct vfsmount *mnt = task_active_pid_ns(current)->proc_mnt;
|
||||
@@ -187,6 +242,7 @@ void mconsole_proc(struct mc_request *req)
|
||||
stop - pause the UML; it will do nothing until it receives a 'go' \n\
|
||||
go - continue the UML after a 'stop' \n\
|
||||
log <string> - make UML enter <string> into the kernel log\n\
|
||||
+ exec <string> - pass <string> to /bin/sh -c synchronously\n\
|
||||
proc <file> - returns the contents of the UML's /proc/<file>\n\
|
||||
stack <pid> - returns the stack of the specified pid\n\
|
||||
"
|
||||
diff --git a/arch/um/drivers/mconsole_user.c b/arch/um/drivers/mconsole_user.c
|
||||
index 9920982..3ed0d32 100644
|
||||
--- a/arch/um/drivers/mconsole_user.c
|
||||
+++ b/arch/um/drivers/mconsole_user.c
|
||||
@@ -30,6 +30,7 @@ static struct mconsole_command commands[] = {
|
||||
{ "stop", mconsole_stop, MCONSOLE_PROC },
|
||||
{ "go", mconsole_go, MCONSOLE_INTR },
|
||||
{ "log", mconsole_log, MCONSOLE_INTR },
|
||||
+ { "exec", mconsole_exec, MCONSOLE_PROC },
|
||||
{ "proc", mconsole_proc, MCONSOLE_PROC },
|
||||
{ "stack", mconsole_stack, MCONSOLE_INTR },
|
||||
};
|
||||
diff --git a/arch/um/os-Linux/file.c b/arch/um/os-Linux/file.c
|
||||
index c17bd6f..1c55fa8 100644
|
||||
--- a/arch/um/os-Linux/file.c
|
||||
+++ b/arch/um/os-Linux/file.c
|
||||
@@ -519,6 +519,8 @@ int os_create_unix_socket(const char *file, int len, int close_on_exec)
|
||||
|
||||
addr.sun_family = AF_UNIX;
|
||||
|
||||
+ if (len > sizeof(addr.sun_path))
|
||||
+ len = sizeof(addr.sun_path);
|
||||
snprintf(addr.sun_path, len, "%s", file);
|
||||
|
||||
err = bind(sock, (struct sockaddr *) &addr, sizeof(addr));
|
||||
diff --git a/include/linux/kmod.h b/include/linux/kmod.h
|
||||
index 0555cc6..476084d 100644
|
||||
--- a/include/linux/kmod.h
|
||||
+++ b/include/linux/kmod.h
|
||||
@@ -62,6 +62,7 @@ struct subprocess_info {
|
||||
int wait;
|
||||
int retval;
|
||||
int (*init)(struct subprocess_info *info, struct cred *new);
|
||||
+ struct file *stdout;
|
||||
void (*cleanup)(struct subprocess_info *info);
|
||||
void *data;
|
||||
};
|
||||
@@ -104,4 +105,6 @@ extern int usermodehelper_read_trylock(void);
|
||||
extern long usermodehelper_read_lock_wait(long timeout);
|
||||
extern void usermodehelper_read_unlock(void);
|
||||
|
||||
+int call_usermodehelper_stdoutpipe(struct subprocess_info *sub_info, struct file **filp);
|
||||
+
|
||||
#endif /* __LINUX_KMOD_H__ */
|
||||
diff --git a/kernel/kmod.c b/kernel/kmod.c
|
||||
index 8241906..2d7f718 100644
|
||||
--- a/kernel/kmod.c
|
||||
+++ b/kernel/kmod.c
|
||||
@@ -39,6 +39,7 @@
|
||||
#include <linux/rwsem.h>
|
||||
#include <linux/ptrace.h>
|
||||
#include <linux/async.h>
|
||||
+#include <linux/pipe_fs_i.h>
|
||||
#include <asm/uaccess.h>
|
||||
|
||||
#include <trace/events/module.h>
|
||||
@@ -206,6 +207,28 @@ static int ____call_usermodehelper(void *data)
|
||||
flush_signal_handlers(current, 1);
|
||||
spin_unlock_irq(¤t->sighand->siglock);
|
||||
|
||||
+ /* Install output when needed */
|
||||
+ if (sub_info->stdout) {
|
||||
+ struct files_struct *f = current->files;
|
||||
+ struct fdtable *fdt;
|
||||
+
|
||||
+ sys_close(1);
|
||||
+ sys_close(2);
|
||||
+ get_file(sub_info->stdout);
|
||||
+ fd_install(1, sub_info->stdout);
|
||||
+ fd_install(2, sub_info->stdout);
|
||||
+ spin_lock(&f->file_lock);
|
||||
+ fdt = files_fdtable(f);
|
||||
+ __set_bit(1, fdt->open_fds);
|
||||
+ __clear_bit(1, fdt->close_on_exec);
|
||||
+ __set_bit(2, fdt->open_fds);
|
||||
+ __clear_bit(2, fdt->close_on_exec);
|
||||
+ spin_unlock(&f->file_lock);
|
||||
+
|
||||
+ /* disallow core files */
|
||||
+ current->signal->rlim[RLIMIT_CORE] = (struct rlimit){0, 0};
|
||||
+ }
|
||||
+
|
||||
/* We can run anywhere, unlike our parent keventd(). */
|
||||
set_cpus_allowed_ptr(current, cpu_all_mask);
|
||||
|
||||
@@ -551,6 +574,20 @@ struct subprocess_info *call_usermodehelper_setup(char *path, char **argv,
|
||||
}
|
||||
EXPORT_SYMBOL(call_usermodehelper_setup);
|
||||
|
||||
+int call_usermodehelper_stdoutpipe(struct subprocess_info *sub_info,
|
||||
+ struct file **filp)
|
||||
+{
|
||||
+ struct file *f[2];
|
||||
+
|
||||
+ if (create_pipe_files(f, 0)<0)
|
||||
+ return PTR_ERR(f);
|
||||
+ sub_info->stdout = f[1];
|
||||
+ *filp = f[0];
|
||||
+ return 0;
|
||||
+}
|
||||
+EXPORT_SYMBOL(call_usermodehelper_stdoutpipe);
|
||||
+
|
||||
+
|
||||
/**
|
||||
* call_usermodehelper_exec - start a usermode application
|
||||
* @sub_info: information about the subprocessa
|
129
target/linux/uml/patches-3.10/102-pseudo-random-mac.patch
Normal file
129
target/linux/uml/patches-3.10/102-pseudo-random-mac.patch
Normal file
|
@ -0,0 +1,129 @@
|
|||
===============================================================================
|
||||
|
||||
This patch makes MAC addresses of network interfaces predictable. In
|
||||
particular, it adds a small routine that computes MAC addresses of based on
|
||||
a SHA1 hash of the virtual machine name and interface ID.
|
||||
|
||||
TECHNICAL INFORMATION:
|
||||
|
||||
Applies to vanilla kernel 3.9.4.
|
||||
|
||||
===============================================================================
|
||||
diff -aur linux-3.9.4-orig/arch/um/Kconfig.net linux-3.9.4/arch/um/Kconfig.net
|
||||
--- linux-3.9.4-orig/arch/um/Kconfig.net 2013-05-24 21:45:59.000000000 +0300
|
||||
+++ linux-3.9.4/arch/um/Kconfig.net 2013-06-11 13:07:06.363999999 +0300
|
||||
@@ -21,6 +21,19 @@
|
||||
enable at least one of the following transport options to actually
|
||||
make use of UML networking.
|
||||
|
||||
+config UML_NET_RANDOM_MAC
|
||||
+ bool "Use random MAC addresses for network interfaces"
|
||||
+ default n
|
||||
+ depends on UML_NET
|
||||
+ help
|
||||
+ Virtual network devices inside a User-Mode Linux instance must be
|
||||
+ assigned a MAC (Ethernet) address. If none is specified on the UML
|
||||
+ command line, one must be automatically computed. If this option is
|
||||
+ enabled, a randomly generated address is used. Otherwise, if this
|
||||
+ option is disabled, the address is generated from a SHA1 hash of
|
||||
+ the umid of the UML instance and the interface name. The latter choice
|
||||
+ is useful to make MAC addresses predictable.
|
||||
+
|
||||
config UML_NET_ETHERTAP
|
||||
bool "Ethertap transport"
|
||||
depends on UML_NET
|
||||
diff -aur linux-3.9.4-orig/arch/um/drivers/net_kern.c linux-3.9.4/arch/um/drivers/net_kern.c
|
||||
--- linux-3.9.4-orig/arch/um/drivers/net_kern.c 2013-05-24 21:45:59.000000000 +0300
|
||||
+++ linux-3.9.4/arch/um/drivers/net_kern.c 2013-06-11 13:09:03.452000001 +0300
|
||||
@@ -25,6 +25,13 @@
|
||||
#include <net_kern.h>
|
||||
#include <net_user.h>
|
||||
|
||||
+#include <crypto/sha.h>
|
||||
+#include <linux/string.h>
|
||||
+#include <linux/crypto.h>
|
||||
+#include <linux/err.h>
|
||||
+#include <linux/scatterlist.h>
|
||||
+#include "os.h"
|
||||
+
|
||||
#define DRIVER_NAME "uml-netdev"
|
||||
|
||||
static DEFINE_SPINLOCK(opened_lock);
|
||||
@@ -295,11 +302,47 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
+#ifndef CONFIG_UML_NET_RANDOM_MAC
|
||||
+
|
||||
+/* Compute a SHA1 hash of the UML instance's id and
|
||||
+ * * an interface name. */
|
||||
+static int compute_hash(const char *umid, const char *ifname, char *hash) {
|
||||
+ char vmif[1024];
|
||||
+ struct scatterlist sg;
|
||||
+ struct crypto_hash *tfm;
|
||||
+ struct hash_desc desc;
|
||||
+
|
||||
+ strcpy (vmif, umid);
|
||||
+ strcat (vmif, ifname);
|
||||
+
|
||||
+ tfm = crypto_alloc_hash("sha1", 0, CRYPTO_ALG_ASYNC);
|
||||
+ if (IS_ERR(tfm))
|
||||
+ return 1;
|
||||
+
|
||||
+ desc.tfm = tfm;
|
||||
+ desc.flags = 0;
|
||||
+
|
||||
+ sg_init_table(&sg, 1);
|
||||
+ sg_set_buf(&sg, vmif, strlen(vmif));
|
||||
+
|
||||
+ if (crypto_hash_digest(&desc, &sg, strlen(vmif), hash)) {
|
||||
+ crypto_free_hash(tfm);
|
||||
+ return 1;
|
||||
+ }
|
||||
+
|
||||
+ crypto_free_hash(tfm);
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+#endif
|
||||
+
|
||||
static void setup_etheraddr(struct net_device *dev, char *str)
|
||||
{
|
||||
unsigned char *addr = dev->dev_addr;
|
||||
char *end;
|
||||
int i;
|
||||
+ u8 hash[SHA1_DIGEST_SIZE];
|
||||
|
||||
if (str == NULL)
|
||||
goto random;
|
||||
@@ -340,9 +383,26 @@
|
||||
return;
|
||||
|
||||
random:
|
||||
+#ifdef CONFIG_UML_NET_RANDOM_MAC
|
||||
printk(KERN_INFO
|
||||
"Choosing a random ethernet address for device %s\n", dev->name);
|
||||
eth_hw_addr_random(dev);
|
||||
+#else
|
||||
+ printk(KERN_INFO
|
||||
+ "Computing a digest to use as ethernet address for device %s\n", dev->name);
|
||||
+ if (compute_hash(get_umid(), dev->name, hash)) {
|
||||
+ printk(KERN_WARNING
|
||||
+ "Could not compute digest to use as ethernet address for device %s. "
|
||||
+ "Using random address instead.\n", dev->name);
|
||||
+ random_ether_addr(addr);
|
||||
+ }
|
||||
+ else {
|
||||
+ for (i=0; i < 6; i++)
|
||||
+ addr[i] = (hash[i] + hash[i+6]) % 0x100;
|
||||
+ }
|
||||
+ addr [0] &= 0xfe; /* clear multicast bit */
|
||||
+ addr [0] |= 0x02; /* set local assignment bit (IEEE802) */
|
||||
+#endif
|
||||
}
|
||||
|
||||
static DEFINE_SPINLOCK(devices_lock);
|
||||
Only in linux-3.9.4/arch/um/drivers: net_kern.c.orig
|
||||
Only in linux-3.9.4/arch/um/drivers: net_kern.c.rej
|
||||
Only in linux-3.9.4/arch/um/drivers: net_kern.c~
|
|
@ -1,24 +0,0 @@
|
|||
diff --git a/arch/um/os-Linux/signal.c b/arch/um/os-Linux/signal.c
|
||||
index b1469fe..9d9f1b4 100644
|
||||
--- a/arch/um/os-Linux/signal.c
|
||||
+++ b/arch/um/os-Linux/signal.c
|
||||
@@ -15,7 +15,7 @@
|
||||
#include <sysdep/mcontext.h>
|
||||
#include "internal.h"
|
||||
|
||||
-void (*sig_info[NSIG])(int, siginfo_t *, struct uml_pt_regs *) = {
|
||||
+void (*sig_info[NSIG])(int, struct siginfo *, struct uml_pt_regs *) = {
|
||||
[SIGTRAP] = relay_signal,
|
||||
[SIGFPE] = relay_signal,
|
||||
[SIGILL] = relay_signal,
|
||||
--- a/arch/um/os-Linux/start_up.c
|
||||
+++ b/arch/um/os-Linux/start_up.c
|
||||
@@ -15,6 +15,8 @@
|
||||
#include <sys/mman.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <sys/time.h>
|
||||
+#include <sys/resource.h>
|
||||
#include <asm/unistd.h>
|
||||
#include <init.h>
|
||||
#include <os.h>
|
Loading…
Reference in a new issue