avr32: remove target
It depends on obsolete compilers and only works on one device (an evaluation board). Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44956
This commit is contained in:
parent
3b6c70b7fc
commit
2450985de9
12 changed files with 0 additions and 375 deletions
|
@ -1,25 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2007-2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
ARCH:=avr32
|
|
||||||
BOARD:=avr32
|
|
||||||
BOARDNAME:=Atmel AVR32
|
|
||||||
FEATURES:=squashfs
|
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
|
||||||
|
|
||||||
KERNEL_PATCHVER:=3.10
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
|
||||||
|
|
||||||
define Target/Description
|
|
||||||
Build firmware images for ATNGW100 board
|
|
||||||
endef
|
|
||||||
|
|
||||||
KERNELNAME:=uImage
|
|
||||||
|
|
||||||
$(eval $(call BuildTarget))
|
|
|
@ -1,5 +0,0 @@
|
||||||
define Package/base-files/install-target
|
|
||||||
rm -f $(1)/etc/config/network
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
|
@ -1,26 +0,0 @@
|
||||||
#!/bin/sh
|
|
||||||
# Copyright (C) 2013 OpenWrt.org
|
|
||||||
|
|
||||||
. /lib/functions/leds.sh
|
|
||||||
|
|
||||||
set_state() {
|
|
||||||
status_led="sys"
|
|
||||||
|
|
||||||
case "$1" in
|
|
||||||
preinit)
|
|
||||||
status_led_blink_preinit
|
|
||||||
;;
|
|
||||||
|
|
||||||
failsafe)
|
|
||||||
status_led_blink_failsafe
|
|
||||||
;;
|
|
||||||
|
|
||||||
preinit_regular)
|
|
||||||
status_led_blink_preinit_regular
|
|
||||||
;;
|
|
||||||
|
|
||||||
done)
|
|
||||||
status_led_on
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
}
|
|
|
@ -1,17 +0,0 @@
|
||||||
#!/bin/sh
|
|
||||||
#
|
|
||||||
# Copyright (C) 2013 OpenWrt.org
|
|
||||||
#
|
|
||||||
|
|
||||||
[ -e /etc/config/network ] && exit 0
|
|
||||||
|
|
||||||
touch /etc/config/network
|
|
||||||
|
|
||||||
. /lib/functions/uci-defaults.sh
|
|
||||||
|
|
||||||
ucidef_set_interface_loopback
|
|
||||||
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
|
||||||
|
|
||||||
uci commit network
|
|
||||||
|
|
||||||
exit 0
|
|
|
@ -1,28 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2013 OpenWrt.org
|
|
||||||
#
|
|
||||||
|
|
||||||
PART_NAME=firmware
|
|
||||||
|
|
||||||
platform_check_image() {
|
|
||||||
local magic="$(get_magic_long "$1")"
|
|
||||||
|
|
||||||
[ "$#" -gt 1 ] && return 1
|
|
||||||
|
|
||||||
[ "$magic" != "27051956" ] && {
|
|
||||||
echo "Invalid image type."
|
|
||||||
return 1
|
|
||||||
}
|
|
||||||
|
|
||||||
return 0
|
|
||||||
}
|
|
||||||
|
|
||||||
disable_watchdog() {
|
|
||||||
killall watchdog
|
|
||||||
( ps | grep -v 'grep' | grep '/dev/watchdog' ) && {
|
|
||||||
echo 'Could not disable watchdog'
|
|
||||||
return 1
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
append sysupgrade_pre_upgrade disable_watchdog
|
|
|
@ -1,112 +0,0 @@
|
||||||
CONFIG_AP700X_16_BIT_SMC=y
|
|
||||||
# CONFIG_AP700X_32_BIT_SMC is not set
|
|
||||||
# CONFIG_AP700X_8_BIT_SMC is not set
|
|
||||||
# CONFIG_ARCH_DISCONTIGMEM_ENABLE is not set
|
|
||||||
CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE=y
|
|
||||||
CONFIG_ARCH_HAVE_CUSTOM_GPIO_H=y
|
|
||||||
# CONFIG_ARCH_HAVE_MEMORY_PRESENT is not set
|
|
||||||
CONFIG_ARCH_HAVE_NMI_SAFE_CMPXCHG=y
|
|
||||||
CONFIG_ARCH_REQUIRE_GPIOLIB=y
|
|
||||||
# CONFIG_ARCH_SPARSEMEM_ENABLE is not set
|
|
||||||
CONFIG_ARCH_SUSPEND_POSSIBLE=y
|
|
||||||
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
|
|
||||||
CONFIG_ATMEL_TCB_CLKSRC=y
|
|
||||||
CONFIG_ATMEL_TCB_CLKSRC_BLOCK=0
|
|
||||||
CONFIG_ATMEL_TCLIB=y
|
|
||||||
CONFIG_AVR32=y
|
|
||||||
CONFIG_BOARD_ATNGW100_ADDON_NONE=y
|
|
||||||
CONFIG_BOARD_ATNGW100_COMMON=y
|
|
||||||
# CONFIG_BOARD_ATNGW100_EVKLCD10X is not set
|
|
||||||
CONFIG_BOARD_ATNGW100_MKI=y
|
|
||||||
# CONFIG_BOARD_ATNGW100_MKII is not set
|
|
||||||
# CONFIG_BOARD_ATNGW100_MRMT is not set
|
|
||||||
# CONFIG_BOARD_ATSTK1000 is not set
|
|
||||||
# CONFIG_BOARD_FAVR_32 is not set
|
|
||||||
# CONFIG_BOARD_HAMMERHEAD is not set
|
|
||||||
# CONFIG_BOARD_MERISC is not set
|
|
||||||
# CONFIG_BOARD_MIMC200 is not set
|
|
||||||
CONFIG_CPU_AT32AP7000=y
|
|
||||||
CONFIG_CPU_AT32AP700X=y
|
|
||||||
CONFIG_DMADEVICES=y
|
|
||||||
CONFIG_DMA_ENGINE=y
|
|
||||||
CONFIG_DW_DMAC=y
|
|
||||||
CONFIG_DW_DMAC_BIG_ENDIAN_IO=y
|
|
||||||
CONFIG_ENTRY_ADDRESS=0x90000000
|
|
||||||
CONFIG_GENERIC_ALLOCATOR=y
|
|
||||||
CONFIG_GENERIC_ATOMIC64=y
|
|
||||||
CONFIG_GENERIC_BUG=y
|
|
||||||
CONFIG_GENERIC_CLOCKEVENTS=y
|
|
||||||
CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
|
|
||||||
CONFIG_GENERIC_IO=y
|
|
||||||
CONFIG_GENERIC_IRQ_SHOW=y
|
|
||||||
CONFIG_GPIOLIB=y
|
|
||||||
CONFIG_GPIO_DEVRES=y
|
|
||||||
CONFIG_HARDIRQS_SW_RESEND=y
|
|
||||||
CONFIG_HAS_DMA=y
|
|
||||||
CONFIG_HAS_IOMEM=y
|
|
||||||
CONFIG_HAS_IOPORT=y
|
|
||||||
# CONFIG_HAVE_64BIT_ALIGNED_ACCESS is not set
|
|
||||||
# CONFIG_HAVE_BOOTMEM_INFO_NODE is not set
|
|
||||||
CONFIG_HAVE_CLK=y
|
|
||||||
CONFIG_HAVE_FB_ATMEL=y
|
|
||||||
# CONFIG_HAVE_GENERIC_DMA_COHERENT is not set
|
|
||||||
CONFIG_HAVE_GENERIC_HARDIRQS=y
|
|
||||||
CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
|
|
||||||
CONFIG_HAVE_NET_DSA=y
|
|
||||||
CONFIG_HAVE_OPROFILE=y
|
|
||||||
CONFIG_I2C_BOARDINFO=y
|
|
||||||
CONFIG_INITRAMFS_SOURCE=""
|
|
||||||
CONFIG_IRQ_WORK=y
|
|
||||||
CONFIG_LEDS_GPIO=y
|
|
||||||
CONFIG_LOADER_U_BOOT=y
|
|
||||||
CONFIG_LOAD_ADDRESS=0x10000000
|
|
||||||
CONFIG_MACB=y
|
|
||||||
CONFIG_MDIO_BOARDINFO=y
|
|
||||||
CONFIG_MODULES_USE_ELF_RELA=y
|
|
||||||
# CONFIG_MTD_CFI_INTELEXT is not set
|
|
||||||
CONFIG_MTD_CMDLINE_PARTS=y
|
|
||||||
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
|
|
||||||
CONFIG_MTD_DATAFLASH=y
|
|
||||||
# CONFIG_MTD_DATAFLASH_OTP is not set
|
|
||||||
# CONFIG_MTD_DATAFLASH_WRITE_VERIFY is not set
|
|
||||||
CONFIG_MTD_PHYSMAP=y
|
|
||||||
CONFIG_MTD_SPLIT_FIRMWARE=y
|
|
||||||
CONFIG_MTD_SPLIT_SQUASHFS_ROOT=y
|
|
||||||
CONFIG_MTD_SPLIT_UIMAGE_FW=y
|
|
||||||
# CONFIG_NEED_NODE_MEMMAP_SIZE is not set
|
|
||||||
CONFIG_NEED_PER_CPU_KM=y
|
|
||||||
# CONFIG_NET_DMA is not set
|
|
||||||
# CONFIG_NMI_DEBUGGING is not set
|
|
||||||
CONFIG_NO_HZ=y
|
|
||||||
CONFIG_NO_HZ_COMMON=y
|
|
||||||
CONFIG_NO_HZ_IDLE=y
|
|
||||||
CONFIG_NR_QUICK=2
|
|
||||||
# CONFIG_OWNERSHIP_TRACE is not set
|
|
||||||
CONFIG_PAGEFLAGS_EXTENDED=y
|
|
||||||
CONFIG_PERFORMANCE_COUNTERS=y
|
|
||||||
CONFIG_PHYLIB=y
|
|
||||||
CONFIG_PHYS_OFFSET=0x10000000
|
|
||||||
CONFIG_PLATFORM_AT32AP=y
|
|
||||||
# CONFIG_PREEMPT_RCU is not set
|
|
||||||
CONFIG_QUICKLIST=y
|
|
||||||
# CONFIG_RCU_STALL_COMMON is not set
|
|
||||||
CONFIG_RTC_CLASS=y
|
|
||||||
CONFIG_RTC_DRV_AT32AP700X=y
|
|
||||||
# CONFIG_RWSEM_XCHGADD_ALGORITHM is not set
|
|
||||||
CONFIG_SCHED_HRTICK=y
|
|
||||||
# CONFIG_SCSI_DMA is not set
|
|
||||||
# CONFIG_SERIAL_8250 is not set
|
|
||||||
CONFIG_SERIAL_ATMEL=y
|
|
||||||
CONFIG_SERIAL_ATMEL_CONSOLE=y
|
|
||||||
CONFIG_SERIAL_ATMEL_PDC=y
|
|
||||||
# CONFIG_SERIAL_ATMEL_TTYAT is not set
|
|
||||||
CONFIG_SPI=y
|
|
||||||
CONFIG_SPI_ATMEL=y
|
|
||||||
CONFIG_SPI_MASTER=y
|
|
||||||
CONFIG_SUBARCH_AVR32B=y
|
|
||||||
CONFIG_TICK_CPU_ACCOUNTING=y
|
|
||||||
CONFIG_UIDGID_CONVERTED=y
|
|
||||||
# CONFIG_USB_ARCH_HAS_EHCI is not set
|
|
||||||
# CONFIG_USB_ARCH_HAS_OHCI is not set
|
|
||||||
# CONFIG_USB_ARCH_HAS_XHCI is not set
|
|
||||||
CONFIG_ZONE_DMA_FLAG=0
|
|
|
@ -1,13 +0,0 @@
|
||||||
config AVR32_UBOOT
|
|
||||||
bool "Build U-Boot bootloader"
|
|
||||||
depends on TARGET_avr32
|
|
||||||
default n
|
|
||||||
|
|
||||||
config AVR32_UBOOT_TARGET
|
|
||||||
string "U-Boot target board"
|
|
||||||
depends on TARGET_avr32
|
|
||||||
depends on AVR32_UBOOT
|
|
||||||
default "atngw100"
|
|
||||||
help
|
|
||||||
For all supported boards there are ready-to-use default
|
|
||||||
configurations available; just type "<board_name>".
|
|
|
@ -1,55 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2007-2010 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
include $(INCLUDE_DIR)/image.mk
|
|
||||||
|
|
||||||
KDIR_TMP:=$(KDIR)/tmp
|
|
||||||
|
|
||||||
ifneq ($(CONFIG_AVR32_UBOOT),)
|
|
||||||
define Build/Clean
|
|
||||||
$(MAKE) -C u-boot clean
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C u-boot compile
|
|
||||||
endef
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Image/BuildKernel
|
|
||||||
-mkdir -p $(KDIR_TMP)
|
|
||||||
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
|
|
||||||
|
|
||||||
$(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
|
|
||||||
mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
|
|
||||||
-e 0x90000000 \
|
|
||||||
-n 'OpenWrt Linux-$(LINUX_VERSION)' \
|
|
||||||
-d $(KDIR)/vmlinux.lzma $(KDIR)/uImage-lzma
|
|
||||||
|
|
||||||
cp $(KDIR)/uImage-lzma $(BIN_DIR)/$(IMG_PREFIX)-uImage-lzma
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Image/Build
|
|
||||||
$(call Image/Build/$(1),$(1))
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Image/Build/squashfs
|
|
||||||
( \
|
|
||||||
cat $(KDIR)/uImage-lzma; \
|
|
||||||
cat $(KDIR)/root.squashfs; \
|
|
||||||
) > $(KDIR_TMP)/avr32-squahsfs.img
|
|
||||||
padjffs2 $(KDIR_TMP)/avr32-squahsfs.img 64
|
|
||||||
dd if=$(KDIR_TMP)/avr32-squahsfs.img of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Image/Build/jffs2-64k
|
|
||||||
( \
|
|
||||||
dd if=$(KDIR)/uImage-lzma bs=64k conv=sync; \
|
|
||||||
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
|
|
||||||
) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildImage))
|
|
|
@ -1,35 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2008-2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
|
||||||
|
|
||||||
PKG_NAME:=u-boot
|
|
||||||
PKG_VERSION:=2011.06
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
|
|
||||||
PKG_MD5SUM:=0cc5026aad02f218a9b9ac56b301c97a
|
|
||||||
PKG_CAT:=bzcat
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
UBOOT_CONFIG=$(call qstrip,$(CONFIG_AVR32_UBOOT_TARGET))
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
mkdir -p $(BIN_DIR)
|
|
||||||
dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(PKG_VERSION)-$(UBOOT_CONFIG).bin bs=64k conv=sync
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call Build/DefaultTargets))
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- a/include/configs/atngw100.h
|
|
||||||
+++ b/include/configs/atngw100.h
|
|
||||||
@@ -65,6 +65,7 @@
|
|
||||||
#define CONFIG_USART_ID 1
|
|
||||||
/* User serviceable stuff */
|
|
||||||
#define CONFIG_DOS_PARTITION
|
|
||||||
+#define CONFIG_LZMA
|
|
||||||
|
|
||||||
#define CONFIG_CMDLINE_TAG
|
|
||||||
#define CONFIG_SETUP_MEMORY_TAGS
|
|
|
@ -1,38 +0,0 @@
|
||||||
#
|
|
||||||
# Copyright (C) 2010 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
define KernelPackage/atmel-wdt
|
|
||||||
SUBMENU:=$(OTHER_MENU)
|
|
||||||
TITLE:=AT32AP700x watchdog
|
|
||||||
DEPENDS:=@TARGET_avr32
|
|
||||||
KCONFIG:=CONFIG_AT32AP700X_WDT
|
|
||||||
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/at32ap700x_wdt.ko
|
|
||||||
AUTOLOAD:=$(call AutoLoad,50,at32ap700x_wdt)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/atmel-wdt/description
|
|
||||||
AT32AP700x watchdog
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call KernelPackage,atmel-wdt))
|
|
||||||
|
|
||||||
|
|
||||||
define KernelPackage/mmc-atmelmci
|
|
||||||
SUBMENU:=$(OTHER_MENU)
|
|
||||||
TITLE:=Amtel MMC Support
|
|
||||||
DEPENDS:=@TARGET_avr32 +kmod-mmc
|
|
||||||
KCONFIG:=CONFIG_MMC_ATMELMCI
|
|
||||||
FILES:=$(LINUX_DIR)/drivers/mmc/host/atmel-mci.ko
|
|
||||||
AUTOLOAD:=$(call AutoLoad,90,atmel-mci)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/mmc-atmelmci/description
|
|
||||||
Kernel support for Atmel Multimedia Card Interface.
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call KernelPackage,mmc-atmelmci,1))
|
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/arch/avr32/boards/atngw100/flash.c
|
|
||||||
+++ b/arch/avr32/boards/atngw100/flash.c
|
|
||||||
@@ -45,7 +45,7 @@ static struct mtd_partition flash_parts[
|
|
||||||
.mask_flags = MTD_WRITEABLE,
|
|
||||||
},
|
|
||||||
{
|
|
||||||
- .name = "root",
|
|
||||||
+ .name = "firmware",
|
|
||||||
.offset = 0x00020000,
|
|
||||||
.size = 0x007d0000,
|
|
||||||
},
|
|
Loading…
Reference in a new issue