ppl: go back to version 0.10.2
GCC 4.5 needs ppl in version 0.10.2. The patch makes it compile with gmp 5. SVN-Revision: 24680
This commit is contained in:
parent
97860d1c5c
commit
22a7f8afb1
2 changed files with 44 additions and 4 deletions
|
@ -7,11 +7,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ppl
|
||||
PKG_VERSION:=0.11
|
||||
PKG_VERSION:=0.10.2
|
||||
|
||||
PKG_SOURCE_URL:=ftp://ftp.cs.unipr.it/pub/ppl/releases/$(PKG_VERSION)/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_MD5SUM:=c414abd2ecaf1f1f48949c78d383ee1a
|
||||
PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
|
||||
|
||||
HOST_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
|
|
38
tools/ppl/patches/001-gmp_5_fix.patch
Normal file
38
tools/ppl/patches/001-gmp_5_fix.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
From: Roberto Bagnara <bagnara@cs.unipr.it>
|
||||
Date: Sat, 9 Jan 2010 15:32:08 +0000 (+0100)
|
||||
Subject: Added support for GMP 5.0.
|
||||
X-Git-Url: http://www.cs.unipr.it/git/gitweb.cgi?p=ppl%2Fppl.git;a=commitdiff_plain;h=9c19bc2b318a35016e0189f9552c98910be37f53
|
||||
|
||||
Added support for GMP 5.0.
|
||||
---
|
||||
|
||||
diff --git a/m4/ac_check_gmp.m4 b/m4/ac_check_gmp.m4
|
||||
index 60cecdc..15acb18 100644
|
||||
--- a/m4/ac_check_gmp.m4
|
||||
+++ b/m4/ac_check_gmp.m4
|
||||
@@ -71,6 +71,10 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[
|
||||
#GMP version 4.1.3 or higher is required
|
||||
#endif
|
||||
|
||||
+#ifndef BITS_PER_MP_LIMB
|
||||
+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
|
||||
+#endif
|
||||
+
|
||||
int
|
||||
main() {
|
||||
std::string header_version;
|
||||
@@ -97,11 +101,11 @@ main() {
|
||||
return 1;
|
||||
}
|
||||
|
||||
- if (sizeof(mp_limb_t)*CHAR_BIT != GMP_LIMB_BITS
|
||||
- || GMP_LIMB_BITS != mp_bits_per_limb) {
|
||||
+ if (sizeof(mp_limb_t)*CHAR_BIT != BITS_PER_MP_LIMB
|
||||
+ || BITS_PER_MP_LIMB != mp_bits_per_limb) {
|
||||
std::cerr
|
||||
<< "GMP header (gmp.h) and library (ligmp.*) bits-per-limb mismatch:\n"
|
||||
- << "header gives " << __GMP_BITS_PER_MP_LIMB << ";\n"
|
||||
+ << "header gives " << BITS_PER_MP_LIMB << ";\n"
|
||||
<< "library gives " << mp_bits_per_limb << ".\n"
|
||||
<< "This probably means you are on a bi-arch system and\n"
|
||||
<< "you are compiling with the wrong header or linking with\n"
|
Loading…
Reference in a new issue