mac80211: move compat_firmware_class.ko into compat.ko (fixes #9864)
SVN-Revision: 27863
This commit is contained in:
parent
0cd8805b0a
commit
21dd9478d7
2 changed files with 17 additions and 8 deletions
|
@ -55,18 +55,10 @@ define KernelPackage/cfg80211
|
|||
$(call KernelPackage/mac80211/Default)
|
||||
TITLE:=cfg80211 - wireless configuration API
|
||||
DEPENDS+= +wireless-tools +iw +crda
|
||||
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.33)),1)
|
||||
FILES:= \
|
||||
$(PKG_BUILD_DIR)/compat/compat.ko \
|
||||
$(PKG_BUILD_DIR)/net/wireless/cfg80211.ko
|
||||
AUTOLOAD:=$(call AutoLoad,20,compat cfg80211)
|
||||
else
|
||||
FILES:= \
|
||||
$(PKG_BUILD_DIR)/compat/compat.ko \
|
||||
$(PKG_BUILD_DIR)/compat/compat_firmware_class.ko \
|
||||
$(PKG_BUILD_DIR)/net/wireless/cfg80211.ko
|
||||
AUTOLOAD:=$(call AutoLoad,20,compat compat_firmware_class cfg80211)
|
||||
endif
|
||||
endef
|
||||
|
||||
define KernelPackage/cfg80211/description
|
||||
|
|
17
package/mac80211/patches/050-compat_firmware.patch
Normal file
17
package/mac80211/patches/050-compat_firmware.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- a/compat/Makefile
|
||||
+++ b/compat/Makefile
|
||||
@@ -1,10 +1,13 @@
|
||||
obj-m += compat.o
|
||||
#compat-objs :=
|
||||
|
||||
-obj-$(CONFIG_COMPAT_FIRMWARE_CLASS) += compat_firmware_class.o
|
||||
|
||||
compat-y += main.o
|
||||
|
||||
+ifdef CONFIG_COMPAT_FIRMWARE_CLASS
|
||||
+ compat-y += compat_firmware_class.o
|
||||
+endif
|
||||
+
|
||||
# Compat kernel compatibility code
|
||||
compat-$(CONFIG_COMPAT_KERNEL_2_6_14) += compat-2.6.14.o
|
||||
compat-$(CONFIG_COMPAT_KERNEL_2_6_18) += compat-2.6.18.o
|
Loading…
Reference in a new issue