Revert "[tools] mklibs: update to 0.1.34"
Too much broken, needs to be reworked SVN-Revision: 32163
This commit is contained in:
parent
e2be7290b1
commit
1e7129ca50
13 changed files with 132 additions and 101 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2009-2012 OpenWrt.org
|
# Copyright (C) 2009 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,11 +7,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mklibs
|
PKG_NAME:=mklibs
|
||||||
PKG_VERSION:=0.1.34
|
PKG_VERSION:=0.1.29
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
|
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
|
||||||
PKG_MD5SUM:=afe0ed527ba96b8a882b5de350603007
|
PKG_MD5SUM:=7f35dfdbde249a090199829c1a1222d8
|
||||||
|
|
||||||
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mklibs
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -19,8 +21,8 @@ HOST_CFLAGS += -I$(CURDIR)/include
|
||||||
|
|
||||||
define Host/Install
|
define Host/Install
|
||||||
$(INSTALL_BIN) \
|
$(INSTALL_BIN) \
|
||||||
$(HOST_BUILD_DIR)/src/mklibs \
|
$(HOST_BUILD_DIR)/src/mklibs.py \
|
||||||
$(HOST_BUILD_DIR)/src/mklibs-copy \
|
$(HOST_BUILD_DIR)/src/mklibs-copy.py \
|
||||||
$(HOST_BUILD_DIR)/src/mklibs-readelf/mklibs-readelf \
|
$(HOST_BUILD_DIR)/src/mklibs-readelf/mklibs-readelf \
|
||||||
$(STAGING_DIR_HOST)/bin/
|
$(STAGING_DIR_HOST)/bin/
|
||||||
endef
|
endef
|
||||||
|
|
20
tools/mklibs/patches/001-missing_includes.patch
Normal file
20
tools/mklibs/patches/001-missing_includes.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
--- a/src/mklibs-readelf/elf.cpp
|
||||||
|
+++ b/src/mklibs-readelf/elf.cpp
|
||||||
|
@@ -25,6 +25,7 @@
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <sys/mman.h>
|
||||||
|
#include <sys/stat.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
|
||||||
|
using namespace Elf;
|
||||||
|
|
||||||
|
--- a/src/mklibs-readelf/main.cpp
|
||||||
|
+++ b/src/mklibs-readelf/main.cpp
|
||||||
|
@@ -7,6 +7,7 @@
|
||||||
|
|
||||||
|
#include <elf.h>
|
||||||
|
#include <getopt.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
|
||||||
|
#include "elf.hpp"
|
||||||
|
|
|
@ -1,20 +1,23 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -524,7 +524,7 @@ while 1:
|
@@ -500,7 +500,7 @@ while 1:
|
||||||
# No progress in last pass. Verify all remaining symbols are weak.
|
# No progress in last pass. Verify all remaining symbols are weak.
|
||||||
for name in unresolved:
|
for name in unresolved:
|
||||||
if not needed_symbols[name].weak:
|
if not needed_symbols[name].weak:
|
||||||
- raise Exception("Unresolvable symbol %s" % name)
|
- raise "Unresolvable symbol %s" % name
|
||||||
+ print "WARNING: Unresolvable symbol %s" % name
|
+ print "WARNING: Unresolvable symbol %s" % name
|
||||||
break
|
break
|
||||||
|
|
||||||
previous_pass_unresolved = unresolved
|
previous_pass_unresolved = unresolved
|
||||||
@@ -559,7 +559,7 @@ while 1:
|
@@ -533,10 +533,7 @@ while 1:
|
||||||
|
|
||||||
|
# which symbols are actually used from each lib
|
||||||
for name in needed_symbols:
|
for name in needed_symbols:
|
||||||
if not name in symbol_provider:
|
- if not name in symbol_provider:
|
||||||
if not needed_symbols[name].weak:
|
- if not needed_symbols[name].weak:
|
||||||
- raise Exception("No library provides non-weak %s" % name)
|
- raise "No library provides non-weak %s" % name
|
||||||
+ print "WARNING: Unresolvable symbol %s" % name
|
- else:
|
||||||
else:
|
+ if name in symbol_provider:
|
||||||
lib = symbol_provider[name]
|
lib = symbol_provider[name]
|
||||||
library_symbols_used[lib].add(library_symbols[lib][name])
|
library_symbols_used[lib].add(library_symbols[lib][name])
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -463,7 +463,7 @@ while 1:
|
@@ -440,7 +440,7 @@ while 1:
|
||||||
passnr = passnr + 1
|
passnr = passnr + 1
|
||||||
# Gather all already reduced libraries and treat them as objects as well
|
# Gather all already reduced libraries and treat them as objects as well
|
||||||
small_libs = []
|
small_libs = []
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
obj = dest_path + "/" + lib
|
obj = dest_path + "/" + lib
|
||||||
small_libs.append(obj)
|
small_libs.append(obj)
|
||||||
inode = os.stat(obj)[ST_INO]
|
inode = os.stat(obj)[ST_INO]
|
||||||
@@ -579,12 +579,7 @@ while 1:
|
@@ -552,12 +552,7 @@ while 1:
|
||||||
if not so_file:
|
if not so_file:
|
||||||
sys.exit("File not found:" + library)
|
sys.exit("File not found:" + library)
|
||||||
pic_file = find_pic(library)
|
pic_file = find_pic(library)
|
||||||
|
@ -23,7 +23,7 @@
|
||||||
# we have a pic file, recompile
|
# we have a pic file, recompile
|
||||||
debug(DEBUG_SPAM, "extracting from:", pic_file, "so_file:", so_file)
|
debug(DEBUG_SPAM, "extracting from:", pic_file, "so_file:", so_file)
|
||||||
soname = extract_soname(so_file)
|
soname = extract_soname(so_file)
|
||||||
@@ -627,22 +622,14 @@ while 1:
|
@@ -600,22 +595,14 @@ while 1:
|
||||||
cmd.append(library_depends_gcc_libnames(so_file))
|
cmd.append(library_depends_gcc_libnames(so_file))
|
||||||
command(target + "gcc", *cmd)
|
command(target + "gcc", *cmd)
|
||||||
|
|
||||||
|
|
|
@ -1,13 +1,13 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -106,14 +106,14 @@ def library_depends(obj):
|
@@ -105,14 +105,14 @@ def library_depends(obj):
|
||||||
|
|
||||||
# Return a list of libraries the passed objects depend on. The
|
# Return a list of libraries the passed objects depend on. The
|
||||||
# libraries are in "-lfoo" format suitable for passing to gcc.
|
# libraries are in "-lfoo" format suitable for passing to gcc.
|
||||||
-def library_depends_gcc_libnames(obj):
|
-def library_depends_gcc_libnames(obj):
|
||||||
+def library_depends_gcc_libnames(obj, soname):
|
+def library_depends_gcc_libnames(obj, soname):
|
||||||
if not os.access(obj, os.F_OK):
|
if not os.access(obj, os.F_OK):
|
||||||
raise Exception("Cannot find lib: " + obj)
|
raise "Cannot find lib: " + obj
|
||||||
libs = library_depends(obj)
|
libs = library_depends(obj)
|
||||||
ret = []
|
ret = []
|
||||||
for i in libs:
|
for i in libs:
|
||||||
|
@ -17,7 +17,7 @@
|
||||||
if match.group('ld'):
|
if match.group('ld'):
|
||||||
ret.append(find_lib(match.group(0)))
|
ret.append(find_lib(match.group(0)))
|
||||||
elif match.group('lib'):
|
elif match.group('lib'):
|
||||||
@@ -619,7 +619,7 @@ while 1:
|
@@ -592,7 +592,7 @@ while 1:
|
||||||
cmd.extend(extra_flags)
|
cmd.extend(extra_flags)
|
||||||
cmd.append("-lgcc")
|
cmd.append("-lgcc")
|
||||||
cmd.extend(["-L%s" % a for a in [dest_path] + [sysroot + b for b in lib_path if sysroot == "" or b not in ("/" + libdir + "/", "/usr/" + libdir + "/")]])
|
cmd.extend(["-L%s" % a for a in [dest_path] + [sysroot + b for b in lib_path if sysroot == "" or b not in ("/" + libdir + "/", "/usr/" + libdir + "/")]])
|
||||||
|
|
|
@ -1,39 +0,0 @@
|
||||||
--- a/src/mklibs
|
|
||||||
+++ b/src/mklibs
|
|
||||||
@@ -509,10 +509,7 @@ while 1:
|
|
||||||
num_unresolved = 0
|
|
||||||
unresolved = set()
|
|
||||||
for name in needed_symbols:
|
|
||||||
- if not name in present_symbols:
|
|
||||||
- debug(DEBUG_SPAM, "Still need: %s" % name)
|
|
||||||
- unresolved.add(name)
|
|
||||||
- num_unresolved = num_unresolved + 1
|
|
||||||
+ library_symbols[library][name] = symbol
|
|
||||||
|
|
||||||
debug (DEBUG_NORMAL, `len(needed_symbols)`, "symbols,",
|
|
||||||
`num_unresolved`, "unresolved")
|
|
||||||
@@ -531,7 +528,6 @@ while 1:
|
|
||||||
|
|
||||||
library_symbols = {}
|
|
||||||
library_symbols_used = {}
|
|
||||||
- symbol_provider = {}
|
|
||||||
|
|
||||||
# WORKAROUND: Always add libgcc on old-abi arm
|
|
||||||
header = elf_header(find_lib(libraries.copy().pop()))
|
|
||||||
@@ -557,12 +553,10 @@ while 1:
|
|
||||||
|
|
||||||
# which symbols are actually used from each lib
|
|
||||||
for name in needed_symbols:
|
|
||||||
- if not name in symbol_provider:
|
|
||||||
- if not needed_symbols[name].weak:
|
|
||||||
- print "WARNING: Unresolvable symbol %s" % name
|
|
||||||
- else:
|
|
||||||
- lib = symbol_provider[name]
|
|
||||||
- library_symbols_used[lib].add(library_symbols[lib][name])
|
|
||||||
+ for lib in libraries:
|
|
||||||
+ if name in library_symbols[lib]:
|
|
||||||
+ library_symbols_used[lib].add(library_symbols[lib][name])
|
|
||||||
+
|
|
||||||
|
|
||||||
# reduce libraries
|
|
||||||
for library in libraries:
|
|
33
tools/mklibs/patches/005-readelf_fixes.patch
Normal file
33
tools/mklibs/patches/005-readelf_fixes.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
--- a/src/mklibs-readelf/main.cpp
|
||||||
|
+++ b/src/mklibs-readelf/main.cpp
|
||||||
|
@@ -57,6 +57,10 @@ static void process_elf_header (Elf::fil
|
||||||
|
static void process_dynamics (Elf::file *file, int64_t tag)
|
||||||
|
{
|
||||||
|
const Elf::section_type<Elf::section_type_DYNAMIC> *section = file->get_section_DYNAMIC ();
|
||||||
|
+
|
||||||
|
+ if (!section)
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
|
for (std::vector<Elf::dynamic *>::const_iterator it = section->get_dynamics ().begin (); it != section->get_dynamics ().end (); ++it)
|
||||||
|
{
|
||||||
|
Elf::dynamic *dynamic = *it;
|
||||||
|
@@ -67,6 +71,9 @@ static void process_dynamics (Elf::file
|
||||||
|
|
||||||
|
static void process_symbols_provided (const Elf::section_type<Elf::section_type_DYNSYM> *section)
|
||||||
|
{
|
||||||
|
+ if (!section)
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
|
for (std::vector<Elf::symbol *>::const_iterator it = section->get_symbols ().begin (); it != section->get_symbols ().end (); ++it)
|
||||||
|
{
|
||||||
|
const Elf::symbol *symbol = *it;
|
||||||
|
@@ -95,6 +102,9 @@ static void process_symbols_provided (co
|
||||||
|
|
||||||
|
static void process_symbols_undefined (const Elf::section_type<Elf::section_type_DYNSYM> *section)
|
||||||
|
{
|
||||||
|
+ if (!section)
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
|
for (std::vector<Elf::symbol *>::const_iterator it = section->get_symbols ().begin (); it != section->get_symbols ().end (); ++it)
|
||||||
|
{
|
||||||
|
const Elf::symbol *symbol = *it;
|
32
tools/mklibs/patches/006-duplicate_syms.patch
Normal file
32
tools/mklibs/patches/006-duplicate_syms.patch
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
--- a/src/mklibs.py
|
||||||
|
+++ b/src/mklibs.py
|
||||||
|
@@ -507,7 +507,6 @@ while 1:
|
||||||
|
|
||||||
|
library_symbols = {}
|
||||||
|
library_symbols_used = {}
|
||||||
|
- symbol_provider = {}
|
||||||
|
|
||||||
|
# WORKAROUND: Always add libgcc on old-abi arm
|
||||||
|
header = elf_header(find_lib(libraries.copy().pop()))
|
||||||
|
@@ -525,17 +524,13 @@ while 1:
|
||||||
|
library_symbols_used[library] = set()
|
||||||
|
for symbol in symbols:
|
||||||
|
for name in symbol.base_names():
|
||||||
|
- if name in symbol_provider:
|
||||||
|
- debug(DEBUG_SPAM, "duplicate symbol %s in %s and %s" % (symbol, symbol_provider[name], library))
|
||||||
|
- else:
|
||||||
|
- library_symbols[library][name] = symbol
|
||||||
|
- symbol_provider[name] = library
|
||||||
|
+ library_symbols[library][name] = symbol
|
||||||
|
|
||||||
|
# which symbols are actually used from each lib
|
||||||
|
for name in needed_symbols:
|
||||||
|
- if name in symbol_provider:
|
||||||
|
- lib = symbol_provider[name]
|
||||||
|
- library_symbols_used[lib].add(library_symbols[lib][name])
|
||||||
|
+ for lib in libraries:
|
||||||
|
+ if name in library_symbols[lib]:
|
||||||
|
+ library_symbols_used[lib].add(library_symbols[lib][name])
|
||||||
|
|
||||||
|
# reduce libraries
|
||||||
|
for library in libraries:
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -597,6 +597,11 @@ while 1:
|
@@ -571,6 +571,11 @@ while 1:
|
||||||
extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
|
extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
|
||||||
symbols.add(ProvidedSymbol('__dso_handle', None, None, True))
|
symbols.add(ProvidedSymbol('__dso_handle', None, None, True))
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -609,7 +609,7 @@ while 1:
|
@@ -583,7 +583,7 @@ while 1:
|
||||||
# compile in only used symbols
|
# compile in only used symbols
|
||||||
cmd = []
|
cmd = []
|
||||||
cmd.extend(gcc_options)
|
cmd.extend(gcc_options)
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -113,11 +113,8 @@ def library_depends_gcc_libnames(obj, so
|
@@ -112,11 +112,8 @@ def library_depends_gcc_libnames(obj, so
|
||||||
ret = []
|
ret = []
|
||||||
for i in libs:
|
for i in libs:
|
||||||
match = re.match("^(((?P<ld>ld\S*)|(lib(?P<lib>\S+))))\.so.*$", i)
|
match = re.match("^(((?P<ld>ld\S*)|(lib(?P<lib>\S+))))\.so.*$", i)
|
||||||
|
@ -14,7 +14,7 @@
|
||||||
return ' '.join(ret)
|
return ' '.join(ret)
|
||||||
|
|
||||||
class Symbol(object):
|
class Symbol(object):
|
||||||
@@ -586,6 +583,7 @@ while 1:
|
@@ -560,6 +557,7 @@ while 1:
|
||||||
extra_flags = []
|
extra_flags = []
|
||||||
extra_pre_obj = []
|
extra_pre_obj = []
|
||||||
extra_post_obj = []
|
extra_post_obj = []
|
||||||
|
@ -22,7 +22,7 @@
|
||||||
|
|
||||||
symbols.update(library_symbols_used[library])
|
symbols.update(library_symbols_used[library])
|
||||||
|
|
||||||
@@ -616,9 +614,10 @@ while 1:
|
@@ -590,9 +588,10 @@ while 1:
|
||||||
cmd.append(pic_file)
|
cmd.append(pic_file)
|
||||||
cmd.extend(extra_post_obj)
|
cmd.extend(extra_post_obj)
|
||||||
cmd.extend(extra_flags)
|
cmd.extend(extra_flags)
|
|
@ -1,20 +0,0 @@
|
||||||
--- a/src/mklibs-readelf/main.cpp
|
|
||||||
+++ b/src/mklibs-readelf/main.cpp
|
|
||||||
@@ -84,7 +84,7 @@ static void process_symbols_provided (co
|
|
||||||
continue;
|
|
||||||
if (shndx == SHN_UNDEF || shndx == SHN_ABS)
|
|
||||||
continue;
|
|
||||||
- if (type != STT_NOTYPE && type != STT_OBJECT && type != STT_FUNC && type != STT_GNU_IFUNC && type != STT_COMMON && type != STT_TLS)
|
|
||||||
+ if (type != STT_NOTYPE && type != STT_OBJECT && type != STT_FUNC && type != STT_COMMON && type != STT_TLS)
|
|
||||||
continue;
|
|
||||||
if (!name.size())
|
|
||||||
continue;
|
|
||||||
@@ -115,7 +115,7 @@ static void process_symbols_undefined (c
|
|
||||||
continue;
|
|
||||||
if (shndx != SHN_UNDEF)
|
|
||||||
continue;
|
|
||||||
- if (type != STT_NOTYPE && type != STT_OBJECT && type != STT_FUNC && type != STT_GNU_IFUNC && type != STT_COMMON && type != STT_TLS)
|
|
||||||
+ if (type != STT_NOTYPE && type != STT_OBJECT && type != STT_FUNC && type != STT_COMMON && type != STT_TLS)
|
|
||||||
continue;
|
|
||||||
if (!name.size())
|
|
||||||
continue;
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/mklibs
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs
|
+++ b/src/mklibs.py
|
||||||
@@ -162,9 +162,10 @@ def undefined_symbols(obj):
|
@@ -161,9 +161,10 @@ def undefined_symbols(obj):
|
||||||
return result
|
return result
|
||||||
|
|
||||||
class ProvidedSymbol(Symbol):
|
class ProvidedSymbol(Symbol):
|
||||||
|
@ -12,7 +12,7 @@
|
||||||
|
|
||||||
def base_names(self):
|
def base_names(self):
|
||||||
ret = []
|
ret = []
|
||||||
@@ -205,11 +206,15 @@ def provided_symbols(obj):
|
@@ -204,11 +205,15 @@ def provided_symbols(obj):
|
||||||
if version_string.lower() not in ('base', 'none'):
|
if version_string.lower() not in ('base', 'none'):
|
||||||
version = version_string
|
version = version_string
|
||||||
|
|
||||||
|
@ -29,7 +29,7 @@
|
||||||
|
|
||||||
return result
|
return result
|
||||||
|
|
||||||
@@ -500,6 +505,9 @@ while 1:
|
@@ -476,6 +481,9 @@ while 1:
|
||||||
debug(DEBUG_SPAM, "present_symbols adding %s" % symbol)
|
debug(DEBUG_SPAM, "present_symbols adding %s" % symbol)
|
||||||
names = symbol.base_names()
|
names = symbol.base_names()
|
||||||
for name in names:
|
for name in names:
|
||||||
|
@ -39,7 +39,7 @@
|
||||||
present_symbols[name] = symbol
|
present_symbols[name] = symbol
|
||||||
|
|
||||||
# are we finished?
|
# are we finished?
|
||||||
@@ -593,12 +601,16 @@ while 1:
|
@@ -567,12 +575,16 @@ while 1:
|
||||||
# may segfault in ptmalloc_init due to undefined weak reference
|
# may segfault in ptmalloc_init due to undefined weak reference
|
||||||
extra_pre_obj.append(sysroot + libc_extras_dir + "/soinit.o")
|
extra_pre_obj.append(sysroot + libc_extras_dir + "/soinit.o")
|
||||||
extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
|
extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
|
Loading…
Reference in a new issue