ipq806x: refresh kernel patches
Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 45727
This commit is contained in:
parent
66950455b7
commit
1c6d332d8f
6 changed files with 12 additions and 43 deletions
|
@ -330,7 +330,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|||
controller->error = error;
|
||||
@@ -339,6 +571,8 @@ static int spi_qup_io_config(struct spi_
|
||||
struct spi_qup *controller = spi_master_get_devdata(spi->master);
|
||||
u32 config, iomode, mode;
|
||||
u32 config, iomode, mode, control;
|
||||
int ret, n_words, w_size;
|
||||
+ size_t dma_align = dma_get_cache_alignment();
|
||||
+ u32 dma_available = 0;
|
||||
|
@ -383,7 +383,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|||
iomode |= (mode << QUP_IO_M_OUTPUT_MODE_MASK_SHIFT);
|
||||
iomode |= (mode << QUP_IO_M_INPUT_MODE_MASK_SHIFT);
|
||||
|
||||
@@ -419,6 +670,14 @@ static int spi_qup_io_config(struct spi_
|
||||
@@ -428,6 +679,14 @@ static int spi_qup_io_config(struct spi_
|
||||
config &= ~(QUP_CONFIG_NO_INPUT | QUP_CONFIG_NO_OUTPUT | QUP_CONFIG_N);
|
||||
config |= xfer->bits_per_word - 1;
|
||||
config |= QUP_CONFIG_SPI_MODE;
|
||||
|
@ -398,7 +398,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|||
writel_relaxed(config, controller->base + QUP_CONFIG);
|
||||
|
||||
/* only write to OPERATIONAL_MASK when register is present */
|
||||
@@ -452,25 +711,29 @@ static int spi_qup_transfer_one(struct s
|
||||
@@ -461,25 +720,29 @@ static int spi_qup_transfer_one(struct s
|
||||
controller->tx_bytes = 0;
|
||||
spin_unlock_irqrestore(&controller->lock, flags);
|
||||
|
||||
|
@ -443,7 +443,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|||
exit:
|
||||
spi_qup_set_state(controller, QUP_STATE_RESET);
|
||||
spin_lock_irqsave(&controller->lock, flags);
|
||||
@@ -553,6 +816,7 @@ static int spi_qup_probe(struct platform
|
||||
@@ -563,6 +826,7 @@ static int spi_qup_probe(struct platform
|
||||
master->transfer_one = spi_qup_transfer_one;
|
||||
master->dev.of_node = pdev->dev.of_node;
|
||||
master->auto_runtime_pm = true;
|
||||
|
@ -451,7 +451,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|||
|
||||
platform_set_drvdata(pdev, master);
|
||||
|
||||
@@ -618,6 +882,56 @@ static int spi_qup_probe(struct platform
|
||||
@@ -628,6 +892,56 @@ static int spi_qup_probe(struct platform
|
||||
QUP_ERROR_INPUT_UNDER_RUN | QUP_ERROR_OUTPUT_UNDER_RUN,
|
||||
base + QUP_ERROR_FLAGS_EN);
|
||||
|
||||
|
@ -508,7 +508,7 @@ Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|||
writel_relaxed(0, base + SPI_CONFIG);
|
||||
writel_relaxed(SPI_IO_C_NO_TRI_STATE, base + SPI_IO_CONTROL);
|
||||
|
||||
@@ -730,6 +1044,11 @@ static int spi_qup_remove(struct platfor
|
||||
@@ -740,6 +1054,11 @@ static int spi_qup_remove(struct platfor
|
||||
if (ret)
|
||||
return ret;
|
||||
|
||||
|
|
|
@ -14,8 +14,6 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
|
|||
drivers/watchdog/qcom-wdt.c | 21 +++++++++++++++------
|
||||
1 file changed, 15 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/drivers/watchdog/qcom-wdt.c b/drivers/watchdog/qcom-wdt.c
|
||||
index aa85618..aa03ca8 100644
|
||||
--- a/drivers/watchdog/qcom-wdt.c
|
||||
+++ b/drivers/watchdog/qcom-wdt.c
|
||||
@@ -20,9 +20,9 @@
|
||||
|
@ -31,7 +29,7 @@ index aa85618..aa03ca8 100644
|
|||
|
||||
struct qcom_wdt {
|
||||
struct watchdog_device wdd;
|
||||
@@ -117,6 +117,8 @@ static int qcom_wdt_probe(struct platform_device *pdev)
|
||||
@@ -117,6 +117,8 @@ static int qcom_wdt_probe(struct platfor
|
||||
{
|
||||
struct qcom_wdt *wdt;
|
||||
struct resource *res;
|
||||
|
@ -40,7 +38,7 @@ index aa85618..aa03ca8 100644
|
|||
int ret;
|
||||
|
||||
wdt = devm_kzalloc(&pdev->dev, sizeof(*wdt), GFP_KERNEL);
|
||||
@@ -124,6 +126,14 @@ static int qcom_wdt_probe(struct platform_device *pdev)
|
||||
@@ -124,6 +126,14 @@ static int qcom_wdt_probe(struct platfor
|
||||
return -ENOMEM;
|
||||
|
||||
res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
|
||||
|
@ -55,7 +53,7 @@ index aa85618..aa03ca8 100644
|
|||
wdt->base = devm_ioremap_resource(&pdev->dev, res);
|
||||
if (IS_ERR(wdt->base))
|
||||
return PTR_ERR(wdt->base);
|
||||
@@ -203,9 +213,8 @@ static int qcom_wdt_remove(struct platform_device *pdev)
|
||||
@@ -203,9 +213,8 @@ static int qcom_wdt_remove(struct platfo
|
||||
}
|
||||
|
||||
static const struct of_device_id qcom_wdt_of_table[] = {
|
||||
|
@ -67,6 +65,3 @@ index aa85618..aa03ca8 100644
|
|||
{ },
|
||||
};
|
||||
MODULE_DEVICE_TABLE(of, qcom_wdt_of_table);
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
|
|
@ -13,8 +13,6 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
|
|||
arch/arm/boot/dts/qcom-ipq8064.dtsi | 14 +++++++++++++-
|
||||
1 file changed, 13 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/qcom-ipq8064.dtsi b/arch/arm/boot/dts/qcom-ipq8064.dtsi
|
||||
index cb225da..d01f618 100644
|
||||
--- a/arch/arm/boot/dts/qcom-ipq8064.dtsi
|
||||
+++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi
|
||||
@@ -60,6 +60,14 @@
|
||||
|
@ -48,6 +46,3 @@ index cb225da..d01f618 100644
|
|||
cpu-offset = <0x80000>;
|
||||
};
|
||||
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
|
|
@ -13,11 +13,9 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
|
|||
2 files changed, 258 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/qcom-ipq8064-db149.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 38c89ca..745360a 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -360,6 +360,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||
@@ -438,6 +438,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||
qcom-apq8084-ifc6540.dtb \
|
||||
qcom-apq8084-mtp.dtb \
|
||||
qcom-ipq8064-ap148.dtb \
|
||||
|
@ -25,9 +23,6 @@ index 38c89ca..745360a 100644
|
|||
qcom-msm8660-surf.dtb \
|
||||
qcom-msm8960-cdp.dtb \
|
||||
qcom-msm8974-sony-xperia-honami.dtb
|
||||
diff --git a/arch/arm/boot/dts/qcom-ipq8064-db149.dts b/arch/arm/boot/dts/qcom-ipq8064-db149.dts
|
||||
new file mode 100644
|
||||
index 0000000..224c54f
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/qcom-ipq8064-db149.dts
|
||||
@@ -0,0 +1,257 @@
|
||||
|
@ -288,6 +283,3 @@ index 0000000..224c54f
|
|||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
|
|
@ -27,9 +27,6 @@ Signed-off-by: Stanimir Varbanov <svarbanov@mm-sol.com>
|
|||
1 files changed, 231 insertions(+), 0 deletions(-)
|
||||
create mode 100644 Documentation/devicetree/bindings/pci/qcom,pcie.txt
|
||||
|
||||
diff --git a/Documentation/devicetree/bindings/pci/qcom,pcie.txt b/Documentation/devicetree/bindings/pci/qcom,pcie.txt
|
||||
new file mode 100644
|
||||
index 0000000..dcf7348
|
||||
--- /dev/null
|
||||
+++ b/Documentation/devicetree/bindings/pci/qcom,pcie.txt
|
||||
@@ -0,0 +1,231 @@
|
||||
|
|
|
@ -31,11 +31,9 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
|
|||
3 files changed, 4 insertions(+), 1 deletion(-)
|
||||
create mode 100644 arch/arm/mach-qcom/Makefile.boot
|
||||
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index 89c4b5c..4583ea5 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -311,7 +311,7 @@ config ARCH_MULTIPLATFORM
|
||||
@@ -314,7 +314,7 @@ config ARCH_MULTIPLATFORM
|
||||
select ARCH_WANT_OPTIONAL_GPIOLIB
|
||||
select ARM_HAS_SG_CHAIN
|
||||
select ARM_PATCH_PHYS_VIRT
|
||||
|
@ -44,11 +42,9 @@ index 89c4b5c..4583ea5 100644
|
|||
select CLKSRC_OF
|
||||
select COMMON_CLK
|
||||
select GENERIC_CLOCKEVENTS
|
||||
diff --git a/arch/arm/Makefile b/arch/arm/Makefile
|
||||
index 7453352..5d6f8ac 100644
|
||||
--- a/arch/arm/Makefile
|
||||
+++ b/arch/arm/Makefile
|
||||
@@ -240,9 +240,11 @@ MACHINE := arch/arm/mach-$(word 1,$(machine-y))/
|
||||
@@ -241,9 +241,11 @@ MACHINE := arch/arm/mach-$(word 1,$(mac
|
||||
else
|
||||
MACHINE :=
|
||||
endif
|
||||
|
@ -60,13 +56,7 @@ index 7453352..5d6f8ac 100644
|
|||
|
||||
machdirs := $(patsubst %,arch/arm/mach-%/,$(machine-y))
|
||||
platdirs := $(patsubst %,arch/arm/plat-%/,$(sort $(plat-y)))
|
||||
diff --git a/arch/arm/mach-qcom/Makefile.boot b/arch/arm/mach-qcom/Makefile.boot
|
||||
new file mode 100644
|
||||
index 0000000..67a6d5a
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/mach-qcom/Makefile.boot
|
||||
@@ -0,0 +1 @@
|
||||
+zreladdr-y+= 0x42208000
|
||||
--
|
||||
1.9.1
|
||||
|
||||
|
|
Loading…
Reference in a new issue