dropbear: update to 2016.73
Update the dropbear package to version 2016.73, refresh patches. The measured .ipk sizes on an x86_64 build are: 94588 dropbear_2015.71-3_x86_64.ipk 95316 dropbear_2016.73-1_x86_64.ipk This is an increase of roughly 700 bytes after compression. Tested-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
fad8bdfa40
commit
1c61b21489
6 changed files with 18 additions and 28 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dropbear
|
PKG_NAME:=dropbear
|
||||||
PKG_VERSION:=2015.71
|
PKG_VERSION:=2016.73
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
http://matt.ucc.asn.au/dropbear/releases/ \
|
http://matt.ucc.asn.au/dropbear/releases/ \
|
||||||
https://dropbear.nl/mirror/releases/
|
https://dropbear.nl/mirror/releases/
|
||||||
PKG_MD5SUM:=2ccc0a2f3e37ca221db12c5af6a88137
|
PKG_MD5SUM:=8d6d78ce60ca52350ec04fcbd711ce9b
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
|
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
|
||||||
|
|
|
@ -61,7 +61,7 @@
|
||||||
/* ECDSA is significantly faster than RSA or DSS. Compiling in ECC
|
/* ECDSA is significantly faster than RSA or DSS. Compiling in ECC
|
||||||
* code (either ECDSA or ECDH) increases binary size - around 30kB
|
* code (either ECDSA or ECDH) increases binary size - around 30kB
|
||||||
* on x86-64 */
|
* on x86-64 */
|
||||||
@@ -189,7 +189,7 @@ If you test it please contact the Dropbe
|
@@ -194,7 +194,7 @@ If you test it please contact the Dropbe
|
||||||
|
|
||||||
/* Whether to print the message of the day (MOTD). This doesn't add much code
|
/* Whether to print the message of the day (MOTD). This doesn't add much code
|
||||||
* size */
|
* size */
|
||||||
|
@ -70,7 +70,7 @@
|
||||||
|
|
||||||
/* The MOTD file path */
|
/* The MOTD file path */
|
||||||
#ifndef MOTD_FILENAME
|
#ifndef MOTD_FILENAME
|
||||||
@@ -237,7 +237,7 @@ Homedir is prepended unless path begins
|
@@ -242,7 +242,7 @@ Homedir is prepended unless path begins
|
||||||
* note that it will be provided for all "hidden" client-interactive
|
* note that it will be provided for all "hidden" client-interactive
|
||||||
* style prompts - if you want something more sophisticated, use
|
* style prompts - if you want something more sophisticated, use
|
||||||
* SSH_ASKPASS instead. Comment out this var to remove this functionality.*/
|
* SSH_ASKPASS instead. Comment out this var to remove this functionality.*/
|
||||||
|
|
|
@ -1,21 +0,0 @@
|
||||||
--- a/cli-runopts.c
|
|
||||||
+++ b/cli-runopts.c
|
|
||||||
@@ -284,6 +284,10 @@ void cli_getopts(int argc, char ** argv)
|
|
||||||
debug_trace = 1;
|
|
||||||
break;
|
|
||||||
#endif
|
|
||||||
+ case 'o':
|
|
||||||
+ next = &dummy;
|
|
||||||
+ case 'x':
|
|
||||||
+ break;
|
|
||||||
case 'F':
|
|
||||||
case 'e':
|
|
||||||
#ifndef ENABLE_USER_ALGO_LIST
|
|
||||||
@@ -301,7 +305,6 @@ void cli_getopts(int argc, char ** argv)
|
|
||||||
print_version();
|
|
||||||
exit(EXIT_SUCCESS);
|
|
||||||
break;
|
|
||||||
- case 'o':
|
|
||||||
case 'b':
|
|
||||||
next = &dummy;
|
|
||||||
default:
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/cli-runopts.c
|
||||||
|
+++ b/cli-runopts.c
|
||||||
|
@@ -296,6 +296,8 @@ void cli_getopts(int argc, char ** argv)
|
||||||
|
debug_trace = 1;
|
||||||
|
break;
|
||||||
|
#endif
|
||||||
|
+ case 'x':
|
||||||
|
+ break;
|
||||||
|
case 'F':
|
||||||
|
case 'e':
|
||||||
|
#ifndef ENABLE_USER_ALGO_LIST
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/dbutil.h
|
--- a/dbutil.h
|
||||||
+++ b/dbutil.h
|
+++ b/dbutil.h
|
||||||
@@ -88,7 +88,11 @@ int m_str_to_uint(const char* str, unsig
|
@@ -78,7 +78,11 @@ int m_str_to_uint(const char* str, unsig
|
||||||
#define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
|
#define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
|
||||||
|
|
||||||
/* Dropbear assertion */
|
/* Dropbear assertion */
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/options.h
|
--- a/options.h
|
||||||
+++ b/options.h
|
+++ b/options.h
|
||||||
@@ -347,7 +347,9 @@ be overridden at runtime with -I. 0 disa
|
@@ -352,7 +352,9 @@ be overridden at runtime with -I. 0 disa
|
||||||
#define DEFAULT_IDLE_TIMEOUT 0
|
#define DEFAULT_IDLE_TIMEOUT 0
|
||||||
|
|
||||||
/* The default path. This will often get replaced by the shell */
|
/* The default path. This will often get replaced by the shell */
|
||||||
|
|
Loading…
Reference in a new issue