uboot-sunxi: Backport fix for stale CONFIG_SUNXIG_GMAC references
This backports the upstream commit fixing stale references to CONFIG_SUNXI_GMAC which have been later replaced by CONFIG_SUN7I_GMAC. This fixes the designware MAC pinmuxing on e.g: Lamobo R1. Refresh patches while we are at it. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
This commit is contained in:
parent
7f0a32e21c
commit
1a53315951
5 changed files with 84 additions and 28 deletions
|
@ -10,8 +10,6 @@ This reverts commit e38ffc42674fedc750ca895046be0bd983b56dd5.
|
|||
scripts/Makefile.spl | 17 ++++-------------
|
||||
2 files changed, 6 insertions(+), 28 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 119ad49eec..071efa8926 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1116,7 +1116,7 @@ cmd_ldr = $(LD) $(LDFLAGS_$(@F)) \
|
||||
|
@ -33,7 +31,7 @@ index 119ad49eec..071efa8926 100644
|
|||
$(call if_changed,binman)
|
||||
endif
|
||||
|
||||
@@ -1355,18 +1354,6 @@ $(version_h): include/config/uboot.release FORCE
|
||||
@@ -1355,18 +1354,6 @@ $(version_h): include/config/uboot.relea
|
||||
$(timestamp_h): $(srctree)/Makefile FORCE
|
||||
$(call filechk,timestamp.h)
|
||||
|
||||
|
@ -52,8 +50,6 @@ index 119ad49eec..071efa8926 100644
|
|||
# ---------------------------------------------------------------------------
|
||||
quiet_cmd_cpp_lds = LDS $@
|
||||
cmd_cpp_lds = $(CPP) -Wp,-MD,$(depfile) $(cpp_flags) $(LDPPFLAGS) \
|
||||
diff --git a/scripts/Makefile.spl b/scripts/Makefile.spl
|
||||
index ac3c2c7f13..135706f21d 100644
|
||||
--- a/scripts/Makefile.spl
|
||||
+++ b/scripts/Makefile.spl
|
||||
@@ -257,12 +257,14 @@ PHONY += dts_dir
|
||||
|
@ -91,6 +87,3 @@ index ac3c2c7f13..135706f21d 100644
|
|||
PHONY += FORCE
|
||||
FORCE:
|
||||
|
||||
--
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -9,8 +9,6 @@ This reverts commit 7452946e7f3742b3ff1cb4a50603e7492aceea88.
|
|||
scripts/Makefile.lib | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
||||
index 80ddb08474..66f8dcbe07 100644
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -306,10 +306,10 @@ $(obj)/%.dtb.S: $(obj)/%.dtb
|
||||
|
@ -26,6 +24,3 @@ index 80ddb08474..66f8dcbe07 100644
|
|||
$(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) - ; \
|
||||
$(DTC) -O dtb -o $@ -b 0 \
|
||||
-i $(dir $<) $(DTC_FLAGS) \
|
||||
--
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -8,8 +8,6 @@ This reverts commit 208db781cad4c24f538658a9cb17e24fa43ca3c9.
|
|||
scripts/Makefile.lib | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
||||
index 66f8dcbe07..54bcb166b0 100644
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -309,7 +309,7 @@ quiet_cmd_dtc = DTC $@
|
||||
|
@ -21,6 +19,3 @@ index 66f8dcbe07..54bcb166b0 100644
|
|||
$(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) - ; \
|
||||
$(DTC) -O dtb -o $@ -b 0 \
|
||||
-i $(dir $<) $(DTC_FLAGS) \
|
||||
--
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -11,8 +11,6 @@ This reverts commit 61b994a386eb6f631dc1c2194d4cce9b1a43542c.
|
|||
3 files changed, 6 insertions(+), 18 deletions(-)
|
||||
delete mode 100644 arch/arm/dts/sunxi-u-boot.dtsi
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 071efa8926..5349621baf 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1125,8 +1125,10 @@ u-boot-x86-16bit.bin: u-boot FORCE
|
||||
|
@ -28,9 +26,6 @@ index 071efa8926..5349621baf 100644
|
|||
endif
|
||||
|
||||
ifneq ($(CONFIG_TEGRA),)
|
||||
diff --git a/arch/arm/dts/sunxi-u-boot.dtsi b/arch/arm/dts/sunxi-u-boot.dtsi
|
||||
deleted file mode 100644
|
||||
index 5adfd9bca2..0000000000
|
||||
--- a/arch/arm/dts/sunxi-u-boot.dtsi
|
||||
+++ /dev/null
|
||||
@@ -1,14 +0,0 @@
|
||||
|
@ -48,8 +43,6 @@ index 5adfd9bca2..0000000000
|
|||
- };
|
||||
- };
|
||||
-};
|
||||
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
||||
index 54bcb166b0..6246265c91 100644
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -308,8 +308,8 @@ quiet_cmd_dtc = DTC $@
|
||||
|
@ -63,6 +56,3 @@ index 54bcb166b0..6246265c91 100644
|
|||
$(CPP) $(dtc_cpp_flags) -x assembler-with-cpp -o $(dtc-tmp) - ; \
|
||||
$(DTC) -O dtb -o $@ -b 0 \
|
||||
-i $(dir $<) $(DTC_FLAGS) \
|
||||
--
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -0,0 +1,83 @@
|
|||
From 6ff005cf19363382fc867d7876a75fd8a386e894 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Prue <dave@prue.com>
|
||||
Date: Thu, 31 Aug 2017 19:21:01 +0200
|
||||
Subject: [PATCH] sunxi: Fix CONFIG_SUNXI_GMAC references
|
||||
|
||||
SUNXI_GMAC was still used to configure the code where as the
|
||||
same has been renamed and moved to Kconfig in below commit
|
||||
"sunxi: Move SUNXI_GMAC to Kconfig"
|
||||
(sha1: 4d43d065db3262f9a9918ba72457bf36dfb8e0bb)
|
||||
|
||||
Signed-off-by: Dave Prue <dave@prue.com>
|
||||
Reviewed-by: Simon Glass <sjg@chromium.org>
|
||||
Reviewed-by: Jagan Teki <jagan@openedev.com>
|
||||
Reviewed-by: Mark Kettenis <kettenis@openbsd.org>
|
||||
Tested-by: Mark Kettenis <kettenis@openbsd.org>
|
||||
[Tweek commit message, config_whitelist.txt, build-whitelist.sh]
|
||||
Signed-off-by: Jagan Teki <jagan@openedev.com>
|
||||
---
|
||||
arch/arm/include/asm/arch-sunxi/sys_proto.h | 2 +-
|
||||
board/sunxi/Makefile | 2 +-
|
||||
include/configs/sunxi-common.h | 2 +-
|
||||
scripts/build-whitelist.sh | 4 ++--
|
||||
scripts/config_whitelist.txt | 1 -
|
||||
5 files changed, 5 insertions(+), 6 deletions(-)
|
||||
|
||||
--- a/arch/arm/include/asm/arch-sunxi/sys_proto.h
|
||||
+++ b/arch/arm/include/asm/arch-sunxi/sys_proto.h
|
||||
@@ -24,7 +24,7 @@ void sdelay(unsigned long);
|
||||
void return_to_fel(uint32_t lr, uint32_t sp);
|
||||
|
||||
/* Board / SoC level designware gmac init */
|
||||
-#if !defined CONFIG_SPL_BUILD && defined CONFIG_SUNXI_GMAC
|
||||
+#if !defined CONFIG_SPL_BUILD && defined CONFIG_SUN7I_GMAC
|
||||
void eth_init_board(void);
|
||||
#else
|
||||
static inline void eth_init_board(void) {}
|
||||
--- a/board/sunxi/Makefile
|
||||
+++ b/board/sunxi/Makefile
|
||||
@@ -9,7 +9,7 @@
|
||||
# SPDX-License-Identifier: GPL-2.0+
|
||||
#
|
||||
obj-y += board.o
|
||||
-obj-$(CONFIG_SUNXI_GMAC) += gmac.o
|
||||
+obj-$(CONFIG_SUN7I_GMAC) += gmac.o
|
||||
obj-$(CONFIG_SUNXI_AHCI) += ahci.o
|
||||
obj-$(CONFIG_MACH_SUN4I) += dram_sun4i_auto.o
|
||||
obj-$(CONFIG_MACH_SUN5I) += dram_sun5i_auto.o
|
||||
--- a/include/configs/sunxi-common.h
|
||||
+++ b/include/configs/sunxi-common.h
|
||||
@@ -302,7 +302,7 @@ extern int soft_i2c_gpio_scl;
|
||||
#define CONFIG_PHYLIB
|
||||
#endif
|
||||
|
||||
-#ifdef CONFIG_SUNXI_GMAC
|
||||
+#ifdef CONFIG_SUN7I_GMAC
|
||||
#define CONFIG_PHY_GIGE /* GMAC can use gigabit PHY */
|
||||
#define CONFIG_PHY_ADDR 1
|
||||
#define CONFIG_MII /* MII PHY management */
|
||||
--- a/scripts/build-whitelist.sh
|
||||
+++ b/scripts/build-whitelist.sh
|
||||
@@ -13,10 +13,10 @@ export LC_ALL=C LC_COLLATE=C
|
||||
# There are two independent greps. The first pulls out the component parts
|
||||
# of CONFIG_SYS_EXTRA_OPTIONS. An example is:
|
||||
#
|
||||
-# SUNXI_GMAC,AHCI,SATAPWR=SUNXI_GPB(8)
|
||||
+# SUN7I_GMAC,AHCI,SATAPWR=SUNXI_GPB(8)
|
||||
#
|
||||
# We want this to produce:
|
||||
-# CONFIG_SUNXI_GMAC
|
||||
+# CONFIG_SUN7I_GMAC
|
||||
# CONFIG_AHCI
|
||||
# CONFIG_SATAPWR
|
||||
#
|
||||
--- a/scripts/config_whitelist.txt
|
||||
+++ b/scripts/config_whitelist.txt
|
||||
@@ -2371,7 +2371,6 @@ CONFIG_STV0991_HZ_CLOCK
|
||||
CONFIG_ST_SMI
|
||||
CONFIG_SUNXI_AHCI
|
||||
CONFIG_SUNXI_EMAC
|
||||
-CONFIG_SUNXI_GMAC
|
||||
CONFIG_SUNXI_GPIO
|
||||
CONFIG_SUNXI_MAX_FB_SIZE
|
||||
CONFIG_SUNXI_USB_PHYS
|
Loading…
Reference in a new issue