iptables: - supress detection of libnfnetlink and force configure to not use it - fix staging install of libxtables, libiptc and libipq libraries
SVN-Revision: 21799
This commit is contained in:
parent
50bf15dd26
commit
1a4e4a3850
2 changed files with 97 additions and 3 deletions
|
@ -297,9 +297,9 @@ define Build/InstallDev
|
|||
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.a $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipq.so* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libiptc.pc $(1)/usr/lib/pkgconfig/
|
||||
|
|
94
package/iptables/patches/030-no-libnfnetlink.patch
Normal file
94
package/iptables/patches/030-no-libnfnetlink.patch
Normal file
|
@ -0,0 +1,94 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -10853,77 +10853,7 @@ $as_echo "no" >&6; }
|
||||
|
||||
fi
|
||||
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
|
||||
-$as_echo_n "checking for libnfnetlink... " >&6; }
|
||||
-
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$libnfnetlink_CFLAGS"; then
|
||||
- pkg_cv_libnfnetlink_CFLAGS="$libnfnetlink_CFLAGS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_libnfnetlink_CFLAGS=`$PKG_CONFIG --cflags "libnfnetlink >= 1.0" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$libnfnetlink_LIBS"; then
|
||||
- pkg_cv_libnfnetlink_LIBS="$libnfnetlink_LIBS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_libnfnetlink_LIBS=`$PKG_CONFIG --libs "libnfnetlink >= 1.0" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libnfnetlink >= 1.0"`
|
||||
- else
|
||||
- libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libnfnetlink >= 1.0"`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$libnfnetlink_PKG_ERRORS" >&5
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- nfnetlink=0
|
||||
-elif test $pkg_failed = untried; then
|
||||
- nfnetlink=0
|
||||
-else
|
||||
- libnfnetlink_CFLAGS=$pkg_cv_libnfnetlink_CFLAGS
|
||||
- libnfnetlink_LIBS=$pkg_cv_libnfnetlink_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- nfnetlink=1
|
||||
-fi
|
||||
- if test "$nfnetlink" = 1; then
|
||||
+if false; then
|
||||
HAVE_LIBNFNETLINK_TRUE=
|
||||
HAVE_LIBNFNETLINK_FALSE='#'
|
||||
else
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -68,9 +68,7 @@ AM_CONDITIONAL([ENABLE_LARGEFILE], [test
|
||||
AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
|
||||
AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
|
||||
|
||||
-PKG_CHECK_MODULES([libnfnetlink], [libnfnetlink >= 1.0],
|
||||
- [nfnetlink=1], [nfnetlink=0])
|
||||
-AM_CONDITIONAL([HAVE_LIBNFNETLINK], [test "$nfnetlink" = 1])
|
||||
+AM_CONDITIONAL([HAVE_LIBNFNETLINK], [false])
|
||||
|
||||
regular_CFLAGS="${largefile_cflags} \
|
||||
-D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \
|
Loading…
Reference in a new issue