kernel: update linux 3.7 to 3.7.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35604
This commit is contained in:
parent
f35c369710
commit
162b8e23a5
19 changed files with 23 additions and 23 deletions
|
@ -8,8 +8,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.6.11)
|
||||
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.7.7)
|
||||
LINUX_KERNEL_MD5SUM:=bd37c2e05cb82331eb00da81773b2d85
|
||||
ifeq ($(LINUX_VERSION),3.7.8)
|
||||
LINUX_KERNEL_MD5SUM:=4bc40d18bf90f25d5463cfb9442876af
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
BOARD:=adm5120
|
||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
SUBTARGETS:=router_le router_be rb1xx
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -191,7 +191,7 @@
|
|||
/*
|
||||
--- a/net/ipv4/tcp_input.c
|
||||
+++ b/net/ipv4/tcp_input.c
|
||||
@@ -3842,13 +3842,14 @@ static bool tcp_parse_aligned_timestamp(
|
||||
@@ -3847,13 +3847,14 @@ static bool tcp_parse_aligned_timestamp(
|
||||
{
|
||||
const __be32 *ptr = (const __be32 *)(th + 1);
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
if (!net_eq(dev_net(dev), sock_net(sk)))
|
||||
goto drop;
|
||||
|
||||
@@ -2511,6 +2513,7 @@ static int packet_create(struct net *net
|
||||
@@ -2513,6 +2515,7 @@ static int packet_create(struct net *net
|
||||
spin_lock_init(&po->bind_lock);
|
||||
mutex_init(&po->pg_vec_lock);
|
||||
po->prot_hook.func = packet_rcv;
|
||||
|
@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
|
||||
if (sock->type == SOCK_PACKET)
|
||||
po->prot_hook.func = packet_rcv_spkt;
|
||||
@@ -3111,6 +3114,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
@@ -3113,6 +3116,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
|
||||
return fanout_add(sk, val & 0xffff, val >> 16);
|
||||
}
|
||||
|
@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
default:
|
||||
return -ENOPROTOOPT;
|
||||
}
|
||||
@@ -3165,6 +3178,13 @@ static int packet_getsockopt(struct sock
|
||||
@@ -3167,6 +3180,13 @@ static int packet_getsockopt(struct sock
|
||||
case PACKET_VNET_HDR:
|
||||
val = po->has_vnet_hdr;
|
||||
break;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/linux/netdevice.h
|
||||
+++ b/include/linux/netdevice.h
|
||||
@@ -134,7 +134,7 @@ static inline bool dev_xmit_complete(int
|
||||
@@ -137,7 +137,7 @@ static inline bool dev_xmit_complete(int
|
||||
*/
|
||||
|
||||
#if defined(CONFIG_WLAN) || IS_ENABLED(CONFIG_AX25)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/linux/netdevice.h
|
||||
+++ b/include/linux/netdevice.h
|
||||
@@ -1074,6 +1074,11 @@ struct net_device {
|
||||
@@ -1077,6 +1077,11 @@ struct net_device {
|
||||
const struct net_device_ops *netdev_ops;
|
||||
const struct ethtool_ops *ethtool_ops;
|
||||
|
||||
|
@ -12,7 +12,7 @@
|
|||
/* Hardware header description */
|
||||
const struct header_ops *header_ops;
|
||||
|
||||
@@ -1130,6 +1135,9 @@ struct net_device {
|
||||
@@ -1133,6 +1138,9 @@ struct net_device {
|
||||
void *ax25_ptr; /* AX.25 specific data */
|
||||
struct wireless_dev *ieee80211_ptr; /* IEEE 802.11 specific data,
|
||||
assign before registering */
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
|
|||
FEATURES:=squashfs jffs2
|
||||
SUBTARGETS=xway ase falcon
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
|||
FEATURES:=squashfs targz
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
|
|||
FEATURES:=spe_fpu ramdisk
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
|||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci targz broken
|
||||
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
|
|||
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
|
||||
kmod-ledtrig-netdev \
|
||||
kmod-cpu-msr hwclock wpad
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
CS5535_MASK:=0x0b000042
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
|
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
|||
kmod-cpu-msr \
|
||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||
hwclock wpad flashrom tc
|
||||
LINUX_VERSION:=3.7.7
|
||||
LINUX_VERSION:=3.7.8
|
||||
CS5535_MASK:=0x0E000048
|
||||
|
||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||
|
|
Loading…
Reference in a new issue