kernel: update linux 3.8 to 3.8.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36363
This commit is contained in:
parent
cf46e78b5f
commit
151cadfe32
25 changed files with 26 additions and 26 deletions
|
@ -11,8 +11,8 @@ endif
|
||||||
ifeq ($(LINUX_VERSION),3.7.10)
|
ifeq ($(LINUX_VERSION),3.7.10)
|
||||||
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
|
LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.8.7)
|
ifeq ($(LINUX_VERSION),3.8.8)
|
||||||
LINUX_KERNEL_MD5SUM:=37ce9b5cc33551b45fea59c1c4c9da13
|
LINUX_KERNEL_MD5SUM:=3b4feff68460881a5dde1307fe1ce87f
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
BOARD:=adm5120
|
BOARD:=adm5120
|
||||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
SUBTARGETS:=router_le router_be rb1xx
|
SUBTARGETS:=router_le router_be rb1xx
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
SUBTARGETS:=generic nand
|
SUBTARGETS:=generic nand
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
||||||
BOARDNAME:=Atheros AR231x/AR5312
|
BOARDNAME:=Atheros AR231x/AR5312
|
||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
|
||||||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
|
||||||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
|
|
@ -62,7 +62,7 @@
|
||||||
|
|
||||||
--- a/mm/memory.c
|
--- a/mm/memory.c
|
||||||
+++ b/mm/memory.c
|
+++ b/mm/memory.c
|
||||||
@@ -1408,6 +1408,7 @@ void zap_page_range(struct vm_area_struc
|
@@ -1409,6 +1409,7 @@ void zap_page_range(struct vm_area_struc
|
||||||
mmu_notifier_invalidate_range_end(mm, start, end);
|
mmu_notifier_invalidate_range_end(mm, start, end);
|
||||||
tlb_finish_mmu(&tlb, start, end);
|
tlb_finish_mmu(&tlb, start, end);
|
||||||
}
|
}
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
|
||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
SUBTARGETS=xway ase falcon
|
SUBTARGETS=xway ase falcon
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
||||||
FEATURES:=targz ext4
|
FEATURES:=targz ext4
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
||||||
FEATURES:=squashfs targz
|
FEATURES:=squashfs targz
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
|
||||||
FEATURES:=spe_fpu squashfs
|
FEATURES:=spe_fpu squashfs
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
|
||||||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
|
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
|
||||||
FEATURES:=squashfs gpio
|
FEATURES:=squashfs gpio
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=\
|
DEFAULT_PACKAGES+=\
|
||||||
|
|
|
@ -91,7 +91,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
||||||
|
|
||||||
/* Private data structure for of_gpiochip_find_and_xlate */
|
/* Private data structure for of_gpiochip_find_and_xlate */
|
||||||
struct gg_data {
|
struct gg_data {
|
||||||
@@ -289,3 +291,62 @@ void of_gpiochip_remove(struct gpio_chip
|
@@ -288,3 +290,62 @@ void of_gpiochip_remove(struct gpio_chip
|
||||||
if (chip->of_node)
|
if (chip->of_node)
|
||||||
of_node_put(chip->of_node);
|
of_node_put(chip->of_node);
|
||||||
}
|
}
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
||||||
BOARDNAME:=Mikrotik RouterBoard 532
|
BOARDNAME:=Mikrotik RouterBoard 532
|
||||||
FEATURES:=jffs2 pci targz broken
|
FEATURES:=jffs2 pci targz broken
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
|
||||||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
||||||
FEATURES:=ext4 audio
|
FEATURES:=ext4 audio
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
|
||||||
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
|
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
|
||||||
kmod-ledtrig-netdev \
|
kmod-ledtrig-netdev \
|
||||||
kmod-cpu-msr hwclock wpad
|
kmod-cpu-msr hwclock wpad
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
CS5535_MASK:=0x0b000042
|
CS5535_MASK:=0x0b000042
|
||||||
|
|
||||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
BOARDNAME:=Generic
|
BOARDNAME:=Generic
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
define Target/Description
|
define Target/Description
|
||||||
Build firmware images for x86 based boards
|
Build firmware images for x86 based boards
|
||||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
||||||
FEATURES:=jffs2 targz ubifs audio broken
|
FEATURES:=jffs2 targz ubifs audio broken
|
||||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||||
|
|
||||||
LINUX_VERSION:=3.8.7
|
LINUX_VERSION:=3.8.8
|
||||||
|
|
||||||
DEVICE_TYPE=other
|
DEVICE_TYPE=other
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue