uboot-sunxi: bump to 2014.04
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 42422
This commit is contained in:
parent
4ea085316e
commit
14cf28b284
4 changed files with 3517 additions and 4435 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=u-boot
|
||||
PKG_VERSION:=2014.01-rc1
|
||||
PKG_VERSION:=2014.04
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:= \
|
||||
http://mirror2.openwrt.org/sources \
|
||||
ftp://ftp.denx.de/pub/u-boot
|
||||
PKG_SOURCE_VERSION:=1552fe43c3e827d56c9cd212fba3dcba
|
||||
PKG_SOURCE_VERSION:=6d2116d1385a66e9a59742caa9d62a54
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -25,46 +25,46 @@ define uboot/Default
|
|||
endef
|
||||
|
||||
define uboot/A10-OLinuXino-Lime
|
||||
TITLE:=U-Boot 2014.01-rc1 for the A10 OLinuXino LIME
|
||||
TITLE:=U-Boot 2014.04 for the A10 OLinuXino LIME
|
||||
endef
|
||||
|
||||
define uboot/A13-OLinuXino
|
||||
TITLE:=U-Boot 2014.01-rc1 for the A13 OlinuXino
|
||||
TITLE:=U-Boot 2014.04 for the A13 OlinuXino
|
||||
endef
|
||||
|
||||
define uboot/A20-OLinuXino_MICRO
|
||||
TITLE:=U-Boot 2014.01-rc1 for A20 OLinuXino MICRO
|
||||
TITLE:=U-Boot 2014.04 for A20 OLinuXino MICRO
|
||||
endef
|
||||
|
||||
define uboot/bananapi
|
||||
TITLE:=U-Boot 2014.01-rc1 for BananaPi
|
||||
define uboot/Bananapi
|
||||
TITLE:=U-Boot 2014.04 for Bananapi
|
||||
endef
|
||||
|
||||
define uboot/Cubieboard
|
||||
TITLE:=U-Boot 2014.01-rc1 for Cubieboard
|
||||
TITLE:=U-Boot 2014.04 for Cubieboard
|
||||
endef
|
||||
|
||||
define uboot/Cubieboard2
|
||||
TITLE:=U-Boot 2014.01-rc1 for Cubieboard2
|
||||
TITLE:=U-Boot 2014.04 for Cubieboard2
|
||||
endef
|
||||
|
||||
define uboot/Cubietruck
|
||||
TITLE:=U-Boot 2014.01-rc1 for Cubietruck
|
||||
TITLE:=U-Boot 2014.04 for Cubietruck
|
||||
endef
|
||||
|
||||
define uboot/Hackberry
|
||||
TITLE:=U-Boot 2014.01-rc1 for the Hackbeery
|
||||
TITLE:=U-Boot 2014.04 for the Hackbeery
|
||||
endef
|
||||
|
||||
define uboot/pcDuino
|
||||
TITLE:=U-Boot 2014.01-rc1 for pcDuino
|
||||
TITLE:=U-Boot 2014.04 for pcDuino
|
||||
endef
|
||||
|
||||
define uboot/pcDuino3
|
||||
TITLE:=U-Boot 2014.01-rc1 for pcDuino3
|
||||
define uboot/Linksprite_pcDuino3
|
||||
TITLE:=U-Boot 2014.04 for Linksprite pcDuino3
|
||||
endef
|
||||
|
||||
UBOOTS:=A10-OLinuXino-Lime A13-OLinuXino A20-OLinuXino_MICRO bananapi Cubieboard Cubieboard2 Cubietruck Hackberry pcDuino pcDuino3
|
||||
UBOOTS:=A10-OLinuXino-Lime A13-OLinuXino A20-OLinuXino_MICRO Bananapi Cubieboard Cubieboard2 Cubietruck Hackberry pcDuino Linksprite_pcDuino3
|
||||
|
||||
define Package/uboot/template
|
||||
define Package/uboot-sunxi-$(1)
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,57 +0,0 @@
|
|||
diff -ruN u-boot-2014.01-rc1.old/board/sunxi/dram_pcduino3.c u-boot-2014.01-rc1/board/sunxi/dram_pcduino3.c
|
||||
--- u-boot-2014.01-rc1.old/board/sunxi/dram_pcduino3.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ u-boot-2014.01-rc1/board/sunxi/dram_pcduino3.c 2014-04-23 20:04:00.919994615 +0200
|
||||
@@ -0,0 +1,31 @@
|
||||
+/* this file is generated, don't edit it yourself */
|
||||
+
|
||||
+#include <common.h>
|
||||
+#include <asm/arch/dram.h>
|
||||
+
|
||||
+static struct dram_para dram_para = {
|
||||
+ .clock = 480,
|
||||
+ .type = 3,
|
||||
+ .rank_num = 1,
|
||||
+ .density = 4096,
|
||||
+ .io_width = 16,
|
||||
+ .bus_width = 32,
|
||||
+ .cas = 9,
|
||||
+ .zq = 0x7a,
|
||||
+ .odt_en = 0,
|
||||
+ .size = 1024,
|
||||
+ .tpr0 = 0x42d899b7,
|
||||
+ .tpr1 = 0xa090,
|
||||
+ .tpr2 = 0x22a00,
|
||||
+ .tpr3 = 0,
|
||||
+ .tpr4 = 0,
|
||||
+ .tpr5 = 0,
|
||||
+ .emr1 = 0x4,
|
||||
+ .emr2 = 0x10,
|
||||
+ .emr3 = 0x0,
|
||||
+};
|
||||
+
|
||||
+unsigned long sunxi_dram_init(void)
|
||||
+{
|
||||
+ return dramc_init(&dram_para);
|
||||
+}
|
||||
diff -ruN u-boot-2014.01-rc1.old/board/sunxi/Makefile u-boot-2014.01-rc1/board/sunxi/Makefile
|
||||
--- u-boot-2014.01-rc1.old/board/sunxi/Makefile 2014-04-12 18:51:34.000000000 +0200
|
||||
+++ u-boot-2014.01-rc1/board/sunxi/Makefile 2014-04-23 20:02:51.828839920 +0200
|
||||
@@ -73,6 +73,7 @@
|
||||
obj-$(CONFIG_MK802II) += dram_sun4i_408_1024_iow8.o
|
||||
obj-$(CONFIG_MK802II_A20) += dram_mk802ii_a20.o
|
||||
obj-$(CONFIG_PCDUINO) += dram_sun4i_408_1024_iow8.o
|
||||
+obj-$(CONFIG_PCDUINO3) += dram_pcduino3.o
|
||||
obj-$(CONFIG_PENGPOD700) += dram_sun4i_384_1024_iow8.o
|
||||
obj-$(CONFIG_PENGPOD1000) += dram_sun4i_408_1024_iow16.o
|
||||
obj-$(CONFIG_POV_PROTAB2) += dram_pov_protab2.o
|
||||
diff -ruN u-boot-2014.01-rc1.old/boards.cfg u-boot-2014.01-rc1/boards.cfg
|
||||
--- u-boot-2014.01-rc1.old/boards.cfg 2014-04-12 18:51:34.000000000 +0200
|
||||
+++ u-boot-2014.01-rc1/boards.cfg 2014-04-23 20:02:27.897132713 +0200
|
||||
@@ -404,6 +404,7 @@
|
||||
Active arm armv7 sunxi - sunxi mk802ii_A20 sun7i:MK802II_A20,SPL -
|
||||
Active arm armv7 sunxi - sunxi mk802ii sun4i:MK802II,SPL -
|
||||
Active arm armv7 sunxi - sunxi pcDuino sun4i:PCDUINO,SPL,SUNXI_EMAC -
|
||||
+Active arm armv7 sunxi - sunxi pcDuino3 sun7i:PCDUINO3,SPL,SUNXI_EMAC,FAST_MBUS -
|
||||
Active arm armv7 sunxi - sunxi pengpod1000 sun4i:PENGPOD1000,SPL -
|
||||
Active arm armv7 sunxi - sunxi pengpod700 sun4i:PENGPOD700,SPL -
|
||||
Active arm armv7 sunxi - sunxi PoV_ProTab2_IPS9 sun4i:POV_PROTAB2,SPL -
|
|
@ -1,91 +0,0 @@
|
|||
From 600e61eed037eb27df6301db9e7dab0a86cc1012 Mon Sep 17 00:00:00 2001
|
||||
From: Bo Shen <voice.shen@gmail.com>
|
||||
Date: Sat, 12 Apr 2014 07:42:11 +0800
|
||||
Subject: [PATCH] bananapi: add bananapi board support
|
||||
|
||||
BananaPi is A20 based board. More information:
|
||||
www.banana-pi.org
|
||||
|
||||
The bananapi.h is original from sun7i.h + sunxi-common.h
|
||||
The dram_bananapi.c is original from dram_cubieboard2.c
|
||||
|
||||
Signed-off-by: Bo Shen <voice.shen@gmail.com>
|
||||
---
|
||||
arch/arm/cpu/armv7/sunxi/board.c | 3 +
|
||||
board/sunxi/Makefile | 1 +
|
||||
board/sunxi/dram_bananapi.c | 31 +++
|
||||
boards.cfg | 1 +
|
||||
include/configs/bananapi.h | 432 +++++++++++++++++++++++++++++++++++++++
|
||||
5 files changed, 468 insertions(+)
|
||||
create mode 100644 board/sunxi/dram_bananapi.c
|
||||
create mode 100644 include/configs/bananapi.h
|
||||
|
||||
diff --git a/arch/arm/cpu/armv7/sunxi/board.c b/arch/arm/cpu/armv7/sunxi/board.c
|
||||
index 9b3d5a2..2df7704 100644
|
||||
diff --git a/board/sunxi/Makefile b/board/sunxi/Makefile
|
||||
index bed033b..bbe73f6 100644
|
||||
--- a/board/sunxi/Makefile
|
||||
+++ b/board/sunxi/Makefile
|
||||
@@ -20,6 +20,7 @@ obj-$(CONFIG_AUXTEK_T003) += dram_auxtek_t003.o
|
||||
# This is not a typo, uses the same mem settings as the a10s-olinuxino-m
|
||||
obj-$(CONFIG_AUXTEK_T004) += dram_a10s_olinuxino_m.o
|
||||
obj-$(CONFIG_BA10_TV_BOX) += dram_sun4i_384_1024_iow8.o
|
||||
+obj-$(CONFIG_BANANAPI) += dram_bananapi.o
|
||||
obj-$(CONFIG_COBY_MID7042) += dram_sun4i_408_1024_iow16.o
|
||||
obj-$(CONFIG_COBY_MID8042) += dram_sun4i_360_1024_iow16.o
|
||||
obj-$(CONFIG_COBY_MID9742) += dram_sun4i_408_1024_iow16.o
|
||||
diff --git a/board/sunxi/dram_bananapi.c b/board/sunxi/dram_bananapi.c
|
||||
new file mode 100644
|
||||
index 0000000..9e75367
|
||||
--- /dev/null
|
||||
+++ b/board/sunxi/dram_bananapi.c
|
||||
@@ -0,0 +1,31 @@
|
||||
+/* this file is generated, don't edit it yourself */
|
||||
+
|
||||
+#include <common.h>
|
||||
+#include <asm/arch/dram.h>
|
||||
+
|
||||
+static struct dram_para dram_para = {
|
||||
+ .clock = 480,
|
||||
+ .type = 3,
|
||||
+ .rank_num = 1,
|
||||
+ .density = 4096,
|
||||
+ .io_width = 16,
|
||||
+ .bus_width = 32,
|
||||
+ .cas = 9,
|
||||
+ .zq = 0x7f,
|
||||
+ .odt_en = 0,
|
||||
+ .size = 1024,
|
||||
+ .tpr0 = 0x42d899b7,
|
||||
+ .tpr1 = 0xa090,
|
||||
+ .tpr2 = 0x22a00,
|
||||
+ .tpr3 = 0x0,
|
||||
+ .tpr4 = 0x1,
|
||||
+ .tpr5 = 0x0,
|
||||
+ .emr1 = 0x4,
|
||||
+ .emr2 = 0x10,
|
||||
+ .emr3 = 0x0,
|
||||
+};
|
||||
+
|
||||
+unsigned long sunxi_dram_init(void)
|
||||
+{
|
||||
+ return dramc_init(&dram_para);
|
||||
+}
|
||||
diff --git a/boards.cfg b/boards.cfg
|
||||
index f1a5d07..5073644 100644
|
||||
--- a/boards.cfg
|
||||
+++ b/boards.cfg
|
||||
@@ -381,6 +381,7 @@ Active arm armv7 sunxi - sunxi
|
||||
Active arm armv7 sunxi - sunxi Auxtek-T003 sun5i:AUXTEK_T003,SPL,AXP152_POWER,STATUSLED=34 -
|
||||
Active arm armv7 sunxi - sunxi Auxtek-T004 sun5i:AUXTEK_T004,SPL,AXP152_POWER,STATUSLED=34 -
|
||||
Active arm armv7 sunxi - sunxi ba10_tv_box sun4i:BA10_TV_BOX,SPL,SUNXI_EMAC -
|
||||
+Active arm armv7 sunxi - sunxi bananapi sun7i:BANANAPI,SPL,SUNXI_GMAC,STATUSLED=248 -
|
||||
Active arm armv7 sunxi - sunxi Coby_MID7042 sun4i:COBY_MID7042,SPL -
|
||||
Active arm armv7 sunxi - sunxi Coby_MID8042 sun4i:COBY_MID8042,SPL -
|
||||
Active arm armv7 sunxi - sunxi Coby_MID9742 sun4i:COBY_MID9742,SPL -
|
||||
diff --git a/include/configs/bananapi.h b/include/configs/bananapi.h
|
||||
new file mode 100644
|
||||
index 0000000..5e70e63
|
||||
--
|
||||
1.9.3
|
||||
|
Loading…
Reference in a new issue