iptables: fix nftables compile issue (FS#711)
Enabling IPTABLES_NFTABLES resulted in an error during build:# *** No rule to make target '../extensions/libext.a', needed by 'xtables-compat-multi'." Comments from Alexander Lochmann and Fedor Konstantinov in FS#711 provided fixes for this build error, allowing iptables to compile. https://bugs.lede-project.org/index.php?do=details&task_id=711. This commit updates the Makefile.am xtables_compat_multi_LDFLAGS and _LDADD, moving linking of extensions to LDFLAGS. Signed-off-by: rektide de la faye <rektide@voodoowarez.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
6e922a0756
commit
0f72690a2d
1 changed files with 20 additions and 0 deletions
|
@ -82,3 +82,23 @@
|
|||
endif
|
||||
xtables_multi_SOURCES += xshared.c
|
||||
xtables_multi_LDADD += ../libxtables/libxtables.la -lm
|
||||
@@ -32,7 +35,8 @@ if ENABLE_NFTABLES
|
||||
BUILT_SOURCES += xtables-config-parser.h
|
||||
xtables_compat_multi_SOURCES = xtables-compat-multi.c iptables-xml.c
|
||||
xtables_compat_multi_CFLAGS = ${AM_CFLAGS}
|
||||
-xtables_compat_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
|
||||
+xtables_compat_multi_LDADD =
|
||||
+xtables_compat_multi_LDFLAGS = -L../extensions/ -liptext -liptext_ebt
|
||||
if ENABLE_STATIC
|
||||
xtables_compat_multi_CFLAGS += -DALL_INCLUSIVE
|
||||
endif
|
||||
@@ -45,7 +49,8 @@ xtables_compat_multi_SOURCES += xtables-
|
||||
getethertype.c nft-bridge.c \
|
||||
xtables-eb-standalone.c xtables-eb.c \
|
||||
xtables-translate.c
|
||||
-xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS} ../extensions/libext4.a ../extensions/libext6.a ../extensions/libext_ebt.a ../extensions/libext_arpt.a
|
||||
+xtables_compat_multi_LDADD += ${libmnl_LIBS} ${libnftnl_LIBS} ${libnetfilter_conntrack_LIBS}
|
||||
+xtables_compat_multi_LDFLAGS += -liptext4 -liptext6 -liptext_arpt
|
||||
# yacc and lex generate dirty code
|
||||
xtables_compat_multi-xtables-config-parser.o xtables_compat_multi-xtables-config-syntax.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
|
||||
xtables_compat_multi_SOURCES += xshared.c
|
||||
|
|
Loading…
Reference in a new issue