bump to 2.6.30.4, apply fix from [15119] to x86_64
SVN-Revision: 17285
This commit is contained in:
parent
149f92b47a
commit
0eeb0d3c2f
5 changed files with 15 additions and 2 deletions
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext2
|
||||
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
|
||||
|
||||
LINUX_VERSION:=2.6.28.10
|
||||
LINUX_VERSION:=2.6.30.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -93,6 +93,7 @@ CONFIG_MPENTIUMII=y
|
|||
# CONFIG_MWINCHIP3D is not set
|
||||
# CONFIG_MWINCHIPC6 is not set
|
||||
CONFIG_NAMESPACES=y
|
||||
# CONFIG_NET_NS is not set
|
||||
CONFIG_NLS=y
|
||||
# CONFIG_NLS_CODEPAGE_850 is not set
|
||||
# CONFIG_NLS_ISO8859_15 is not set
|
||||
|
|
|
@ -13,6 +13,7 @@ CONFIG_BLK_DEV_UBD_SYNC=y
|
|||
CONFIG_CON_CHAN="xterm"
|
||||
CONFIG_CON_ZERO_CHAN="fd:0,fd:1"
|
||||
CONFIG_CRAMFS=y
|
||||
# CONFIG_CRYPTO_AES_NI_INTEL is not set
|
||||
# CONFIG_CRYPTO_AES_X86_64 is not set
|
||||
# CONFIG_CRYPTO_SALSA20_X86_64 is not set
|
||||
# CONFIG_CRYPTO_TWOFISH_X86_64 is not set
|
||||
|
@ -60,6 +61,7 @@ CONFIG_MCORE2=y
|
|||
CONFIG_MK8=y
|
||||
CONFIG_MODE_SKAS=y
|
||||
CONFIG_NEST_LEVEL=0
|
||||
# CONFIG_NET_NS is not set
|
||||
CONFIG_NET_SCH_FIFO=y
|
||||
CONFIG_NLS=y
|
||||
# CONFIG_NLS_CODEPAGE_850 is not set
|
||||
|
|
|
@ -9,3 +9,13 @@
|
|||
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|
||||
+
|
||||
KBUILD_CFLAGS += $(cflags-y)
|
||||
--- a/arch/um/Makefile-x86_64
|
||||
+++ b/arch/um/Makefile-x86_64
|
||||
@@ -24,3 +24,7 @@ LINK-y += -m64
|
||||
|
||||
# Do unit-at-a-time unconditionally on x86_64, following the host
|
||||
KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
|
||||
+
|
||||
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
|
||||
+# and later
|
||||
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|
||||
|
|
|
@ -3,7 +3,7 @@ or as a module
|
|||
|
||||
--- a/lib/Kconfig
|
||||
+++ b/lib/Kconfig
|
||||
@@ -83,7 +83,7 @@ config ZLIB_INFLATE
|
||||
@@ -92,7 +92,7 @@ config ZLIB_INFLATE
|
||||
tristate
|
||||
|
||||
config ZLIB_DEFLATE
|
||||
|
|
Loading…
Reference in a new issue