add support for Comtrend AR5381u.
Router: Comtrend AR5381u. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: fix subject, indentation in patch] Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> SVN-Revision: 33895
This commit is contained in:
parent
d73871fb18
commit
0cc4bed41c
9 changed files with 96 additions and 5 deletions
|
@ -14,6 +14,7 @@ brcm63xx_detect
|
|||
|
||||
case "$board_name" in
|
||||
96328avng |\
|
||||
96328A-1241N |\
|
||||
96328A-1441N1 |\
|
||||
963281TAN |\
|
||||
963281T_TEF |\
|
||||
|
|
|
@ -15,6 +15,7 @@ ucidef_set_interface_loopback
|
|||
case "$board_name" in
|
||||
|
||||
96328avng |\
|
||||
96328A-1241N |\
|
||||
96328A-1441N1 |\
|
||||
963281TAN |\
|
||||
963281T_TEF |\
|
||||
|
|
|
@ -22,6 +22,11 @@ brcm63xx_detect() {
|
|||
status_led="96328avng::power"
|
||||
ifname=eth0
|
||||
;;
|
||||
96328A-1241N)
|
||||
brcm63xx_has_reset_button="true"
|
||||
status_led="96328A-1241N:green:power"
|
||||
ifname=eth0
|
||||
;;
|
||||
96328A-1441N1)
|
||||
brcm63xx_has_reset_button="true"
|
||||
status_led="96328A-1441N1:green:power"
|
||||
|
|
1
target/linux/brcm63xx/image/Makefile
Normal file → Executable file
1
target/linux/brcm63xx/image/Makefile
Normal file → Executable file
|
@ -148,6 +148,7 @@ define Image/Build
|
|||
$(call Image/Build/CFE,$(1),96328avng,6328,96328avng-4M-flash-generic,,--pad 2)
|
||||
$(call Image/Build/CFE,$(1),96328avng,6328,96328avng-8M-flash-generic,,--pad 4)
|
||||
$(call Image/Build/CFE,$(1),96328avng,6328,96328avng-16M-flash-generic,,--pad 8)
|
||||
$(call Image/Build/CFE,$(1),96328A-1241N,6328,96328A-1241N-generic,,--pad 8)
|
||||
$(call Image/Build/CFE,$(1),96328A-1441N1,6328,96328A-1441N1-generic,,--pad 8)
|
||||
$(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-4M-flash-generic,,--pad 2)
|
||||
$(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-8M-flash-generic,,--pad 4)
|
||||
|
|
|
@ -0,0 +1,83 @@
|
|||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
@@ -136,6 +136,72 @@ static struct board_info __initdata boar
|
||||
},
|
||||
};
|
||||
|
||||
+static struct board_info __initdata board_96328A_1241N = {
|
||||
+ .name = "96328A-1241N",
|
||||
+ .expected_cpu_id = 0x6328,
|
||||
+
|
||||
+ .has_uart0 = 1,
|
||||
+ .has_pci = 1,
|
||||
+ .has_ohci0 = 1,
|
||||
+ .has_ehci0 = 1,
|
||||
+ .has_enetsw = 1,
|
||||
+
|
||||
+ .enetsw = {
|
||||
+ .used_ports = {
|
||||
+ [0] = {
|
||||
+ .used = 1,
|
||||
+ .phy_id = 1,
|
||||
+ .name = "Port 1",
|
||||
+ },
|
||||
+ [1] = {
|
||||
+ .used = 1,
|
||||
+ .phy_id = 2,
|
||||
+ .name = "Port 2",
|
||||
+ },
|
||||
+ [2] = {
|
||||
+ .used = 1,
|
||||
+ .phy_id = 3,
|
||||
+ .name = "Port 3",
|
||||
+ },
|
||||
+ [3] = {
|
||||
+ .used = 1,
|
||||
+ .phy_id = 4,
|
||||
+ .name = "Port 4",
|
||||
+ },
|
||||
+ },
|
||||
+ },
|
||||
+
|
||||
+ .leds = {
|
||||
+ {
|
||||
+ .name = "96328A-1241N:green:power",
|
||||
+ .gpio = 8,
|
||||
+ .active_low = 1,
|
||||
+ .default_trigger = "default-on",
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "96328A-1241N:red:alarm",
|
||||
+ .gpio = 2,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ {
|
||||
+ .name = "96328A-1241N:green:inet",
|
||||
+ .gpio = 3,
|
||||
+ .active_low = 1,
|
||||
+ },
|
||||
+ },
|
||||
+
|
||||
+ .buttons = {
|
||||
+ {
|
||||
+ .desc = "reset",
|
||||
+ .gpio = 23,
|
||||
+ .active_low = 1,
|
||||
+ .type = EV_KEY,
|
||||
+ .code = KEY_RESTART,
|
||||
+ .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
|
||||
+ },
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
static struct board_info __initdata board_96328A_1441N1 = {
|
||||
.name = "96328A-1441N1",
|
||||
.expected_cpu_id = 0x6328,
|
||||
@@ -3063,6 +3129,7 @@ static struct board_info __initdata boar
|
||||
static const struct board_info __initdata *bcm963xx_boards[] = {
|
||||
#ifdef CONFIG_BCM63XX_CPU_6328
|
||||
&board_96328avng,
|
||||
+ &board_96328A_1241N,
|
||||
&board_96328A_1441N1,
|
||||
&board_963281TAN,
|
||||
&board_963281T_TEF,
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
@@ -1852,6 +1852,99 @@ static struct board_info __initdata boar
|
||||
@@ -1918,6 +1918,99 @@ static struct board_info __initdata boar
|
||||
|
||||
.has_ohci0 = 1,
|
||||
.has_ehci0 = 1,
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
@@ -1309,6 +1309,19 @@ static struct board_info __initdata boar
|
||||
@@ -1375,6 +1375,19 @@ static struct board_info __initdata boar
|
||||
},
|
||||
|
||||
.has_ohci0 = 1,
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||
@@ -777,6 +777,17 @@ static struct board_info __initdata boar
|
||||
@@ -843,6 +843,17 @@ static struct board_info __initdata boar
|
||||
.active_low = 1,
|
||||
},
|
||||
},
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
#include <linux/spi/spi.h>
|
||||
#include <linux/spi/spi_gpio.h>
|
||||
#include <linux/spi/74x164.h>
|
||||
@@ -3250,7 +3251,7 @@ static const struct board_info __initdat
|
||||
@@ -3317,7 +3318,7 @@ static const struct board_info __initdat
|
||||
* bcm4318 WLAN work
|
||||
*/
|
||||
#ifdef CONFIG_SSB_PCIHOST
|
||||
|
@ -17,7 +17,7 @@
|
|||
.revision = 0x02,
|
||||
.board_rev = 0x17,
|
||||
.country_code = 0x0,
|
||||
@@ -3270,6 +3271,7 @@ static struct ssb_sprom bcm63xx_sprom =
|
||||
@@ -3337,6 +3338,7 @@ static struct ssb_sprom bcm63xx_sprom =
|
||||
.boardflags_lo = 0x2848,
|
||||
.boardflags_hi = 0x0000,
|
||||
};
|
||||
|
|
Loading…
Reference in a new issue