automake: update to 1.11.6
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 39108
This commit is contained in:
parent
7340bc73f2
commit
0b4e8c4c36
4 changed files with 10 additions and 24 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2012 OpenWrt.org
|
# Copyright (C) 2006-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,11 +7,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=automake
|
PKG_NAME:=automake
|
||||||
PKG_VERSION:=1.11.3
|
PKG_VERSION:=1.11.6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/automake
|
PKG_SOURCE_URL:=@GNU/automake
|
||||||
PKG_MD5SUM:=3d72b2076eb4397ad5e9a2aace6357fd
|
PKG_MD5SUM:=cf4752287ad708f83bd3689da57a32c9
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -25,7 +25,7 @@ define Host/Install
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Clean
|
define Host/Clean
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/aclocal.in
|
--- a/aclocal.in
|
||||||
+++ b/aclocal.in
|
+++ b/aclocal.in
|
||||||
@@ -29,7 +29,8 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
|
@@ -27,7 +27,8 @@
|
||||||
|
|
||||||
BEGIN
|
BEGIN
|
||||||
{
|
{
|
||||||
|
@ -10,7 +10,7 @@
|
||||||
unshift @INC, (split '@PATH_SEPARATOR@', $perllibdir);
|
unshift @INC, (split '@PATH_SEPARATOR@', $perllibdir);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -61,8 +62,8 @@ $perl_threads = 0;
|
@@ -58,8 +59,8 @@
|
||||||
# ACLOCAL_PATH environment variable, and reset with the `--system-acdir'
|
# ACLOCAL_PATH environment variable, and reset with the `--system-acdir'
|
||||||
# option.
|
# option.
|
||||||
my @user_includes = ();
|
my @user_includes = ();
|
||||||
|
@ -23,7 +23,7 @@
|
||||||
my $install = 0;
|
my $install = 0;
|
||||||
--- a/automake.in
|
--- a/automake.in
|
||||||
+++ b/automake.in
|
+++ b/automake.in
|
||||||
@@ -31,7 +31,8 @@ package Language;
|
@@ -31,7 +31,8 @@
|
||||||
|
|
||||||
BEGIN
|
BEGIN
|
||||||
{
|
{
|
||||||
|
@ -35,7 +35,7 @@
|
||||||
# Override SHELL. This is required on DJGPP so that system() uses
|
# Override SHELL. This is required on DJGPP so that system() uses
|
||||||
--- a/lib/Automake/Config.in
|
--- a/lib/Automake/Config.in
|
||||||
+++ b/lib/Automake/Config.in
|
+++ b/lib/Automake/Config.in
|
||||||
@@ -31,7 +31,7 @@ our $APIVERSION = '@APIVERSION@';
|
@@ -31,7 +31,7 @@
|
||||||
our $PACKAGE = '@PACKAGE@';
|
our $PACKAGE = '@PACKAGE@';
|
||||||
our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
|
our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
|
||||||
our $VERSION = '@VERSION@';
|
our $VERSION = '@VERSION@';
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/aclocal.in
|
--- a/aclocal.in
|
||||||
+++ b/aclocal.in
|
+++ b/aclocal.in
|
||||||
@@ -314,6 +314,12 @@ sub scan_m4_dirs ($@)
|
@@ -327,6 +327,12 @@
|
||||||
|
|
||||||
foreach my $m4dir (@dirlist)
|
foreach my $m4dir (@dirlist)
|
||||||
{
|
{
|
||||||
|
@ -12,4 +12,4 @@
|
||||||
+
|
+
|
||||||
if (! opendir (DIR, $m4dir))
|
if (! opendir (DIR, $m4dir))
|
||||||
{
|
{
|
||||||
fatal "couldn't open directory `$m4dir': $!";
|
if ($install && $type == FT_USER && $first_user_m4dir)
|
||||||
|
|
|
@ -1,14 +0,0 @@
|
||||||
Index: automake-1.11.3/lib/am/python.am
|
|
||||||
===================================================================
|
|
||||||
--- automake-1.11.3.orig/lib/am/python.am 2012-01-31 12:41:18.000000000 +0100
|
|
||||||
+++ automake-1.11.3/lib/am/python.am 2012-06-07 16:42:53.488515898 +0200
|
|
||||||
@@ -23,8 +23,8 @@
|
|
||||||
## Installing. ##
|
|
||||||
## ------------ ##
|
|
||||||
|
|
||||||
-if %?INSTALL%
|
|
||||||
?FIRST?am__py_compile = PYTHON=$(PYTHON) $(SHELL) $(py_compile)
|
|
||||||
+if %?INSTALL%
|
|
||||||
am__installdirs += "$(DESTDIR)$(%NDIR%dir)"
|
|
||||||
.PHONY install-%EXEC?exec:data%-am: install-%DIR%PYTHON
|
|
||||||
install-%DIR%PYTHON: $(%DIR%_PYTHON)
|
|
Loading…
Reference in a new issue