add a patch to disable compile-time buffer checks enabled by default on Ubuntu 8.10 and later (closes: #4826)
SVN-Revision: 15119
This commit is contained in:
parent
7b6729e101
commit
0a2efdd06a
1 changed files with 11 additions and 0 deletions
11
target/linux/uml/patches/002-gcc4_unfortify_source.patch
Normal file
11
target/linux/uml/patches/002-gcc4_unfortify_source.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/arch/um/Makefile-i386
|
||||
+++ b/arch/um/Makefile-i386
|
||||
@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
|
||||
echo $(call cc-option,-fno-unit-at-a-time); \
|
||||
else echo $(call cc-option,-funit-at-a-time); fi ;)
|
||||
|
||||
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
|
||||
+# and later
|
||||
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|
||||
+
|
||||
KBUILD_CFLAGS += $(cflags-y)
|
Loading…
Reference in a new issue