kernel: update kernel to version 2.6.39.4
SVN-Revision: 28022
This commit is contained in:
parent
3e94ee9642
commit
09b1073f9b
12 changed files with 15 additions and 15 deletions
|
@ -26,8 +26,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),2.6.38.8)
|
||||
LINUX_KERNEL_MD5SUM:=d27b85795c6bc56b5a38d7d31bf1d724
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.39.2)
|
||||
LINUX_KERNEL_MD5SUM:=51be93d92028658ec93f68b79a378b17
|
||||
ifeq ($(LINUX_VERSION),2.6.39.4)
|
||||
LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.0.1)
|
||||
LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
|
|||
SUBTARGETS=au1500 au1550
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio
|
|||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz pci ext4
|
|||
CFLAGS:=-O2 -pipe -mtune=r5000 -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
|
|||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
if (!net_eq(dev_net(dev), sock_net(sk)))
|
||||
goto drop;
|
||||
|
||||
@@ -1523,6 +1526,7 @@ static int packet_create(struct net *net
|
||||
@@ -1524,6 +1527,7 @@ static int packet_create(struct net *net
|
||||
spin_lock_init(&po->bind_lock);
|
||||
mutex_init(&po->pg_vec_lock);
|
||||
po->prot_hook.func = packet_rcv;
|
||||
|
@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
|
||||
if (sock->type == SOCK_PACKET)
|
||||
po->prot_hook.func = packet_rcv_spkt;
|
||||
@@ -2091,6 +2095,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
@@ -2093,6 +2097,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
po->tp_tstamp = val;
|
||||
return 0;
|
||||
}
|
||||
|
@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|||
default:
|
||||
return -ENOPROTOOPT;
|
||||
}
|
||||
@@ -2148,6 +2162,13 @@ static int packet_getsockopt(struct sock
|
||||
@@ -2150,6 +2164,13 @@ static int packet_getsockopt(struct sock
|
||||
|
||||
data = &val;
|
||||
break;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/net/bridge/br_private.h
|
||||
+++ b/net/bridge/br_private.h
|
||||
@@ -132,6 +132,7 @@ struct net_bridge_port
|
||||
@@ -133,6 +133,7 @@ struct net_bridge_port
|
||||
|
||||
unsigned long flags;
|
||||
#define BR_HAIRPIN_MODE 0x00000001
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
|
|||
FEATURES:=squashfs jffs2
|
||||
DEFAULT_SUBTARGET:=danube
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.39.2
|
||||
LINUX_VERSION:=2.6.39.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
Loading…
Reference in a new issue