avr32: update to latest atmel sources
SVN-Revision: 11665
This commit is contained in:
parent
ed3aeb2031
commit
03b9d260c7
4 changed files with 1601 additions and 1057 deletions
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
|||
BOARD:=avr32
|
||||
BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
LINUX_VERSION:=2.6.25.9
|
||||
LINUX_VERSION:=2.6.25.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -128,12 +128,14 @@ CONFIG_MTD_PHYSMAP_START=0x80000000
|
|||
# CONFIG_NEED_NODE_MEMMAP_SIZE is not set
|
||||
# CONFIG_NMI_DEBUGGING is not set
|
||||
CONFIG_NO_HZ=y
|
||||
CONFIG_NR_QUICK=2
|
||||
# CONFIG_OWNERSHIP_TRACE is not set
|
||||
CONFIG_PERFORMANCE_COUNTERS=y
|
||||
CONFIG_PHYLIB=y
|
||||
CONFIG_PHYS_OFFSET=0x10000000
|
||||
CONFIG_PLATFORM_AT32AP=y
|
||||
# CONFIG_QSEMI_PHY is not set
|
||||
CONFIG_QUICKLIST=y
|
||||
# CONFIG_REALTEK_PHY is not set
|
||||
CONFIG_RTC_CLASS=m
|
||||
CONFIG_RTC_DRV_AT32AP700X=m
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,43 +0,0 @@
|
|||
--- a/drivers/mmc/host/atmel-mci.c
|
||||
+++ b/drivers/mmc/host/atmel-mci.c
|
||||
@@ -77,6 +77,7 @@ struct atmel_mci {
|
||||
struct clk *mck;
|
||||
struct platform_device *pdev;
|
||||
|
||||
+ int pending_stop;
|
||||
#ifdef CONFIG_DEBUG_FS
|
||||
struct dentry *debugfs_root;
|
||||
struct dentry *debugfs_regs;
|
||||
@@ -866,6 +867,12 @@ static void atmci_tasklet_func(unsigned long priv)
|
||||
data->bytes_xfered = data->blocks * data->blksz;
|
||||
atmci_data_complete(host, data);
|
||||
}
|
||||
+ /* See if there is a pending STOP which can be sent */
|
||||
+ if (host->pending_stop && mci_cmd_is_complete(host)) {
|
||||
+ host->pending_stop = 0;
|
||||
+ if (mrq->stop && !mci_set_stop_sent_is_completed(host))
|
||||
+ send_stop_cmd(host->mmc, mrq->data, 0);
|
||||
+ }
|
||||
}
|
||||
|
||||
static void atmci_cmd_interrupt(struct mmc_host *mmc, u32 status)
|
||||
@@ -918,9 +925,16 @@ static void atmci_xfer_complete(struct dma_request *_req)
|
||||
* drivers) or when interrupts are disabled for a long time.
|
||||
*/
|
||||
mci_set_dma_complete(host);
|
||||
- if (data->stop && mci_cmd_is_complete(host)
|
||||
- && !mci_set_stop_sent_is_completed(host))
|
||||
- send_stop_cmd(host->mmc, data, 0);
|
||||
+
|
||||
+ if (data->stop) {
|
||||
+ if (!mci_cmd_is_complete(host)) {
|
||||
+ /* Just remember a STOP must be sent */
|
||||
+ host->pending_stop = 1;
|
||||
+ } else if (!mci_set_stop_sent_is_completed(host)) {
|
||||
+ send_stop_cmd(host->mmc, data, 0);
|
||||
+ host->pending_stop = 0;
|
||||
+ }
|
||||
+ }
|
||||
|
||||
/*
|
||||
* Regardless of what the documentation says, we have to wait
|
Loading…
Reference in a new issue