Hopefully fix the PCI resource conflict and upgrade to .24.2
SVN-Revision: 10515
This commit is contained in:
parent
0f5d018d81
commit
03b451b3bd
2 changed files with 23 additions and 13 deletions
|
@ -11,7 +11,7 @@ BOARD:=au1000
|
|||
BOARDNAME:=AMD Alchemy AU1x00
|
||||
FEATURES:=jffs2 usb pci
|
||||
|
||||
LINUX_VERSION:=2.6.24
|
||||
LINUX_VERSION:=2.6.24.2
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += yamonenv
|
||||
|
|
|
@ -1,14 +1,24 @@
|
|||
--- linux-2.6.22.1.orig/include/asm-mips/mach-au1x00/au1000.h 2007-07-24 18:44:21.598778839 +0200
|
||||
+++ linux-2.6.22.1/include/asm-mips/mach-au1x00/au1000.h 2007-07-24 22:08:49.761901610 +0200
|
||||
@@ -1680,9 +1680,9 @@
|
||||
#define PCI_LAST_DEVFN (19<<3)
|
||||
diff --git a/arch/mips/au1000/common/pci.c b/arch/mips/au1000/common/pci.c
|
||||
index c93d7a6..6c25e6c 100644
|
||||
--- a/arch/mips/au1000/common/pci.c
|
||||
+++ b/arch/mips/au1000/common/pci.c
|
||||
@@ -39,15 +39,15 @@
|
||||
|
||||
#define IOPORT_RESOURCE_START 0x00001000 /* skip legacy probing */
|
||||
-#define IOPORT_RESOURCE_END 0xffffffff
|
||||
+#define IOPORT_RESOURCE_END 0xfffffffffULL
|
||||
#define IOMEM_RESOURCE_START 0x10000000
|
||||
-#define IOMEM_RESOURCE_END 0xffffffff
|
||||
+#define IOMEM_RESOURCE_END 0xfffffffffULL
|
||||
/* TBD */
|
||||
static struct resource pci_io_resource = {
|
||||
- .start = PCI_IO_START,
|
||||
- .end = PCI_IO_END,
|
||||
+ .start = (resource_size_t)PCI_IO_START,
|
||||
+ .end = (resource_size_t)PCI_IO_END,
|
||||
.name = "PCI IO space",
|
||||
.flags = IORESOURCE_IO
|
||||
};
|
||||
|
||||
/*
|
||||
* Borrowed from the PPC arch:
|
||||
static struct resource pci_mem_resource = {
|
||||
- .start = PCI_MEM_START,
|
||||
- .end = PCI_MEM_END,
|
||||
+ .start = (resource_size_t)PCI_MEM_START,
|
||||
+ .end = (resource_size_t)PCI_MEM_END,
|
||||
.name = "PCI memory space",
|
||||
.flags = IORESOURCE_MEM
|
||||
};
|
||||
|
|
Loading…
Reference in a new issue