139f99c058
Changes compared to GCC 7.x 001-revert_register_mode_search.patch dropped The underlying issue is described at the end of https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58139 It is fixed by the upstream commit:3fa2798aa8
020-PR-libstdc-81797-Add-.NOTPARALLEL-to-include-Makefil.patch dropped due to already upstream 100-PR-rtl-optimization-83496.patch dropped due to already upstream 910-mbsd_multi.patch modified to fix ambiguous overloaded inform() call error gcc/input.h header: define UNKNOWN_LOCATION ((source_location) 0) - inform (0, "someone does not honour COPTS correctly, passed %d times", - honour_copts); + inform (UNKNOWN_LOCATION, "someone does not honour COPTS correctly, passed %d times", + honour_copts); 940-no-clobber-stamp-bits.patch dropped due to fixed upstream by another way upstream commit:87b2d547f8
950-cpp_file_path_translation.patch dropped, Both -fmacro-prefix-map and -ffile-prefix-map are added to gcc 8.1.0, if I understand it correctly, we should use -fmacro-prefix-map usage: -fmacro-prefix-map=@var{old}=@var{new} upstream commit:859b51f836
-iremap exists as a flag for a long time, for backward compatibility, I think we should keep the variable name unchanged but change its value in rules.mk for gcc 8.x and higher. Compile and run tested on x86_64 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
20 lines
684 B
Diff
20 lines
684 B
Diff
Fix https://gcc.gnu.org/bugzilla/show_bug.cgi?id=84790.
|
|
MIPS16 functions have a static assembler prologue which clobbers
|
|
registers v0 and v1. Add these register clobbers to function call
|
|
instructions.
|
|
|
|
--- a/gcc/config/mips/mips.c
|
|
+++ b/gcc/config/mips/mips.c
|
|
@@ -3102,6 +3102,12 @@ mips_emit_call_insn (rtx pattern, rtx or
|
|
emit_insn (gen_update_got_version ());
|
|
}
|
|
|
|
+ if (TARGET_MIPS16 && TARGET_USE_GOT)
|
|
+ {
|
|
+ clobber_reg (&CALL_INSN_FUNCTION_USAGE (insn), MIPS16_PIC_TEMP);
|
|
+ clobber_reg (&CALL_INSN_FUNCTION_USAGE (insn), MIPS_PROLOGUE_TEMP (word_mode));
|
|
+ }
|
|
+
|
|
if (TARGET_MIPS16
|
|
&& TARGET_EXPLICIT_RELOCS
|
|
&& TARGET_CALL_CLOBBERED_GP)
|