openwrtv3/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
Imre Kaloz 50800bb207 resync 2.6.30/2.6.31 patches
SVN-Revision: 18270
2009-11-02 09:54:06 +00:00

25 lines
534 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -788,6 +788,8 @@ config CRYPTO_ANSI_CPRNG
for cryptographic modules. Uses the Algorithm specified in
ANSI X9.31 A.2.4
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o