openwrtv3/package/firmware/rcw/patches/0001-makefile-generate-byte_swap-rcw-for-ls1046ardb.patch
Yangbo Lu 2e2203ff72 layerscape: update packages with LSDK git trees
NXP Layerscape LSDK had set up its own open source web site
and github for release.

https://lsdk.github.io
https://github.com/qoriq-open-source

This patch is to update rcw/fman_ucode/u-boot packages with LSDK
git trees. Also add some patches of packages to support LEDE.
Since ARMv8 32-bit u-boot images are same with ARMv8 64-bit images
but 64-bit toolchain couldn't be used for 32-bit targets, we still
use a private tree for ARMv8 32-bit u-boot images. This is in plan
to move this private tree to NXP Layerscape github.

Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
2017-10-07 23:13:22 +02:00

26 lines
766 B
Diff

From 6836519a638a0c30ef3d2137c248a1a9f1befbc4 Mon Sep 17 00:00:00 2001
From: Yangbo Lu <yangbo.lu@nxp.com>
Date: Tue, 4 Jul 2017 20:25:40 +0800
Subject: [PATCH] makefile: generate byte_swap rcw for ls1046ardb
Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
---
Makefile | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Makefile b/Makefile
index fb55c8b..ab1b573 100644
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,8 @@ all install clean:
@for board in $(BOARDS); do \
$(MAKE) -C $$board $@ DESTDIR=$(DESTDIR)/$$board; \
done
+ tclsh ./tools/byte_swap.tcl ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot.bin \
+ ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot_swap.bin 8
release: $(foreach board,$(BOARDS),rcw-$(board)-$(VER).tar.gz)
--
2.7.4