52c17bff3c
This adds kernel support for the Pistachio SoC and the Marduk (Ci40) board which uses it. Much of the code for Pistachio has been upstreamed however some patches are still required to boot from the Marduk board: * spi bug fixes * dma bug fixes * pistachio internal clock tree bug fixes * spi-nand implementation * dts based mtd device naming scheme * dts backports and bug fixes Signed-off-by: Abhijit Mahajani <Abhijit.Mahajani@imgtec.com> Signed-off-by: Francois Berder <francois.berder@imgtec.com> Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com>
27 lines
774 B
Diff
27 lines
774 B
Diff
From a907fdeb3f057e4c4b3960ca864b460dc1fa687a Mon Sep 17 00:00:00 2001
|
|
From: Ian Pozella <Ian.Pozella@imgtec.com>
|
|
Date: Thu, 16 Feb 2017 10:42:22 +0000
|
|
Subject: MIPS: DTS: add img directory to Makefile
|
|
|
|
An img directory exists for the Pistchio Soc but the directory
|
|
itself isn't in the dts Makefile meaning the dtbs never get built.
|
|
|
|
Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com>
|
|
---
|
|
arch/mips/boot/dts/Makefile | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/arch/mips/boot/dts/Makefile b/arch/mips/boot/dts/Makefile
|
|
index fc7a0a9..b9db492 100644
|
|
--- a/arch/mips/boot/dts/Makefile
|
|
+++ b/arch/mips/boot/dts/Makefile
|
|
@@ -1,5 +1,6 @@
|
|
dts-dirs += brcm
|
|
dts-dirs += cavium-octeon
|
|
+dts-dirs += img
|
|
dts-dirs += ingenic
|
|
dts-dirs += lantiq
|
|
dts-dirs += mti
|
|
--
|
|
2.7.4
|
|
|