987f14ab23
The package Makefile was based on work at link [1] with the following changes 1. Disable minidebuginfo support thus no dependency on liblzma 2. Add 2 patches for building against musl-libc and building with mips16 enabled 3. Add LICENSE and DEPENDS info, etc. [1] https://github.com/rpi-openwrt/rpi-packages/tree/master/libs/libunwind Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
22 lines
679 B
Diff
22 lines
679 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -36,7 +36,7 @@
|
|
|
|
nodist_include_HEADERS = include/libunwind-common.h
|
|
|
|
-SUBDIRS = src tests doc
|
|
+SUBDIRS = src doc
|
|
|
|
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
|
|
include/compiler.h include/libunwind_i.h include/mempool.h \
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -313,7 +313,7 @@
|
|
$(am__append_7) $(am__append_8) $(am__append_9) \
|
|
$(am__append_10)
|
|
nodist_include_HEADERS = include/libunwind-common.h
|
|
-SUBDIRS = src tests doc
|
|
+SUBDIRS = src doc
|
|
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
|
|
include/compiler.h include/libunwind_i.h include/mempool.h \
|
|
include/remote.h \
|